Unbricking Archer C6/A6 v3.x

Continuing the discussion from here.

You will need a UART 3.3V USB adapter, open the device and connect the UART to a PC and to it.

The UART pinout and some more instructions you can find here. I was able to make a successful connection using a three pin connector without soldering.

After that, you will need to run a serial terminal on the PC (Putty for example) connected to the UART serial port @115200 bps.

Turn on your device, while it is booting in the serial console press "x". This will activate the web recovery. Then open a browser at 192.168.0.1 and upload the factory firmware. Wait a few minutes and the router will be recovered with the factory firmware. I have not tried but it may be possible to recover directly with the OpenWRT factory image.

1 Like

@subhranil, in fact the ethernet ports are dead.

I believe (just an hypothesis) the web recovery is not automatically activated because uboot finds a valid kernel and tries to load it. And what happens is what it seems kernel gets stuck for some reason and does not report any error.

That's why the device ends up bricked without any activity in the ethernet ports because kernel did not load and web recovery is not activated. TFTP is also not an option.

Therefore the only option is to attach a UART and activate web recovery manually via serial console before kernel load.

1 Like

Yeah, the theory sounds about right.

Opened the device, and ordered this UART converter, can you confirm if this should work?

That should work, I have a similar one. @dsouza Usually one does not need to connect the 3.3V pin. Just ground, Tx and Rx. I've never connected 3.3V.

2 Likes

That's correct. What I was referring is that some UART adapters have a jumper to configure 3.3V or 5V as the signal/TTL level (see below). It needs to be 3.3V otherwise if you use 5V it may/will damage your router.

The wires that need to be connected to the router are only three: GND, TXD, RXD.

2 Likes

Should I be able to check with multimeter what the adapter is already providing?

You should be good as is. Check the spec page of your Amazon link, it says 3.3V.

In other news, the offending commit has been located and reverted. I'd wait for new master images from the buildbots before trying to flash them (you can of course build your own).

If you measure between GND and RX you should see the nominal voltage. Between GND and RX you will see ~50% as it is pulling high and low in case anything is listening.

Important note: usually the pins are labeled from the device perspective. So the TXD (transmit data) pin of the adapter must be connected to the RXD (receive data) on the router, and vice-versa.

Below are more details for reference:

https://www.circuitbasics.com/how-to-set-up-uart-communication-for-arduino/

Recovered successfully and went back to 21.02.1 for now. Thanks a lot everyone.

Have you tried 192.168.0.1? This router has a recovery web page. Otherwise you may need to open it and use an UART to activate the recovery page as described in this topic.

linking to my post there,...if the lights are solid on....ur router is recoverable without UART.

2 Likes

You are awesome! You saved me a lot of time and won a burger and :beer:.

1 Like

:relaxed::relaxed::relaxed:

Glad it helped!

1 Like

Sorry for replying late but thanks a lot for this!

1 Like

Can you explain how you connected it without soldering?
I have this (RPi) serial adapter and also a Pine64 woodpecker serial adapter, but I assume I'd need pins (like RPi's GPIO pins) to connect them, but all I see are the holes.
I have no soldering experience, so if I can do without that, that would be great.

I used a 3 pin header (like the one below, but cut with 3 pins only). I plugged the shorter side (without soldering) to the router board, and to the other side the serial wiring.

2 Likes

Thanks!
Do you know if it's possible to attach an UART (with those pins) and then close the enclosure again?

I don't think so. The enclosure of this device is pretty tight. So unless you drill a hole for the UART wires, I do not believe it will be possible to close the case with the UART wires attached.

1 Like

Thanks for that very useful info, much appreciated :slight_smile:
The Pine64 UART adapter does have individual wires, which might fit in the existing holes, but it looks like those holes are below the board, which means the chances of success are quite low.
I thought it may be an interesting learning experience, but I'm not willing to damage things for that.
Cheers :+1:

1 Like