TP-Link Archer C50 (EU) V6.0 - 5 GHz interface not present

I'm mainly wondering how much does this data influence compared to for instance adjusting the antennas or rotating the device, generally the environment it's put in. Also there are devices that simply use standard miniPCIe cards which would not be so specifically calibrated. Are those inherently inferior?

dear expert @jschwart , I'm trying to rebuild the image of this binary file. could you please share the configuration for this?

Warmly thank you so much~

I'm not sure what you're trying to rebuild. @xristos' or my image? I only included luci in the prior images, no other special configuration.

thank you so much for your feedback, I tested and re-produced with your source completely, however when I ported that into the target router all LED off and it seems the router is not working. I also tried with your binary image, it is also have the same result.

In addition, the pre-built image before you recommended to me seem work for me in this reply thread, I think @xristos image, so it would be glad if anyone in forum can share to me the config file, thank you so much~

1 Like

hi expert @Marssl, your firmware works well in my target Tp-Link V6 with flash Windbond device. However, when I port this firmware in Tp-link V6 with flash XMC, it seems not working. Based on your expertise, could you please recommend some solutions?
Thank you so much!


So i used the sysupgrade.bin from this link to update my router, and it appears i no longer have luci and zerotier on my router.

i had to make my own build at the time with those packages.

i did tick the option to keep installed packages and settings.
strangely my devices still connect to the wifi and internet

what do you think is the best option for me to get those packages back?

I guess rebuilding from OpenWRT master would be the easiest. It seems these packages are not part of the supplementary files listed on that page.

Please it would appear I have forgotten how to put this device into tftp recovery mode

I can use the tftp get command to pull from the router, but I keep getting server permission error for flashing the router

Kindly remind me.

We have no WPS led, so I am unsure holding the reset button whilst booting is doing the job

Would actually prefer to go back to stock but apparently you can't flash that through OpenWRT upgrade

The procedure is described on the wiki page I think?

I'll share my own experience. Starting with a stock firmware on the Archer C50 v6 EU, I tried installing one of the snapshots through TP-Link's online firmware upload interface. The first time I did it, nothing changed. The second time, I believe I got disconnected (I did both through Wi-Fi like an idiot). Well, that lead to a brick. Maybe it is because I didn't follow these instructions here:

I spent the whole night trying to fix it, fearing I had bricked the boot-loader and that I'd have to get a £50 JTAG cable or something. I had some spare Raspberry Pis and I set up a TFTP server on one, using tftp-hpa and these instructions.

I had set the IP address to, connected the router and the Pi through LAN1 using a CCA Ethernet patch cable, and monitoring using tcpdump -ni eth0, I was seeing who-has requests for everytime I did the reset process (hold down the reset button, then power on and keep holding it), though that may just be some DHCP/ARP protocol thing. I couldn't see any kind of request specifically for tftp-hpa.service, so I feared TFTP recovery was out of the window.

I then tried it the next day on a Windows 10 machine using Ttfpd64, and it worked perfectly. So it's not a boot-loader brick! I had flashed the tp_recovery.bin that was for v4:

and I'm back to a nearly-perfect point. The problem is precisely that the firmware is for v4, and that's now what my router thinks it is. It won't let me flash the v6 official image, like he describes, instead giving me an error code 4503 (The uploaded file was not accepted by the device).

Apparently he had success using TFTP, so I set that up again, using the MediaFire link he created here:

and it does flash over. Only now, the device is not discoverable or reachable. Suspecting maybe he created an OpenWRT image, I tested ssh root@, which doesn't work. I tested reaching the TP-Link portal, and the one I guess OpenWRT uses, Neither work. @xristos, if you have anymore information on how you achieved this, it'd be much appreciated.

So I've re-flashed the v4 firmware. I'm not extremely fussed about it, but I would like if anyone has any guidance for bringing it back to the official v6 firmware, which I can stay at until v6 support is proper. Maybe I'll get my own feet wet in the semester holidays.

I'm assuming, reading about the talk around the split-uboot design and that my TFTP recovery worked, that my factory-uboot (at 0x00000000) is untouched, and that a perfect official reinstall is still possible. Hopefully I haven't lost any calibration data or functionality permanently.

As long as you dont erase the flash with a SPI-programmer like I did, it should all be recoverable.

Nah, I have no hardware tools nor have I opened it up. Just Ethernet/Wi-Fi flashes. I'm unsure though of what TP-Link's own re-flashing process does, and what it rewrites. I think it's a good assumption though that it doesn't overwrite the factory-uboot.

Well, apparently it does overwrite it, at least whe you do it via tftp. I think someone mentioned that somewhere.
Thats why I had to flash the chip directly in the first place. I just was stupid enough to leave "erase chip" checked lol

RIght, but you flashed via OpenWRT's LuCI interface, right? I have exclusively used TP-Link's flashing process, and the TFTP process that TP-Link uses.

Yeah, I tried flashing back from LuCI which soft-"bricked" it. Then I tried via TFTP which did further "damage" and my last try with the spi prog completely f*cked it up.

Right. I didn't know TP-Link's TFTP could do that :grimacing:

There is a message in multiple spots:

WARNING: Do NOT flash the tplink_C50-v[4,6]-squashfs-sysupgrade.bin from the “Downloads” section to the C50 v4/v5/v6 via the TP-Link firmware's web GUI. It will brick the router!

Do you think it would be helpful to still add this elsewhere? It seems unfortunate that people miss it.

Generally support is merged to master and seems to be in good shape. It is important to read the instructions in the commit message.

If you're running the a stock v4 firmware, you can probably prepend a v4 OEM bootloader to the OpenWRT v6 image to get it accepted by the TP-Link GUI and go to the v6 image for OpenWRT. I guess if you prepare an official image for TFTP recovery according to the instructions, you could also get that to work. Then you would be able to go to OpenWRT with the official v6 version of the bootloader. I have no experience with TFTP recovery myself though.

Yeah I may have missed it, I don't remember seeing it. Though that may not reflect on anyone but me xD

I'll get to those suggestions. Splicing together a v6 TP-Link with a v6 OpenWRT image and flashing through TFTP seems to not work -- Looking at Wireshark, Router Advertisements get sent from it, but when SSHing, even though ARP works and the query for gives back the MAC of the router, TCP retransmissions are all that happens. Edit: pinging doesn't work either for some reason, so it might just be a deeper config issue.

So I'll try the v4 suggestion.

Which instructions did you follow? Did you also prepend the extra zeros?

I'm curious how that will work out! My suspicion if that if there is a proper bootloader, it needs to match the version of the running firmware for it to accept it. Somehow an OpenWRT sysupgrade is always passing TP-Link's checks despite that it should not.

None the less, any suggestion you have to improve would be useful. There have been multiple posts that people missed this, so you're not alone :wink:

OK so update. It's a Linux thing again. It works on Windows 10, I just tried it with the v6 TP-Link + v6 OpenWRT firmware. I get the OpenWRT ASCII art. So I'm pretty sure it's just a config issue on my Raspberry Pi. I'll get that sorted.

The instructions in this commit message -- they're really good instructions.

Looking now for the message, I don't see it specifically for the v6. I see it for the v3, v4 and v5, though. Though you may expect a reasonable person to be able to extrapolate, I guess it's possible to make it more explicit.

Currently, [OpenWrt Wiki] TP-Link Archer C50 says:

The Archer C50 v6 CA/EU and RU versions are supported in the main branch, but not yet in a release. Check the nightly builds for images.

There is a link to this discussion forum at the bottom of the page, but maybe if it was in that above message. Maybe if it said something like: ... ?

The Archer C50 v6 CA/EU and RU versions are supported in the main branch, but not yet in a release. Check the nightly builds for images. See this discussion for information and follow the instructions in this commit message carefully. Do NOT flash the .sysupgrade file as-is or you may brick the router.