Restoring Stock Firmware for Archer C50 V4

Hello, After I installed OpenWRT 19.07.02 on TP Link Archer C50 V4 I experienced the common 2.4 GHz Wifi range issue so I decided to revert to stock firmware.

I tried flashing the stock image through web interface and TFTP directly and it bricked the router (Only Power or Power + Lock led on).

I have also tried stripping the first 512 bytes before flashing it and it didn't work either.

I found what seemed to be a solution by gurangax in this post : Archer C50 AC1200 V4 bricked

He suggested inserting 0x30000 dummy bytes at offset 0 and removing the last 0x30000 bytes at the end of the file but I don't know how to do that using dd commands.

If you could transform these to dd commands I would be so much thankful.

I have the edited firmware, which worked for my device:

https://mega.nz/file/k5di1IyC#x1MN4skqGTSYrR6t6ejZ3GBdV3QhG667iQXKE2WCnro

kind regards,
manuel

1 Like

Thank you so much. This one worked for me too. But I couldn't upgrade to the latest firmware normally using web interface, it made all leds blink rapidly.

If you could please share how you edited this one so I can edit future stock firmware images and upgrade to it. I would be thankful.

Regards.

I've used HxD Editor in Windows.

1 Like

Thanks for replying. I installed the app and tried to insert 0x30000 bytes containing (00) at the beginning of the file but I couldn't use it to remove that same number from the end of the file. I see select block in the menus but couldn't do it properly.

If you could please help me with this step, I would be so much thankful.

This is the latest stock image that I tried to edit by the way:
https://static.tp-link.com/2019/201903/20190315/Archer%20C50(EU)_V4_190125.zip

you check the size in the editor of the file subtract 30000 and the result is the start offset of the selection, but if you could not figure this out, please why you want to edit a newer firmware, I think of you flashed mine, you should be able to flash the default tp-link firmwares via the web interface.

1 Like

It finally worked! I did it by doing all the steps using HxD editor and not doing any of them using Linux or dd commands.

I selected then removed the first 0x200 bytes, inserted 0x30000 bytes at the beginning containing zeros, and selected then deleted 0x30000 bytes of FFs at the end of the file and flashed it using TFTP.

Thanks for your advice on using this application, I hope we can install a stable version of OpenWRT on our devices soon!

I have uploaded the edited stock file for the above version (Build 190125) for future reference:

2 Likes

Would the same fix work on the Archer C6?

Why does this work by the way?

If you tried the original stock firmware and also tried stripping 512 bytes from its beginning and it didn't work, this might work for you.

I think this works because C50 v4 has dual u-boot built in and this is some workaround to make the image fit manually, but I don't know exactly why it works.

Why you want to edit the new file of you could flash my recovery bin? You should be able to flash the firmware via the web interface.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.