TP-Link Archer C50 (EU) V6.0 - 5 GHz interface not present

I'm sorry if my questions were not clear enough. I can imagine it can be quite nerving when you have such a situation. I was mainly confused where you were finding the instructions that you were following.

Great that you have a running firmware again!! At this point having the carefully crafted firmware along with the bootloader from an ODM/stock firmware should allow flashing to OpenWRT with working radio I guess.

Let's make sure we capture as much as possible from your experience and document! Please share suggestions on what you believe could be helpful and what we could add to the documentation. Thank you so much for sharing everything!

can you give me the instructions so i wont mess up again ?
im on windows and every command is for linux os ,i would prefer not to install ubuntu cmd just for that

you probably referring to

dd if=/dev/zero of=tp_recovery.bin bs=196608 count=1
dd if=tpl.bin of=tmp.bin bs=131584 count=1
dd if=tmp.bin of=boot.bin bs=512 skip=1
cat boot.bin >> tp_recovery.bin
cat owrt.bin >> tp_recovery.bin

is there an alternative to dd for win?

The main instruction is in the commit message over here:

It was mostly copied from the v4 commit message. If you have any feedback on how it could be improved, that would be great.

Note that there seem to be different instructions to generate the file used for flashing through the stock firmware and the instructions to generate the file for flashing through the ODM firmware interface. The commands you are showing are related to the TFTP recovery variant if I'm correct.
The one you would need to flash through the ODM firmware would be:

TP-Link image:             tpl.bin
OpenWRT sysupgrade image:  owrt.bin

 > dd if=tpl.bin of=boot.bin bs=131584 count=1
 > cat owrt.bin >> boot.bin

This is the one I used myself to create the initial OpenWRT firmware to flash.

My knowledge is very limited regarding Windows. There might be similar tools to dd for Windows, but if they do something slightly differently for this particular situation, then I'm afraid you may run into a "brick" again. You will want to be sure you follow these instructions very precisely as it turns out that TP-Link's software does not really do any sanity checks on whatever image is provided before starting the flashing procedure.

i guess i will install ubuntu lts and check ,
dl official latest v6 from tp link web
dl the ramips
name them tpl/owrt respectively and run

 > dd if=tpl.bin of=boot.bin bs=131584 count=1
 > cat owrt.bin >> boot.bin

then flash through tftp ? i remember reading flashing through routers page will brick it

Running it from a live USB flash drive should also work.

I flashed through the routers web interface with the file generated that way (just the prepended bootloader) and it worked fine.

The instruction for TFTP is the one you gave I think. (With the extra zeros.)

Once you have OpenWRT itself running, you can use the regular sysupgrade image, so creating the special image with prepended bootloader is just a one-time thing.

but when i try to flash though i get

Error code: 4503

The uploaded file was not accepted by the device.

i manage to flash it through tftp though and it works so far

this tp_recovery is ready to use with tftp (for our windows folks)

1 Like

That's interesting. Maybe the v4 firmware you used recognized the bootloader from the v6 firmware and rejected explicitly. It would seem somewhat odd though that it does recognize firmwares meant for other models, but not firmwares that would not work at all.

Great that you got it working and thank you for posting your version!

yeah no idea why but all the v6 didnt work for recovery,i tried v4 and then it worked,i logged in the default and the hardware was saying v4,lost the ap then i tried flashing through browser the v6 of ,no luck.then i created the tp_recovery with v6 as instructed in the provided link and i got luci up and running,so far so good .i have a question .i am cyrrently using the router as a receiver ,wall->ispRouter->wifi---wifi(c50)->pc. is it possible to strip the broadcast bssid to gain some room ?i only care to receive wifi not send out.changes on the router sometimes make it "freeze" the luci counts down till 0 no changes made and i have to power it the loader?is it the small space? no idea.

Sure you can disable/delete that without issue. I don't think it's even enabled out of the box, but there is the disabled default stuff which you can just remove if you don't need it.

I had the wired switch crash once. Only WiFi was working then and I could find the related stack trace in the kernel messages: TP-Link Archer C50 (EU) V6.0 - 5 GHz interface not present - #74 by jschwart

Maybe you are seeing that too? Of course for things like this it can also be helpful to use the link local address to reach the device as it never changes while you might be making configuration changes to its other addresses.

i cant tell if its the same as i didnt look at it,oute of the box the broadcasting ssids (ability to broadcast you connection through wifi) is present and can be enabled or disabled ,what i am asking is to remove that from the firmware to gain some it doable?is it worth it or its a few kbs so no point doing so,changes made after flashing wont stay/uninstall,it will be present in the rom

I think that should be possible. But then you do really need to set up your own build environment. At the make menuconfig stage you could probably uncheck the AP related items. I have no idea how much space that would give you.

I've bricked my router eeprom but I've got the full 8mb backup...Do you have any idea on how to unlock Winbond W25Q64JVSIQ eeprom from ch341a or any flasher to my TPlink archer c50 v6...

I'm sorry. I never opened up this router and I have no experience at all in this regard. I would suggest looking at similar router models like the earlier Archer C50s and other models listed in target/linux/ramips/image/

I would expect not much information to be available for particularly the C50 v6, but hopefully some of the other TP-Link routers listed there are similar enough and there might be one with information available on this topic.

Are you really sure that TFTP recovery is not possible anymore?

1 Like

Attention all!! Some more adjustments were necessary and these need to be tested. I am in another country than my Archer C50 v6 right now, so I cannot test myself. I created new images and put them in the prior locations:

It would be great if people could test and confirm everything works with these new images. Please note Hauke's message in the PR:

Could someone please test this device and check if the 5GHz Wifi works fine (more than 10MbIt/s over 5 meters).

You may leave a message directly in the PR or here if you do not have a GitHub account. Many thanks in advance!!

Hi Marssl!

I have the same router TP-Link, but the flash type is XMC, unfortunately, I cannot port this firmware in the router. Could you please advise me on what I should do about this?

the question I placed in this link

warmly thank you so much

Could you share more about which firmware image you used? Did you also try the most recent version I provided?

Are you sure that differences are related to the flash memory? What model(s) do you have exactly?

Dear expert!

I confirm that I use the latest version of the binary file you sent.
The binary file I used from this link:

That binary file working well in TP-Link archer C50 V6 with IC flash Windbond

But with TP-Link archer C50 V6 with flash XMC it is the issue with LED blinking and not running.

based on your expertise, could you please advise to me?
Thank you so much

What is the md5sum?

Those are binaries from 2021 and not mine.

Are there any differences between these two models that you can identify apart from what you see inside?

I would suggest reading the topic more carefully or involve somebody that might be more comfortable. There are multiple links to newer binaries including my last post before you joined the conversation. Note that if you do not follow instructions carefully, you can brick your device.

Dear expert!

Thank you for your question, can I answer you as below:

  1. What is the md5sum?
    => I used file: owrt21.02.0rc4-experimental-c50-v6-syssupgrade.bin => This is working well in Tp-Link with IC flash Winbond
    But failed with IC flash XMC

  2. Are there any differences between these two models that you can identify apart from what you see inside?
    => As I check it seems only the IC flash chip is different.

  3. I'm looking around in the OpenWrt forum about this problem, if you have any ideas it will be more appreciated.

Thank you so much~

I would suggest trying a newer version. The image you used is already over 2 years old. Maybe flash support in OpenWRT was improved during this time.