TP-Link-archer-c20-v4 usb drives support

Hello there!I would like to ask you to add usb support to this model, albeit through hardware and software modifications.
There is an opportunity to test, but in a limited amount - the router is the main one and keeps the system.

I'm confused. How can we help you with hardware on your individual device, that would need a modification to do what you desire?

:spiral_notepad: BTW - OpenWrt doesn't manufacture hardware.

Software in OpenWrt already exists to do this - see:

I already made all the necessary modifications, and before that, on another firmware (padavan), the usb port was detected and worked (I was able to send packages to a USB flash drive). I did not manage to start usb on openwrt. When I tried to run lsusb it gave me an error:
libusb something :-99
And I also looked at the page of my device, and there is no usb support there yet, and decided to write here

If you modify your hardware, you have to compile OpenWrt yourself.
Official OpenWrt does not care about user modified hardware.

1 Like

This is not a modification in that radical sense. The chip on board can work with usb, but the manufacturers did not bring it to the usb port. I found the necessary contacts and brought them to the usb connector (which I had previously inserted into the case on the side) and connected the power step down converter.
I will try to build a firmware with usb support, there should be enough space

Did you already test by installing the available packages on official firmware?

I don't quite understand what you mean. (wrong link)

The link was correct.

If you've already successfully made the hardware modifications, feel free to install the requisite software to do what you desire.

I already install all needed packets, but it didnt work

  • Are you sure?
  • If that's the case, what exactly are you asking OpenWrt to do?
  • Additionally, you should verify your soldiering and connections

1.2)Add support to my device(specific revision)
2)I check it now.But libusb -99 error still where and idk that to do with her.

This has been explained - there's nothing to "add":

  • You need to do soldiering (you stated you did this)
  • You need to install the correct software packages - this is required for every OpenWrt device to enable USB (you stated you did this)

Are you saying there's missing packages or something further needed - if so, can you explain exactly what it is?

Can you provide more information on what this statement means?

Is this from a log?

Idk what to provide
Not, that returned from:

root@OpenWrt:~# lsusb
unable to initialize libusb: -99

Hello i am also trying to do the mod ,, any progress in your one

The needed information is in the thread you created: