TP-Link Archer A6 v2 (EU, RU) support

Hello,

I bought this device and trying to install openwrt. Openwrt wiki says that this device is the same as C6 and suggest me to use firmware for C6. But I am not able to flash my device with this firmware. I see tftp sending firmware to router but router reboots with factory firmware. I tried old and latest firmware. Someone tried to use openwrt on this device?

1 Like

Bump, anyone?

Hi,
I have the same issue.
Have tried old and the latest openwrt firmware (19.07.0 - snapshot), with and without "switch" (my old WRT54GL and cisco switch), tried different periods of releasing the reset button, I have tried to update the stock firmware from 1.1.0 to 1.2.1, tried different machines (3 x Linux, 2 x Windows), different TFTP servers (atftp, tftp-hpa, dnsmasq, tftp64) none of it works.
As you mentioned, router actually detects the TFTP server. Tcpdump shows some sort of timeout:

21:15:38.207414 IP (tos 0x0, ttl 255, id 0, offset 0, flags [DF], proto UDP (17), length 73)
192.168.0.86.1469 > 192.168.0.66.69: [no cksum]  45 RRQ "ArcherC6v2_tp_recovery.bin" octet timeout 5

I also see some "link down | link up" entries in the log, so to me it seems like the router drops the connection.
I have also tried to flash the stock firmware via tftp, and the same thing happens, so I think there must be something wrong with the router itself. I don't think it's some sort of validation issue, since firmware is never downloaded.

Does anyone know of a way to connect (telnet, ssh...) to router and see boot logs?

Do you have direct connect to router or over switch?

The advice to put a switch between your computer and the router which is to be recovered only applies to unmanaged switches, because it's meant to avoid link training on your computer (the link (to the switch) always stays up - and an unmanaged switch is 'stupid' enough not to require link training of its own). Using a managed switch or another router however usually involves link training as well.

Hi again,
So I've spent a few more hours working on the issue. I have tried to compile the latest master, still not working.
I don't have a dumb switch, so I used the Linksys WRT54GL to simulate it. I found out that router connects to my TFTP server even without it and have verified with wireshark that firmware is sent (all chunks) and all of them receive confirmation. So it seems that the router actually receives the full firmware image.
The funny thing I found out today: If I go to 192.168.0.1/cgi-bin/luci the page says:

No root node was registered, this usually happens if no module was installed.
Install luci-mod-admin-full and retry. If the module is already installed, try removing the /tmp/luci-indexcache file.

Which I found in the openwrt/luci. Unless OEM firmware somehow included this (which I doubt), then at least some part of the openwrt must have been installed.
Still, SSH-ing doesn't work (I have tried as root/, root/, admin/ and admin/admin combinations), which results in:
exec request failed on channel 0
Did I somehow brick the router? If I go to router's IP it shows OEM's page which works fine.
Anything else I could try?

Are you sure you have A6 v2 device for EU/RU market?

It says so on the sticker at the bottom. Model: Archer A6(EU) Ver: 2.0
And I bought it in Europe, so I would imagine it's EU version, right?

Right, so we are in the same boat. For some reason this device is not supported

1 Like

So I managed to install by adding the Archer A6 product name to:
tools/firmware-utils/src/tplink-safeloader.c:891

.id     = "ARCHER-C6-V2",
.vendor = "",
.support_list =
    "SupportList:\r\n"
    "{product_name:Archer C6,product_ver:2.0.0,special_id:45550000}\r\n"
    "{product_name:Archer A6,product_ver:2.0.0,special_id:45550000}\r\n"
    "{product_name:Archer C6,product_ver:2.0.0,special_id:52550000}\r\n"
    "{product_name:Archer C6,product_ver:2.0.0,special_id:4A500000}\r\n",

The line I added is for EU version (4555), I guess the other versions should work in the same way.
Then just compiled and flashed via TFTP normally.
See if it helps.

I have noticed different partitions addresses in memory looking at stock C6 and A6 bin files. Is it OK just to add A6 line to tplink-safeloader.c ?

Works perfect for me. I think there are different addresses for US version of the A6/C6.