Asus AC1750u same spec as AC65P and AC85P


It look like Asus AC1750u router has same spec as AC65P and AC85P.
Here is info: it has the same FCC ID and hardware:

Both AC65P and AC85P have already snapshots: AC65P from version 21.02-SNAPSHOT
and AC85P from 21.02.0-rc1
Link to wiki:
I've tried to install all available versions (7 bins) but with no success.
For AC1750u method with TFTP is not working, set local ip to but there's no sign of connection via tftpd. Installation via SSH working but after bin placed in /tmp/ set to flash and reboot router enter to boot loop. Asus Firmware Restoration helps.
Maybe there is need to add product name on top and OpenWRT will start to install properly on AC1750u like on TP-LINK Archer A6: TP-Link Archer A6 v2 (EU, RU) support.
Please help if you can.


Firewall is usually to blame when there's no life sign from the TFTP.

Firewall was off.

Then you'll need serial console access to investigate further..

When gateway set to TFTP method is working. But after that still bootloop.

Restore of ASUS AC1750U is possible with all original firmware versions from ASUS for model AC65P.

So there are 3 possible ways to upload firmware via TFTP, SSH and ASUS Firmware Restoration but still no success with OpenWrt images after that.
Is anyone can confirm that images for AC65P/AC85P has got coded of possible versions and adding new one will help? It must be something simple.

How could we, it's not supported, hence unknown, SW wise.
You are however probably correct - Asus AC1750u same spec as AC65P and AC85P - #4 by frollic

Hi to all, i can confirm that openwrt-21.02.1-ramips-mt7621-asus_rt-ac65p-squashfs-factory.bin is installed to RT-AC1750U via SSH and works perfect.

1 Like