TL-MR6400 v5 back to stock firmware bricked

Please help me.
Sorry to open the same topic
Tftpd64 I do the update After that not booting (all led blinking)
I reserved it https: //

But I can not do this operation : prepare the file using the command dd if=”original.bin” of=”tp_recover.bin” skip=1 bs=512 cout=16000 This is an original site, you can TL-MR6400 (EU) _V5_201207 make this change and send it to me at mail

Should be count

The poster in the thread you linked to (and copy/pasted the command) spelled it incorrectly.

Can you tell me what the problem is?

Pointing out the obvious:

cout != count

WRONG: cout=
RIGHT: count=

Oh, Thanks for the friendly reply. I heard that.

I just could not understand how to do this operation, can you tell me? Do I need to make any changes to the firmware? I just could not grasp the principle

Am I doing it right?

Or what am I doing wrong?

Exactly what it says, there's no source file called original.bin.

Try man dd.

And you don't need sudo to run dd.

Thanks Bro
But, the same problem

What happens if you leave out the "?

e.g. if=original.bin instead of if="original.bin"

Well, you still haven't a source file called original.bin.

Or what tmomas said ,)

From the link you posted...

Download the firmware from TP-Link website , unzip the file and rename the TL-MR6400v5_1.1.0_0.9.1_up_boot(200511)_2020-05-11_12.28.03.bin file into original.bin

I do so, but the mistake is in the picture above

ok oh i think it's done
I will clarify now

Thank you friends, help me a lot
If you come to Georgia, visit me


Since this worked for the OP, and it's the second "typo" that was c/p'd, could you or one of the mods make corrections to that post the OP linked to?

I could see this happening again...

But now a new problem has arisen

Does not read the SIM card
Ime number can be seen

Post the exact error you're getting.

And since your router is no longer bricked, mark this thread as solved, and start a new thread for this issue, and include the requested error info.


Done, posting corrected.

1 Like

Apparently part of the 4G modem program was cut with the DD command. Because 50 MB became 8 MB
No updates from the router write an error CODE 71211

See my previous post on starting a new thread for this issue, since the device is obviously no longer bricked.

You should be able to just reflash the stock firmware from the GUI now.

Make sure you have the firmware for the correct region (i.e. US, EU, etc.).