Hello all,

While downgrading to original firmware on my TP-link MR 3020 as shown in the below video.

Please help me to unbrick it.

This new type of brick driving me crazy :<<

I must've blinked and missed the flashing lights

sorry, i missed typed

seems you've already opened it, tried the serial console ?

It only flashed WPS/Reset light really fast, and the Power LED is still on after that

Yeah, I tried, but no luck, it only displays scramble things

no it probably doesn't, my guess is you're using an incorrect baud rate.

I set the baud rate to 115200

well, there are other speeds out there too.

true, I think i'll try

Do you got any suggestions about different baud rate?

1200, 2400, 4800, 9600, 19200, 38400, 57600 are all popular


Though, did you read this:


I did read that but I didn't do that because before I get this "bricked", I have unbricked without it so i thought it wouldn't be important.

it's never important, until you need it ... :slight_smile:

Oh, so, are you saying the serial connection worked OK before the brick?

And if so, was the baud rate working at 115200

If the serial connection worked with the same serial cable and the speed 115200, and now it doesn't, I think you truly do have a brick


Yeah, I did get a different "bricked" MR3020 bricked while downgrading like the 3 flashing lights boot loop
It did worked at baud rate 115200

As I said, I have a hard-bricked TL-MR3020 v1.9 while trying to revert back to original firmware.

well, you left out some relevant details in the initial posts .... :wink:

anyway, RIP MR3020.

1 Like

But what if I change the flash chip on the mr3020?