TL-MR3020 64MB RAM upgrade failed

So I have a TP-LINK TL-MR3020 v1.9 (SoC AR9331-AL3A). It had a Zentel A3S56D40GTP-50 RAM chip (32 MB). I decided to upgrade it to 64 MB RAM and decided to buy a Hynix HY5DU121622DTP-D43 chip after seeing the wiki for the 64MB mod for the TL-WR703N. I'm not an hardware expert but the specs between the 2 RAM chips seemed equal (protocol used, voltage etc) so I decided to go for it and replaced it today.

Needless to say the router seems bricked. The power led stays ON forever (it never blinks) and the reset LED blinks only once at the very start.

Is the Hynix HY5DU121622DTP-D43 incompatible for the TP-LINK TL-MR3020 v1.9 model? The soldering was done by a professional and was checked under a digital microscope.

Did any of you upgraded the RAM of yours too? If so which chip did you use? Thanks in advance.

NEW chip:


What does the serial output say?

I can't get the serial to show up anything. I tried with CP2102 USB serial converter.

dmesg on Linux machine:

[ 6928.791779] usb 2-1.5: Product: CP2102 USB to UART Bridge Controller
[ 6928.791781] usb 2-1.5: Manufacturer: Silicon Labs
[ 6928.791783] usb 2-1.5: SerialNumber: 0001
[ 6928.799825] cp210x 2-1.5:1.0: cp210x converter detected
[ 6928.802050] usb 2-1.5: cp210x converter now attached to ttyUSB0

screen /dev/ttyUSB0 115200

[screen is terminating]

sudo screen /dev/ttyUSB0 115200


Before and after powering the router:


No blinking leds at all. If I unpower the router its power led stays on for some reason (it only gets less bright).

Tried with and without the 10k pullup resistor same results.

Maybe I should also point out that for some reason that the RAM chip doesn't have the notch on the corner to mark PIN 1. I took as reference images from the Internet.

Connection should be
Router GND <-> Adapter GND
Router TXD --> Adapter RXD
Router RXD <-- Adapter TXD

From your picture it looks all correct. But basing that on info in TOH. Its possible the TX/RX have been mislabelled. Try swapping TX(Orange)/RX(Brown) wires on the router side.

The LED stays ON even if I don't use the pull-up resistor. See .gif below.

I add also board booting without serial connection (same leds turn on):

No luck with swapping TX and RX. Same behavior.


this info i got from old openwrt forum member:

Thanks for your help, now I made my tl-mr22u works with OpenWrt!
I also found out what leads to my failure, it is 64MB RAM! I have tried ESMT M13S5121616A and Micron MT46V32M16P. They are 8Megx16bitx4Banks DDR, and works well on tl-mr10u(AR9331), but mr22u won’t start up with them, it only runs when I solder the 32MB 4Megx16bitx4Banks DDR(ESMT M13S2561616A). There is no difference in pin arrangements between 4meg RAM and 8meg one. Maybe you’ll be interested in this phenomenon.

eventually i gave up on my mod attempt

if you got any success with different kind of ram chip please keep us updated

@mbo2o ...isn't UART standard 5 Volt Serial?

TTL is 5V
CMOS is usually 3.3V

So it depends on what technology the UART IC and the board in general is using. Best way to find out is to measure voltage between GND and VCC on the board.

1 Like


I think we discussed this in another thread. When unsure, always use a voltimeter (multimeter) to check.

If uboot can't start, most of issue is soldering not good.
I used this ram chip on some router and it work well.
Let check Vdd & Vddq pin ~2.6v, this chip required 2.6v (+0.1/-0.2v) for running 400mhz speed.

Thank you all for your replies. Since the guy who soldered the chip won't be able to do it again (he'll change job soon) I asked him today to solder back the old chip. And he did... And 2 pads popped out during the process... :frowning:

Router with old RAM chip:


New RAM chip (desoldered):

According to the data sheet the corresponding 2 pins are not connected/used, which explains why the pads came out so easily:

But unfortunately the router exhibits the same behavior as before, with the power led staying on forever.

Maybe I'll try to do more tests or maybe I'll just give up. I'm starting to think it either got damaged during the upgrading process or I had a defective IC which damaged the router. I don't really know at this point.

If I find something I'll keep you updated. Thank you again.

check your flash chip contents. try using pepe2k's modified uboot

I have replaced ram for a good amount of routers with that hynix chip. I'm waiting for my 3rd. batch of that chip hy5du121622DTP-D43. It is compatible with tplink 840v2/v3 841v9/10/11, mr3420 for sure, as I did changed their ram with that chip.
I'm gonna do it again(chip not in hand now) with some more 840 v3 routers with same chip and replace exact same zentel as56040gtp-50 or 50L(some winbond), shall see how it goes.

For replacing ram chip with tsop-66,

  1. Always desolder with hot air rework or a hot air gun with proper nozzle.
  2. Need quality Flux, flood it.
  3. U used tape that I always use, otherwise tiny registors/caps will come off very easily.
    I hv always took out the pins(UART Riser) before I do any ram or flash chip change. While I was starting I had problems, short out UART pins, as a result no boot!!, as hot air guns produce a lots of heat!!, melt and bridge solder inside the pads(for flash chip of 840 routers).
  4. Always used a fine tipped iron for solder back original or new chip.
  5. Always used pepe2k u-boot for qca/atheros before changing ram!! cfe is more forgiving.
  6. Replace ART after upgrade flash or no wifi or kernel panic.

Definitely check the +2.6 volt supply to the chip, it looks like in this case it comes from Q2 and C103. The +2.6 is used only by the RAM.

Any JEDEC standard DDR1 should interchange, they are made to meet the standard.

I have upgraded a MR3420v1 and the original boot works fine with 64M. I think there is a small ROM inside the SOC which probes and initializes the RAM before it even starts to boot from the flash.

4 posts were split to a new topic: TL-WA730RE v2 64MB RAM mod

visual check is insufficient. see my photo: the chip looks like is soldered fine, but there is no connection. multimeter confirms it. after flux+iron rework, connections appeared and the upgrade worked

Please check my thread: TL-MR3020 v1.9 HARD BRICKED
I think that you had the brick same as mine so my solution should work for you with or without your new ram