But what if I change the flash chip on the mr3020, like it just the chip problem right?

what do you mean by "chip problem"

physically faulty flash chip? or did you flash bad content?

I think I flashed half the way and ended, so that could be the problem

You will need a dump of the original flash to program before you install the chip. Then you need to desolder the existing chip and solder in the new one. If you are good at soldering surface mount components, it wouldn’t be that difficult, but it seems like a lot of extra effort to go though for a device that is entirely obsolete. I did recently repurpose one of mine with NUT so I could have a network readout of one of my ups units, but aside from little utility functions, the device has little value as a router or ap. Otoh, if you don’t mind some wasted time and money, you’ve got nothing to lose trying.

so which chip do you think is compatible with mr3020 v1.9?

Which instructions did you follow to revert to tp-link firmware? Interested to know what you may have done wrong

But, the fact that serial is showing garbage pretty much makes any recovery almost impossible (since all recovery methods require commands issued via serial)

I follow the instruction using tftp server, ethernet cable and using the reset button to safe my time

Likely the one listed on the hardware info page. Open your device and look at the part number to be sure.

Why are you linking to a RECOVERY video for a WR841N/ND???

What instructions were you following to downgrading to original firmware

But it did worked for me before this "hard brick"

What worked for you?

You're making little sense ...

My understanding is:

Step 1: you wanted to install original tp-link firmware on your router, that was running openwrt
Step 2: ????
Step 3: you now have a brick

What did you do in step two, to turn your router, running OpenWRT, into a brick?

My step 2 is was following the video, when I flashed the original firmware the first time, I thought I have to make sure I flashed it so I flashed the second time, but I didn't put a serial connection so I couldn't see what was happened, so it brick right after I think is mid-flashed.

yeah but is the Atheros chip is the flash chip?

If you have to ask about any of this, you really shouldn't even consider attempting it.


I found the chip

that makes no sense - you didn't recover from soft brick the first time

you used the same firmware image both times? that makes no sense that it worked, then bricked - except of course you did say

which probably isnt' the best thing to do

still doesn't explain why serial DID work, but now doesn't

how do you know serial DID work? were you tinkering with the serial port before any of this happened?

1 Like

How good are your soldering skills? Have you replaced surface mount components before?

I know the serial did work because the first soft brick is the flashing 3 lights which is easy to unbrick, but now it is just a POWER LED which is a hard brick

Oh, so you soft bricked, then in trying to fix the soft brick, you hard bricked

Now I'm beginning to understand the order of events from a router running OpenWRT to a brick

  • OpenWRT running
  • reverted to ORIGINAL (tp-link) firmware
  • soft brick?
  • attempt to fix soft brick
  • hard bricked
1 Like

I would remove the capacitor (and short across where the capacitor was) so that the SoC is connected directly to the serial line. Then you should get clear output. All of the ath9k chip bootloaders I've seen use 115200 N81. If the serial port is sending anything the bootloader is working and you should use that method to debrick.

Also do not power the router from a USB port on the same PC you have connected serial to. Use a separate wall plugged power supply, not a USB port.

1 Like