Support for Archer c50 v4

#32

Thank you for your efforts!

0 Likes

#33

I compiled a new image with ovpn... Not sure if it works but here it is:

If this won't work someone have to change the kernel in code or something else to make ovpn running.

0 Likes

#34

Superb, I will test and correct code if needed. Can you share your development branch with me so I can commit my changes on top of yours?

Bloctron branch is working have been running on my C50v4 for 2 weeks with no reboots or instability on 2.4 or 5 ghz have transferred more than 500GB on both Interfaces.

0 Likes

#35

I'm using this Github branch.
It's not my work!

0 Likes

#36

Regarding upstreaming the Archer C50 v4: I plan on submitting a patch without the dual-uboot hackery and provide instructions on how to create your own factory image. This might be more inconvenient but IMHO has a much greater chance of getting supported upstream.

2 Likes

#37

Hello,

THANKS for your work!!!!

When you work on a Image for the C50v4 please can you add USB support, for the people that soldered an USB-port on the PCB like described here:

Best Regards

0 Likes

#38

This is not going upstream, as upstream only supports OOTB hardware
features.

0 Likes

#39

@blocktrron - Is there any kind of schedule or timeline in which we can hope/expect the support for Archer C50 v4 to be official?

0 Likes

#40

Sorry for the delayed response, i currently do not have my Archer C50 v4
with me, but I've made the relevant changes, it's just needed to test
those. I wont be able to test them myself until mid of next week.

If you can test them, we might get the patch submitted earlier.

So if you can build an image and flash it to the device as described in
the commit message (and the device is working without any problems after
that :wink: ) the patch is - from my side - ready to be submitted.

Best Wishes

1 Like

#42

Unfortunatelly I didn't manage to make this on the weekend. I'll try it the next few days.
But just one question to make sure I get things wright.

Which "OpenWRT sysupgrade" do I need to use?

Or would it be possible for you to supply the ".bin" file to install/update?
Could you please also add opkg? and/or LuCi?

Kind regards

0 Likes

#43

I did compile the .bin file from the branch c50v4-noboot as this contained exactly the same description as seen in your latest link.
I kept on going and at the end I got this file (SelfMade-Archer_C50v4-OpenWrt-blocktrron_c50v4-noboot. Here is the VirusTotal check. This is the sha256 48e6174efda8405462b489f37ad4d21626fcef4885234232e7221f2034add363 ).
I'll give this a try tonight. As soon as I have some news I'll post.

Regrads

0 Likes

#44

Hi,

sorry, I've just seen your posts. The assumption you did regarding the tree I've meant was right.

I did test my tree just yesterday and everything works as expected, the patch also got sent to the mailinglist: https://patchwork.ozlabs.org/patch/1007372/

So if the installation method is no blocker for upstream support this device should be in master soon.

Best wishes

0 Likes

#45

I managed to install the built image to the c50 v4 and it works perfectly. The only thing I noticed, the Image has no LuCi (please follow the described steps from pulkkinen)

Thanks a lot everyone.

0 Likes

#46

Hi! Witch build and install-methode did you use? I have an new c50 v4 and not shure witch way is the right way.

Thanks! M

0 Likes

#47

For Archer C50 v4 installation see:

1 Like

#48

Maybe this helps a little:
https://niklas.theis-web.eu/2018/12/12/openwrt-on-archer-c50v4/

Or even gives you the comfort of using the files

0 Likes

#49

Hey all,

I have cloned @blocktrron 's c50v4 branch and compiled a build with LuCI and full wpad package.

Installed the resulting factory image from the TPLink WebUI and so far so good.

The Power LED keeps off, have to check the LED settings if there's something to change about that, but my problem is the wifi:
I can use the 2.4 Ghz Wifi, but the 5Ghz modes aren't there. And as others wrote that 5Ghz is working fine for them, I'm confused what I'm missing.

In my /etc/config/wireless I only see one radio and that is the 2.4Ghz type. But the 5Ghz radio isn't listed there either.

Any advice? Maybe I forgot something in the buildconfig?

Greetings, L

0 Likes

#50

You have to build from my c50v4-noboot branch in order to get an up-to-date image. The c50v4 branch contains stuff which has no chance of going upstream, therefore it is in a very old state. Make sure you remove your .config file before building.

You can simply sysupgrade the image from there. Just make sure you make sure to drop existing configuration

0 Likes

#51

Umm, the build only gave me the sysupgrade image.
That's flashable directly from an existing openwrt installation?

So for the c50v4-noboot branch to be flashable from the original firmware I'd have to do the dd trick for uboot?

L

0 Likes

#52

Oh gosh,

I tried it with the c50v4-noboot branch aswell now.
But I first compiled a build where I used the master branch and merged the c50v4-noboot branch into it.
Seems there happened something upstream that kills the 5Ghz.
After switching to the c50v4-noboot and building without the latest upstream changes the 5Ghz is working well^^.

Merry Christmas to you all :slight_smile:

L

0 Likes