Support for Archer A7


#1

I have read many forums that said that Archer C7 and A7 are the same except for minor things, is it possible to install 18.06 on an A7 using the C7 build?


#2

Yeap, the same question. OpenWrt support Archer A7? I already tried to load image from C7 but I got the error window that it is invalid image. Cheers, Tomasz


#3

From Archer C7v5 FCC documentation:

grafik


#4

Identical hardware doesn't necessarily imply that hardware IDs or mtd partitioning are identical as well, but it means that it might be easy to add support for it (unless the vendor has added firmware signing/ verification as well).


#5

Can somebody with an A7 try what is described on this thread? https://www.reddit.com/r/HomeNetworking/comments/8vxj1j/openwrt_support_for_tplink_archer_a7_vs_c7/e5ikoft/


#6

I changed the HEX values and still doesn't work.... Any ideas?

image


#7

Hi Guys, anybody found the solution? Of course something different than "buy C7" ;-p Cheers, Tomasz


#8

According to boot message, the flash layout is different, with ART in the end of the flash:

[    0.000000] Kernel command line:  console=ttyS0,115200 board=AP152 rootfstype=squashfs init=/etc/preinit mtdparts=spi0.0:128k(factory-uboot),128k(u-boot),1152k(uImage),14912k(rootfs),64k@0xff0000(ART) mem=128M rootfstype=squashfs,jffd
...
[    0.470000] Creating 5 MTD partitions on "spi0.0":
[    0.470000] 0x000000000000-0x000000020000 : "factory-uboot"
[    0.480000] 0x000000020000-0x000000040000 : "u-boot"
[    0.490000] 0x000000040000-0x000000160000 : "uImage"
[    0.490000] 0x000000160000-0x000000ff0000 : "rootfs"
[    0.500000] mtd: partition "rootfs" set to be root filesystem
[    0.510000] 0x000000ff0000-0x000001000000 : "ART"
The image seems to be based on QSDK

#9

Update: the partition table in the firmware is wrong, but because the rootfs is read-only in stock firmware, no harm is caused.
The actual partition table is 128k(factory-uboot)ro,128k(u-boot)ro,15360k@0x40000(firmware),704k@0xf40000(config)ro,64k@0xff0000(art)ro
I am recovering my bricked router


#10

The following patch should add Archer A7 V5 support and allow flashing from the factory firmware:
https://gist.github.com/dword1511/b0ead3a1a8f3bfae35d710b4a17b4ce8

I had to create a separate board file (mach-archer-a7-v5.c) due to different art and default-mac locations.

However, in the middle of the process, I bricked my router and somehow restored the factory firmware. Some of my factory partitions are empty. Although factory firmware runs normally and can be flashed into OpenWRT, I am not 100% sure that it would work on a clean, out-of-box A7.

Factory firmware boot log (and my botched first attempt):
https://gist.github.com/dword1511/1a2b750be9f3bd8eae4da0faff7ebebb


#11

I accidentally got an Archer A7 yesterday. Thought I was ordering a C7 but I didn't notice the difference. Oh well!

I can confirm that it will not load C7 firmware, whether OpenWRT's or TP-Link's.

There's is no difference between the latest TP-Link firmware for the EU and the US. 'diff' claims they're the same binary.

When the Archer A7 does a tftp boot, it looks for the ArcherC7v5_tp_recovery.bin.

Once I figure out how to build OpenWRT from the sources (again! BB was the last one I built.), I'll try dword1511's patch on my fresh machine.

Mike


#12

I built 18.06 with the patch from @dword1511. The A7 rejects the image from both the web interface and from tftp.

I'm going to have to hook the serial port up to it to see what if anything I can gather from the boot log.


#13

Support for the archer a7 has been merged yesterday, so you can try an official snapshot build as well:

https://downloads.openwrt.org/snapshots/targets/ath79/generic/openwrt-ath79-generic-tplink_archer-a7-v5-squashfs-factory.bin


#14

Looks like there's a good amount of duplicate efforts.

The commit that slh is referencing: https://github.com/openwrt/openwrt/commit/1e4ee63cc8d1889a78b539a5ed7be8d56e9b976f

There's also an open pull request out there:


#15

And right after I got the case taken off! :grinning:

It flashed but I haven't found it on the lan yet. I thought OpenWRT would come up on 192.168.1.1 but it doesn't appear to be there. TP-link's 192.168.0.1 doesn't work either. Nor the local address I assigned to it when it was running TP-link's firmware.

Some more experimenting to do!


#16

Just to be sure, you are trying ping and/ or ssh, not your web browser (development snapshots don't include luci by default).


#17

It doesn't answer broadcast pings. Just tried ssh and it's asking for the root password. Which is not set?


#18

forgot the "root@" part! (It's getting late here!)

I have a BusyBox shell! Now I just have to remember how to configure the thing from the shell. I'm spoiled by the GUI.

Or build my own full image from the sources. And then remember how to to the upgrade.

Like I said, I haven't touched my Buffalo WZR-600DHP running BB in years! So I've forgotten a few things. :grinning:


TP-Link Archer C7 AC1750, v4 though v5 was expected
#19

Connect the archer a7 with its WAN port to one of the LAN ports of your current router, the defaults are to request an IP address via DHCP and should get it online without any kind of configuration. Once you provided internet access for it opkg update && opkg install luci will provide you with the normal webinterface.


#20

Ah, but I want to run it as a local LAN only bridge. So I changed the IP address to my local network's static address. I can login via ssh at that local static address. I added a 'gateway' option to /etc/config/network and 'netstat -rn' says routing is correct:

root@WAP3:~# netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         10.11.12.2      0.0.0.0         UG        0 0          0 br-lan
10.11.12.0      0.0.0.0         255.255.255.0   U         0 0          0 br-lan
root@WAP3:~# 

But 'opkg update' can't find any of the servers. Seems like I've had this problem before.

/etc/resolv.conf has the DNS server as the localhost. Once I changed that, I can find the opkg list.

And now I've been cut off by a 3 post limit so I won't be able to contribute to the A7 work anymore. :frowning_face: