Support for Archer A7

The procedure depicted above, using dhcp, is the most simple way to install a webinterface on OpenWrt - how you configure it afterwards is another issue (you can invoke firstboot to get to the original state).

Just got an Archer A7 (hardware v5.0) and it worked out of the box with snapshot firmware build.

Thanks everyone!

Is there any rough idea when this might be available in a stable build? I'm not really comfortable using a snapshot.

1 Like

Just got an Archer A7 (v5) and it worked fine. Flashed the snapshot build that @slh linked. Power cycled my modem to get internet, then SSH'd into 192.168.1.1 and installed luci (opkg update && opkg install luci).

1 Like

Just bought a A7 v5, updated to latest stock firmware Archer A7(US)_V5_181210 and installed the snapshot r9278-39273b8 via web interface without any issues.

Downside of a snapshot is you have to update opkg package list daily, or you will hit a hashsum mismatch error :rofl:

That's a bit alarming. Is that true if you only install luci or is it true if you install several other packages?

See https://openwrt.org/releases/snapshot for implications of using snapshots.

1 Like

Simply put, it happens for almost every package, but that won't cause any obvious problems.

However, if you were using packages that relying on kernel mods (or k-mod-xxx), like fuse or 6-in-4, you should install them as soon as possible. As later when the new snapshots (and their corresponding packages) are released, opkg may report updated kernel mods incompatible with currently installed kernel.

That's good to know because I very nearly installed this on an A7 for my 86 year old mother and then left town. Now I will wait and exchange this A7 with my own C7 so that she can have something more reliable!

These are on heavy discount on Amazon Treasure Truck today. $44.99

@Bunbury911 OpenWrt != dd-wrt
This is the OpenWrt forum.
Please ask this question in the dd-wrt forum.

hi there! can you help me to install gui to be able to roll back to stock or configure setting on the router? I an newbie to all this staff. I got a7 v5.0, and i installed this software over stock firmware, but now i can't configure anything

ttps://downloads.openwrt.org/snapshots/targets/ath79/generic/openwrt-ath79-generic-tplink_archer-a7-v5-squashfs-factory.bin

Please don't double post, see Archer A7 v5.0