Stuck after flashing ZTE MF283+

The problem is that the router is answering pings only when in recovery mode.

Yes, I have this feeling too that using the serial console might be the outcome.
However before splashing some money on it (which is roughly around 1/3 of a Xiaomi 4A budget router) I need to know if that is a safe gamble. Otherwise I'll dash some extra money out and buy Xiaomi 4A instead of the serial console.

Preferably I would like to get the ZTE MF283+ router working and in the near future I would prefer to buy a more decent OpenWrt friendly router than the Xiaomi 4A one.

Of course when I have learned and gained some experience in using/ tweaking OpenWrt which makes the ZTE MF283+ router a perfect one to start with.
The author Leo managed to have it functioning so there must be a way. :slight_smile:
And to be totally honest, I am always up for a challenge, a life without challenges is just like some dull tupperware party.

Unlikely. If you waited patiently using the TFTP method triggered by reset + Wi-Fi key combo, until the system booted, then flash should be complete.
But maybe a broken overlay filesystem lingers on the flash for some reason? Please try holding the reset button during normal startup for around 8 seconds, until red LED blinks, this will trigger a "first boot" scenario.

Okay. I can reproduce the issue on clean installation of 22.03.2. LAN doesn't start for some reason in normal startup, but I can SSH into device while in failsafe mode sometimes - in this case VLANs get set correctly.
For the time being, please try 21.02 release, this one should work. I'll try to debug this on my device, I have pins for serial console already soldered in.

Edit: just confirmed, 21.02.4 release works. You can also try with snapshots or previous version, it would greatly help with finding the root cause. No need to disassemble the device, just simple "works/doesn't work" will be great.

After flashing 22.03.2 again, I got an oops:

[  166.162245] ------------[ cut here ]------------
[  166.171432] WARNING: CPU: 0 PID: 1980 at net/sched/sch_generic.c:467 0x802cd198
[  166.185987] NETDEV WATCHDOG: eth0 (mtk_soc_eth): transmit queue 0 timed out
[  166.199838] Modules linked in: rt2800soc rt2800mmio rt2800lib pppoe ppp_async option nft_fib_inet nf_flow_table_ipv6 nf_flow_table_ipv4 nf_flow_table_inet usb_wwan rt2x00soc rt2x00mmio rt2x00lib qmi_wwan pppox ppp_generic nft_reject_ipv6 nft_reject_ipv4 nft_reject_inet nft_reject nft_redir nft_quota nft_objref nft_numgen nft_nat nft_masq nft_log nft_limit nft_hash nft_flow_offload nft_fib_ipv6 nft_fib_ipv4 nft_fib nft_ct nft_counter nft_chain_nat nf_tables nf_nat nf_flow_table nf_conntrack mac80211 cfg80211 usbserial usbnet slhc nfnetlink nf_reject_ipv6 nf_reject_ipv4 nf_log_ipv6 nf_log_ipv4 nf_log_common nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c crc_ccitt compat cdc_wdm sha256_generic libsha256 seqiv jitterentropy_rng drbg hmac cmac leds_gpio ohci_platform ohci_hcd fsl_mph_dr_of ehci_platform ehci_fsl ehci_hcd gpio_button_hotplug usbcore nls_base usb_common mii crc32c_generic
[  166.353896] CPU: 0 PID: 1980 Comm: mount_root Not tainted 5.10.146 #0
[  166.366717] Stack : 804f0000 8004cb48 80417a08 804179e8 00000000 00000000 00000000 00000000
[  166.383389]         00000000 00000000 00000000 00000000 00000000 00000001 80809db8 6b5d53c4
[  166.400063]         80809e50 00000000 00000000 80809c68 00000038 801f2904 00000000 00000023
[  166.416730]         6d6f4320 81a67d64 00000000 6d203a6d 803f4758 80000000 80809ea0 00000009
[  166.433401]         804353a0 00200000 00000000 804f4d34 00000000 8021a4a0 00000000 80630000
[  166.450066]         ...
[  166.454993] Call Trace:
[  166.455023] [<8004cb48>] 0x8004cb48
[  166.466853] [<801f2904>] 0x801f2904
[  166.473818] [<8021a4a0>] 0x8021a4a0
[  166.480720] [<80006988>] 0x80006988
[  166.487696] [<80006990>] 0x80006990
[  166.494655] [<8002181c>] 0x8002181c
[  166.501558] [<802cd198>] 0x802cd198
[  166.508533] [<802cd198>] 0x802cd198
[  166.515517] [<800218a4>] 0x800218a4
[  166.522480] [<802cd198>] 0x802cd198
[  166.529383] [<8005c588>] 0x8005c588
[  166.536356] [<802cd098>] 0x802cd098
[  166.543314] [<8005a88c>] 0x8005a88c
[  166.550220] [<8005ac1c>] 0x8005ac1c
[  166.557198] [<8004f44c>] 0x8004f44c
[  166.564163] [<803e2bec>] 0x803e2bec
[  166.571065] [<80052f10>] 0x80052f10
[  166.578039] [<8004ec54>] 0x8004ec54
[  166.585032] [<80002718>] 0x80002718
[  166.591928] 
[  166.594947] ---[ end trace 14dc8732c05b37d6 ]---
[  166.604161] mtk_soc_eth 10100000.ethernet eth0: transmit timed out
[  166.616481] mtk_soc_eth 10100000.ethernet eth0: dma_cfg:00000055
[  166.628468] mtk_soc_eth 10100000.ethernet eth0: tx_ring=0, base=01a88000, max=1024, ctx=78, dtx=69, fdx=69, next=78
[  166.649215] mtk_soc_eth 10100000.ethernet eth0: rx_ring=0, base=01a8c000, max=1024, calc=305, drx=383[  244.162295] mtk_soc_eth 10100000.ethernet eth0: transmit timed out
[  244.174635] mtk_soc_eth 10100000.ethernet eth0: dma_cfg:00000055
[  244.186646] mtk_soc_eth 10100000.ethernet eth0: tx_ring=0, base=024ac000, max=1024, ctx=94, dtx=0, fdx=0, next=94
[  244.207055] mtk_soc_eth 10100000.ethernet eth0: rx_ring=0, base=02504000, max=1024, calc=284, drx=299

Tagging @lynxis and @981213 - as the issue seems related to mtk_eth_soc,maybe you do have some clues or know someone with more knowledge on that driver. The interface seems to receive ARP requests from the network, but cannot send anything.

I also managed to capture this kernel panic:

[   14.066466] rt3050-esw 10110000.esw: port 2 link down
[   14.215730] skbuff: skb_over_panic: text:80266770 len:7265 put:7265 head:817969e0 data:81796a22 tail:0x81798683 end:0x81797040 dev:eth0
[   14.239955] Kernel bug detected[#1]:
[   14.247037] CPU: 0 PID: 367 Comm: ip Not tainted 5.10.146 #0
[   14.258219] $ 0   : 00000000 00000001 0000007b 804e71e0
[   14.268581] $ 4   : 00000001 804f0000 00000000 80809cb0
[   14.278938] $ 8   : 00000001 80809cc8 00000000 00000015
[   14.289294] $12   : 20323261 8088bb08 00000003 6c696174
[   14.299651] $16   : 80a584e0 809e43c0 80a58000 00000002
[   14.310008] $20   : a16bc020 00000002 81964c60 00000000
[   14.320363] $24   : 00000000 8021a4a0                  
[   14.330719] $28   : 8178a000 80809e50 00001c61 80282c00
[   14.341078] Hi    : 00000084
[   14.346762] Lo    : b61f0000
[   14.352454] epc   : 80282c00 0x80282c00
[   14.360032] ra    : 80282c00 0x80282c00
[   14.367605] Status: 1100a403 KERNEL EXL IE 
[   14.375893] Cause : 10800024 (ExcCode 09)
[   14.383813] PrId  : 0001964c (MIPS 24KEc)
[   14.391728] Modules linked in: leds_gpio ohci_platform ohci_hcd fsl_mph_dr_of ehci_platform ehci_fsl ehci_hcd gpio_button_hotplug usbcore nls_base usb_common mii crc32c_generic
[   14.422952] Process ip (pid: 367, threadinfo=(ptrval), task=(ptrval), tls=77e99df0)
[   14.438084] Stack : 00000002 8042fd20 80266770 00001c61 00001c61 817969e0 81796a22 81798683
[   14.454656]         81797040 80a58000 7fffffff 80284910 00000002 00000000 80a584e0 80a584e0
[   14.471227]         817969e0 80266770 81000200 8047fb00 00000000 00000003 00000000 8006a030
[   14.487796]         7fffffff 00c00004 00000f00 00000004 00000000 00c00004 0000000c 20000000
[   14.504365]         01964ca2 40000000 00000000 8088d180 01796a22 6370056c 80a584bc 00000042
[   14.520936]         ...
[   14.525770] Call Trace:
[   14.525789] [<80266770>] 0x80266770
[   14.537504] [<80284910>] 0x80284910
[   14.544399] [<80266770>] 0x80266770
[   14.551295] [<8006a030>] 0x8006a030
[   14.558197] [<8029d260>] 0x8029d260
[   14.565094] [<8029d454>] 0x8029d454
[   14.571988] [<8004f44c>] 0x8004f44c
[   14.578887] [<803e2bec>] 0x803e2bec
[   14.585781] [<80052f10>] 0x80052f10
[   14.592675] [<80039770>] 0x80039770
[   14.599575] [<80002718>] 0x80002718
[   14.606464] 
[   14.609398] Code: afa30010  0c0126d9  2484faa4 <000c000d> 8c8200a4  8c880054  8c8300a0  00451023  01053821 
[   14.628739] 
[   14.631791] ---[ end trace d1f3d02249e55cfd ]---
[   14.640992] Kernel panic - not syncing: Fatal exception in interrupt
[   14.653568] Rebooting in 1 seconds..

I have waited patiently and I did use the TFTP method triggered by reset + WPS buttons combo, after which firmware got transferred to the router (which can be seen in the TFTP Log Viewer pics I posted above).

Also the flashing did occur and I have patiently waited for it to be done (for the green LED to stop flashing and turn into blue).

Like I mentioned above, thanks to @mk24 I did get into the recovery/ failsafe mode by holding the reset button during the boot up until the LED switched from green into red and started flashing rapidly.

That's the only time I could "reach" the router with ping command (as also explained in one of my posts above).
Also put did not time out in this case but the cursor froze and I did not have the possibility of entering any commands.

Thanks a million for trying to debug the issue.

As for not disassembling the router........ :

A little too late....:slight_smile:

I was about to go and buy a serial console.....

And a couple of pins to solder....

I will gladly put the router back together and try installing the 21.02.4 release.

As soon as I am done flashing I will post my findings here.

You may try with current snapshot as well, but you'll have to manually install LuCI which is a bit PITA, but it would be nice to know if kernel 5.15 fixes those issues.

1 Like



We are IN!!!!!

1 Like


All Hail Now

1 Like

Okay...... so far so good...

LuCI has finally arrived....

I have managed to log in....

When checking the network adapter the SSID is still the ISP's one "Vip WLAN_4475A3"...

Not that it matters to me.... but I recall someone saying that after successful flashing the ISP's stock SSID should not be visible...

Anyway.... version 21.02.4 seems to work and I reckon it is because of it's older kernel which is 5.4.215 instead of the newer 5.15 in OpenWrt 22.03.2....

I am willing to try the snapshot and install the 22.03.2...
I just need to check how to install LuCI manually and I would appreciate if you could inform me of anything I need to know involved when installing the snapshot.... (special procedures/ steps or anything like that)...

I can give it a go tomorrow when I have time to do so..... just let me know...

Old SSID is shown, again, due to Windows caching and showing the same network name, not necessarily wireless, with the same gateway MAC address. You need to enable WI-Fi manually on "wireless" page.

As for manual LuCI installation: have your WAN connection configured already, and do an upgrade from current image. Have configuration backup at hand. Then on new version, SSH into the router and do opkg update; opkg install luci-mod-admin-full.

I wonder if 22.03.0 release works as well, but have little time to hop around versions now.


No it doesn't:


Also, you need to enable it (and set security).

I would advise checking the OpenWrt, not the unrelated Windows device.

1 Like

Yes I was aware that I had to set up the network yet but just wanted to show that I can finally log in.

Thank you for the explanation on how to install LuCI.
As soon as I have got some time I will set up the network, back up my configuration and try upgrading with snapshot(s).

Lately I am also very short on time myself but I will put all of my free time into trying to sort this out, even if it means hopping from version to version. :slight_smile:

Yes sir!!!
Roger sir!!!

Aye aye captain!!!

Thank you as always for your valuable input.
I have no doubt that what you saying is going to turn out right as it always does.

I was just posting my first glance observations which were a bit premature I guess.
Anyway I am so happy to have finally managed to log into LuCI.

Now I will go about setting up the network soooo.... please do stay put for new topics, questions, messages and from time to time, wrong observings.... :wink:

1 Like

Hi everyone!

Due to shortage of time I have not replied recently.
I apologize for that.

First of all I wish you all happy holidays with all your merits to be pursued to even higher levels.

I want to thank everyone so far for trying to help me.

I have done some reading up and decided that I want to try to install the snapshot with attended sys-upgrade..... thinking that it might be a tailored solution to my problem.
The initial problem that is.

However, I have done some research about connecting 2 routers which was my purpose in the first place.
After that I am more confused than ever.

I will send a private message to one of the OpenWrt forum members who has been most engaged so far in this matter (frequently posting) and after that I might open another topic.

I will update my findings and results here and due time when the FINAL solution has arrived I will close of this topic as "SOLVED".

Once again, many thanks to everyone being involved as well as the author of the firmware. I am aware we all lack the time but even so, I so much appreciate all of your time and efforts.

Stay safe and a happy new year!!!

1 Like

From the description in the private message, you just plug the OpenWrt downstream of the other device. As long as there's not an IP conflict (i.e. both networks can't be - you're good!

Hope this helps.

(Feel free to make a public post if more is needed.)

Thanks Ileachii.

Just dropping a line so the topic does not close off automatically until I have tried the suggested solution.

Next few days I will have time to work on the routers.

While at that, you might want to test out 22.03.3 release, maybe the kernel bug which caused your initial problems was fixed. Just be sure to have a config backup :wink:
I need to upgrade my fleet to 22.03 finally, but I lack time for that currently.

Hi Leo,

Unfortunately I have not yet configured the router.
Thought of trying the attended system upgrade with a snaphot.

But before getting to that point I need to discover how to make 2 separate private networks, more specifically how to set up the interfaces in OpenWrt.

Tomorrow I will start another topic on that and once I have the networks running I will make a config backup and then try updating it and closing this topic off.

1 Like

Okay, time for a little update....

With the help of @pavelgl & @psherman I have successfully created 2 private networks and finally connected to the internet.

I have installed luci-app-attendedsysupgrade:

And where I expected to be able to directly to 22.03.3 release I hit the wall with:

It gives me the choice of upgrading to 21.02.5 release.
Maybe after upgrading to the 21.02.5 release, a new option of upgrading to 22.03.3 release would become available?

Why did I not try to upgrade yet?

Because I have installed OpenVPN too and I have to smooth out some things first, like DNS leak that I am experiencing. Once I have got the OpenVPN working to my liking, I will back up all my configurations and then finally go over to trying to upgrade to the latest official release available.

And if it can not be done with attended sysupgrade option, then I will find another way of doing it.

Anyway, I will keep you posted and post the final solution so this topic can be closed off as "SOLVED".

I will be back as soon as I have figured out how to get rid off the DNS leak I am experiencing.