Stuck after flashing ZTE MF283+

  • How do you know this to be so?
  • If this is truly the case, can you SSH?

My bad.

Thank you very much for explaining it to me trendy.
So as I understand it now, the bootloader is embedded on the router itself hence it is not connected to the one that OpenWrt assigns to the router after it's fully booted.

So if I interpret that information correctly it also means that OpenWrt is not successfully flashed as the router is not accessible after a full boot cycle.

The thing is I have already got this router as I first had 4G LTE internet before I switched over to fibre optic internet with the same ISP so I thought why not use it instead of buying an extra router which I eventually might do as I mentioned above in my post.

I really need to go now.
I will reply to messages as soon as I get back home.

Thank you very much trendy.

You misinterpreted 1 part. 1 bootloader, hence Openwrt doesn't offer one. It should be the same.

I don't have any experience with that model so can offer only general advice.

The LED flashing fast then slow then staying on usually means that OpenWrt has booted up. If you press the reset button while the LED is flashing fast you may get recovery mode, where the LED flashes really fast and OpenWrt runs from RAM with default settings. If you can activate recovery mode try connecting and logging in then.

Try different Ethernet ports because OpenWrt may assign them differently than the stock firmware and labels on the case. When there is more than one Ethernet port, OpenWrt will make one of them WAN and you won't be able to log in on that port. This is true even with a LTE model where the WAN is intended to be LTE-- LTE support is not included in the initial install it will need to be added later.


Hi, author here. I noticed your email.

Which image are you flashing? If you do install snapshot, it comes without LuCI by default, only release builds do.

I presume this part is solved already, but please use ports LAN2-LAN4 for flashing, because U-boot for some strange reasons communicates only over them. IIRC, for OpenWrt all ports then were attached to LAN interface.

1 Like

Thank you so much for clarifying lleachi.

All clear now!!!

Thank you very much Mike. All input is appreciated.

I will try to reset the router while the green LED is flashing fast to see if it makes any difference and if I can get the OpenWrt to run from RAM like you have said.

I will post the results as soon as I have tried.

Hi Leo the Author,

Thank you very much for taking notice of my e-mail and for reacting to it.
Lately I am extremely busy so hence the delay in my replying.

Also, I have tried a couple of suggested things to see it they could help fix the problem.

I followed the author's instructions at:;a=commit;h=59d065c9f81c4d1a89464d071134a50529449f34

....which say and I quote:

"There are two installation methods:
(1) Using serial console and initramfs-kernel - recommended, as it
allows you to back up original firmware, or
(2) Using TFTP recovery - does not require disassembly."

I went for the TFTP recovery installation which says:

"(2) Using TFTP recovery

  • Set your host IP to - for example using:
    sudo ip addr add dev
  • Set up a TFTP server on your machine
  • Put the sysupgrade image in TFTP server root named as 'root_uImage'
    (no quotes), for example using tftpd:
    cp openwrt-ramips-rt305x-zte_mf283plus-squashfs-sysupgrade.bin /srv/tftp/root_uImage
  • Power on the router holding BOTH Reset and WPS buttons held for around
    5 seconds, until after WWAN and Signal LEDs blink.
  • Wait for OpenWrt to start booting up, this should take around a

First time that I had flashed, I used the wrong file. The one that is supposed to be used when flashing with UART serial console, the "initramfs-kernel.bin" file.

After flashing with that file there was a kind of log in page when trying to access the LuCI web interface but it looked like a corrupted webpage without letters and with disfigured thumbnails. In best case nothing readable or interactive.

After carefully reading openwrt.git/commit page again I saw that I should've used the "sysupgrade.bin" file.

So I flashed back to the stock firmware, logged in and checked that it worked and then flashed again with the "sysupgrade.bin" file after renaming it to "root_uImage".

Since then I am caught up in this limbo of not being able to access the router after flashing it.

So I have used no snapshot or anything like that.

I was not aware of this so all the time I have been using the LAN1/WAN port for flashing and for connecting to my NIC.

After reading this I decided to flash the router again, which I did 3 times today but this time I used the LAN2 Ethernet port.

Like all the previous times the firmware got transferred to the RAM without problem:

As can be noticed the transfer succeeds without a problem only the router does not start flashing until turned off and on again. However the flashing process takes place and after it is done the router finally finds the "unidentified network" again and there is no way to access the router through LuCI or any other way as it is not accessible.

When switching the IPv4 settings to DHCP (Obtan address autpmatically) the router seems to struggle even more to boot up than when I use a manually assigned address like e.g

I wonder if I should maybe try and flash it with the "initramfs-kernel.bin" file again?

I have also followed up Mike's advice and this is where things start getting interesting.


So this is what I did.....

During the boot up when the 3/4g LED starts blinking, I have pushed the reset button and held it until it became RED (this is the first time) so I assume that I have entered the "recovery mode" as explained by Mike. The RED light LED was flashing in a rapid gunfire kind of way. VERY fast.

After that I could see in the "Network and Sharing Center" that the OEM SSID ( Vip WLAN_4475A3) was finally found and recognized. Normally it always says "Unidentified Network".

And as can be seen in the image above, I for the 1st time even succeeded in pinging the router.

At that point I thought I might be able to get into the configuration setting through LuCI but to my dismay as soon as I typed '' into browsers address bar I received a "refused to connect" message as can be seen here:

I have also tried accessing the router through "" with the next result:

Other than that I have also tried connecting through different Ethernet ports @mk24 but without success.

I have the feeling that the router is flashed halfway, meaning that it is hanging in some twilight zone between the OEM and OpenWrt firmware.

I also have the feeling that this is solvable only I lack the knowledge to accomplish that.

Any further insights, suggestions, inputs as well as advices would be more then welcome.

I thank you all for taking time to read this thread as well for trying to help me out with this predicament.

I can smell that we are so close to solving this......
We need the magic hint.... that's all....

Try the ssh, you are getting connection refused on which means that there is something listening to that address but not allowing the access.

If it's broadcasting wifi with the stock SSID, it's still running stock firmware. OpenWrt does not start WiFi at all when first installed.

I did try with Putty (not today) but the router could not be reached either.

The only time I could kind of "communicate' with it was today after following Mike's "restart button/ recovery mode" trick.

However I forgot to mention that the LED kept flashing red like crazy and that once it engaged in doing so, the only way to get the router into a regular boot up mode was to switch the router off.

I will give it another try with Putty though and I will let you know the result.

Thank you again for your input Panagiotis.

That is recovery mode, but if the stock firmware is OpenWrt based it may do the same thing.

It is definitely not. But Windows identifies networks not only by SSID, but also by gateway MAC, and if it matches over wired interface, it'll be displayed as such.
Over the weekend I may try 22.03 release on my device - haven't touched it for quite some time, and see if there isn't a regression present.


Here is the result of trying to connect through Putty.
I have tried to connect through it as per Mike's advice that is running the router in recovery mode (red LED rapidly blinking) and this time it does seem to connect unlike the previous time, well at least the connection does not time out.
However, the cursor in Putty is frozen and does not let me enter any commands or type anything.
Ping does still work.

Putty in regular boot up mode:

I've stopped scratching my head cause I made a hole in my skull....

That is the funny thing Mike.
It is not broadcasting any wi-fi with the stock SSID (it is when I flash it with stock firmware) and as I have done a lot of reading I was already aware that with OpenWrt the wi-fi is turned off due to security measures and that it needs to be activated inside LuCI.

So we got no wi-fi (also not during the regular boot up) and neither the or can be reached through the web interface to get configured.
Hence I am prone to think that the router is hanging in some kind of purgatory place....
Neither here nor there....
A ghost between the 2 firmwares.... in a no router's land...
It is there but it is not at the same time as it can not be accessed...

Sounds like there is no way to find out what is wrong unless you get access to the console.

1 Like

Nope, like Leo the author has already mentioned the stock firmware is ABSOLUTELY NOT OpenWrt based.
It is rather stripped down and mutilated by the ISP so there is no VPN, Guest network or bridging option in the configuration menu and this in 2022..... pretty sad actually.
That is the very reason I am trying to flash it with OpenWrt and I was really excited when I found that the OpenWrt firmware has been compiled for it.
Hopefully Leo will have a look at it over the weekend and maybe come with some/ new insights.

I very much appreciate your input Mike.
Thank you once more.

My next way of trying to "access" the console will most likely end up with trying to access it with a hammer......:slight_smile:

Leo, I was wondering that maybe the router only can be properly flashed with the serial UART console method... by opening the console and wiring it to the PC but I might be wrong.

I am not sure which method you used to flash it successfully...

Windows 10 has a CLI ssh client which is a port of OpenSSH and works basically identical to on a Linux box. I use that instead of Putty.

If the router is answering pings but not allowing http or ssh in you will probably need serial console to see what the problem is.