[Solved] WRT3200ACM - Unable to flash LEDE successfully

Hello!

Hopefully this is worth posting, I can not get the feeling out of my head that I am missing a major thing in the guides or something like that.

Today I got a Linksys WRT3200ACM and I would like to flash LEDE. I did the following:

  • Checked if the router itself works (walked through Linksys webGUI, connected a few devices, minor stuff...)
  • Read this and that
  • Downloaded the firmware via the link on the Techdata page, as suggested
  • Noticed that all links refer do a ..factory.IMG though documentation says it should be a ..factory.BIN (but did not bother with that because the original firmware is distributed via a .img, so the router should be able to handle them)
  • compared the checksums
  • and started the flashing process via Linksys webGUI

Everything seemed to be fine, no errors occurred, the router rebooted but I was not able to enter any kind of webGUI after that. In fact I got no IP via DHCP, I was unable to ping the default adress (which is 192.168.1.1 if I am not mistaken) with a manually assigned IP, I did not get a sign of any life. The only working LEDs were the power LED and the LED indicating a wired connection.
After 20-25 minutes I lost patience and rebooted the router disconntecting and reconnecting power. Tried a few things again, nothing worked, so I did a second reboot and I was back on Linksys software.
This left me a bit confused, since I thought I had flashed LEDE. So I repeated the steps above with no other result than ending in Linksys webGUI again.

Obviously I am doing something wrong, but after about three hours of trying things out it seems to be time to ask people who have more experience than I do. So - is anyone able to tell me what I am doing wrong? Any comment or thought is appreciated, and thanks in advance!

1 Like

Just to confirm, you downloaded the firmware from here and used the squashfs-factory.img file to flash...

https://lede-project.org/toh/views/toh_fwdownload?dataflt[Model*~]=wrt3200acm

Some routers have an issue with the long filename, so you might try renaming the LEDE firmware file something like factory.img

That being said, If you can ping 192.168.1.1, then LEDE is there.

Try to get into failsafe mode...

https://lede-project.org/docs/user-guide/failsafe_and_factory_reset?s[]=failsafe

Three failed boots will change back to the partition from which you flashed.. It sounds like you chose to use master(aka snapshot) which has not GUI. Might want to start with stable 17.01.4, or ssh in and install LuCI.

@jwoods Yes, I downloaded the exact same image you linked and renamed it to factory.img, but no success.
192.168.1.1 is not pingable. To enter failsafe mode I first need a working LEDE, right?

@anomeome This is good to know, thanks. The image I tried to flash is a stable one which should have a GUI. But even if not - a ping should return a result, which does not happen.

A few questions just to be sure to rule out some problems:

  1. You installed "generic/lede-17.01.4-mvebu-linksys-wrt3200acm-squashfs-factory.img" and not "generic/lede-17.01.4-mvebu-linksys-wrt3200acm-squashfs-sysupgrade.bin", right?

  2. You are connected to the router via ethernet cable? Not wifi?

  3. You can access the router running the original Linksys firmware via ethernet? Also when you manually assign an ip address and other network information? Does a ping work with the original Linksys firmware?

  1. Yes, I tried the image from this location.
sha256sum lede-17.01.4-mvebu-linksys-wrt3200acm-squashfs-factory.img 

2f325bdd9c0102273ff4af205601d06335a101a4a3bc6dd470885d64651ef144 lede-17.01.4-mvebu-linksys-wrt3200acm-squashfs-factory.img

  1. Yes, I use a ethernet cable for this.
  2. Accessing Linksys works fine, both via ethernet and wifi. I am not sure what you mean with the second question, I am able to ping the router with its default address (192.168.1.1). I am also able to change the routers network information (e.g. 10.1.0.1) and ping this.

I'm not sure if a vanilla lede installation has dhcp running already. I would manually setup the network interface on your computer, which you seemed to have done as well. With my questions I just wanted to make sure there isn't a problem on your computer's network setup. So, if you can't reach the router with the original firmware with a manually assigned ip (like 192.168.1.2) and other network information (like netmask and gateway), probably your problem is with your local network interface setup.

I am quite confident that this is not a problem with the local interface.

I can ping the router and access the webGUI while Linksys is running. Something prevents LEDE from booting correctly after flashing via Linksys webGUI, resulting in the behaviour described in my first post an "confirmed" by @anomeome (three failed boots --> back to Linksys).

Hey,
I have the same problem as the author of the topic. I bought WRT3200 yesterday and I wanted to install LEDE. Computer connected via Ethernet cable, LEDE image: "lede-17.01.4-mvebu-linksys-wrt3200acm-squashfs-factory.img", after reboot the router does not get an IP address.
I have the same symptoms as a colleague described above.
After manually setting the IP address, netmask, getaway I also can not communicate with the router.
The original Linksys software works fine.
Any suggestions?

1 Like

Might be worth a try to flash a master snapshot image, there will be no GUI, easy enough to install:

ssh to device
opkg update
opkg install luci

assuming you can ssh to device of course, but easy enough to use power switch to get back to working image.

Flashing a master snapshot image results in a reboot-loop and finally Linksys again.

SSH or Telnet into the Linksys and run the following command...

ubootenv get boot_part

This will tell us which partition Linksys is on.

iirc I do not believe the OEM supports ssh. There was some chatter a while back about a change to the flash chip going into the rango, not sure if that is what is happening here or not though. Are these both recent devices? So, this is both a 4.4k stable image, and a 4.9 snapshot, yielding the same result.

Doing further research, that is correct. Uproar about no SSH on the Linksys forums.

Mine was delivered friday - no manufacturing date anywhere.
EDIT: The white/blue quick start guide says it is a "Rev. B00"

I bought my own yesterday. There is no information about the version or date of production.

wikidevi has gone walkabout, there may be some place else to check HW components used.

If anyone needs to know which boot part you're on while on Linksys stock, you should be able to find out by opening the Linksys stock gui in a browser, then open another tab and go to -

192.168.1.1/sysinfo.cgi

the boot part should be near the top of the log.

2 Likes

@jwoods is this what you need?

-----U-Boot Data-----
fw_printenv bootdelay: bootdelay=3

fw_printenv mtdparts: mtdparts=mtdparts=armada-nand:2048K(uboot)ro,128K(u_env),256K(s_env),256K@8064K(devinfo),1920K@8320K(sysdiag),80m@10m(kernel),74m@16m(rootfs),80m@90m(alt_kernel),74m@96m(alt_rootfs),160m@10m(ubifs),-@170m(syscfg)

fw_printenv bootcmd: bootcmd=run nandboot

fw_printenv boot_part: boot_part=2

fw_printenv auto_recovery: auto_recovery=yes

fw_printenv mtdparts_version:

EDIT:

-----Boot Data-----
cat /proc/cmdline: console=ttyS0,115200 root=/dev/mtdblock8 ro rootdelay=1 rootfstype=jffs2 earlyprintk mtdparts=armada-nand:2048K(uboot)ro,128K(u_env),256K(s_env),256K@8064K(devinfo),1920K@8320K(sysdiag),80m@10m(kernel),74m@16m(rootfs),80m@90m(alt_kernel),74m@96m(alt_rootfs),160m@10m(ubifs),-@170m(syscfg)

cat /proc/mtd: dev: size erasesize name
mtd0: 00200000 00020000 "uboot"
mtd1: 00020000 00020000 "u_env"
mtd2: 00040000 00020000 "s_env"
mtd3: 00040000 00020000 "devinfo"
mtd4: 001e0000 00020000 "sysdiag"
mtd5: 05000000 00020000 "kernel"
mtd6: 04a00000 00020000 "rootfs"
mtd7: 05000000 00020000 "alt_kernel"
mtd8: 04a00000 00020000 "alt_rootfs"
mtd9: 0a000000 00020000 "ubifs"
mtd10: 05600000 00020000 "syscfg"

@anomeome manufacturing date below
----EPROM Manufacturer Data-----
mfg_data_version = 1
modelNumber = WRT3200ACM-EU
hw_version = 48SAM203.0GA
hw_mac_addr = 60:38************
manufacturer_date = 2017/11/04
serial_number = 1981160************
uuid_key = B951D************
wps_device_pin = 26************

One thing I noticed, my output of cat /proc/mdt looks different (with lede running on my wrt3200):

mtd0: 00200000 00020000 "u-boot"
mtd1: 00020000 00020000 "u_env"
mtd2: 00040000 00020000 "s_env"
mtd3: 00040000 00020000 "devinfo"
mtd4: 001e0000 00020000 "sysdiag"
mtd5: 05000000 00020000 "kernel1"
mtd6: 04a00000 00020000 "ubi"
mtd7: 05000000 00020000 "kernel2"
mtd8: 04a00000 00020000 "rootfs2"
mtd9: 05600000 00020000 "syscfg"
mtd10: 005c0000 00020000 "unused_area"

Not sure if that changes during the first installation of lede, which I somehow doubt because the linksys firmware still has to work on the other partition.

Another thing, which may or may not be totally unrelated: On the official Linksys download site it appears there were some bigger changes in the firmware. Maybe switching the Linksys firmware and then installing lede could work? Here seems to be the download link of the other firmware.