[solved] Trouble installing shelby 18.06.4 on WRT1900ACS

I have a WRT1900ACS router I bought second hand from a reputable seller.

I’ve followed the OEM install instructions to install the latest OpenWRT firmware on a WRT1900ACS (openwrt-18.06.4-mvebu-cortexa9-linksys-wrt1900acs-squashfs-factory.img)
Flashing seems to work fine, up to the reboot. On the reboot the router boots into the stock firmware rather than openWRT.

Not sure if this is an auto revert due to an error or a failure to load the firmware in the first place

I could use some help diagnosing and fixing the issue.

forum posts where not very helpfull, although I did read through both of these:


what I've tried:

  • Google
  • reset, 30/30/30 reset and boot/restore from second boot partition then reflash.
  • renaming the image (as some forum posts suggested)

what I haven't tried yet

  • use an older version of openwrt (cannot find it on the site)

help would be much appreciated


I found the issue. Seller had apparently flashed the firmware for the WRT1900ACSv2 to the device rather than the firmware for WRT1900ACS. this did not impact the normal operation as far as I could tell, but it prevented me from flashing OpenWRT.

reverting to the correct firmware and then flashing OpenWRT solved the issue for me.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.