[SOLVED] Which download for Totolink X5000R Factory Install?

I hope this is a simple question for those that have done it. From reading the Factory install guide I was sure that it is the kernel image named below that I'm suppose to use.


However someone reported on r/openwrt that this exact file bricked their X5000R and it's the sysupgrade download that should be used so now I'm confused. Furthermore there are two sysupgrade.bin with different checksums from the following two links. Which exact download am I suppose to use with the factory firmware?

  1. https://openwrt.org/toh/totolink/x5000r

  2. https://firmware-selector.openwrt.org/?version=21.02.0&target=ramips%2Fmt7621&id=totolink_x5000r

Thank you in advance from an OpenWrt newbie.

İ think you need sysupgrade. Because in x5000r device page only available sysupgrade. And kernel file is testing purposes. İf you will install kernel file after reboot it will get erased. Because its for one time use.


From https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=23be410b3d1267c752bf9f6e5c8f5a514dc562c4

Flash instruction:
Upload the sysupgrade firmware to the firmware upgrade page in vendor fw.

1 Like

Thank you.

Any idea which sys upgrade download I should be using (URL 1 or 2?). Although they are both 6 MB and named similar they have different checksum.


Use the 21.02.0 image.


Thank you too.

1 Like

How flashing went?

1 Like

Thank you all for the pointers. The flashing went well. To get both 2.4G and 5G radio working I did have to ssh in and edit /etc/config/wireless by follow this post

Hopefully this will help other Totolink X5000R users out if they run into the same problem.

Just to summarize. I used the 21.02.0 squashes sysupgrade from the firmware selector page here https://firmware-selector.openwrt.org/?version=21.02.0&target=ramips%2Fmt7621&id=totolink_x5000r


If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.


1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.