X5000R: Unable to create 2.4G networks ("Wireless is not associated")

Hi! So I recently purchased this device and installed 21.02 stable on it.

Photos of the issue here due to new user restriction.

After performing basic configuration I entered the Network - Wireless menu to configure my access points. The following was observed:

  • With the default configuration, two radios are detected (radio0: MT7915E nac, radio1: Generic bgn).
  • See 1.png
  • Activated both APs with their default settings (OpenWrt SSID, no password...) and I could connect my devices.
  • See 2.png
  • Both 2.4G and 5G were displayed as being used. No issues here.
  • See 3.png
  • Anyhow, I proceeded to modify these and have two separate APs for 2.4G and 5G.
  • After saving and rebooting, radio0 and radio1 appear to share the same name and both allow all available configurations (N, AC...). I dont think this is correct.
  • Radio0 displays "Wireless not associated" and only radio1 is currently working with my 5G SSID.
  • See 4.png

Side note: AX not available?

I'm not fully comfortable using uci to modify my settings hence the reason I'm using the web interface, although I can ssh into the machine and post logs and configs upon request.



the problem is that device use same PCI ID for both radios,
so LUCI are lost and write 5ghz configuration to 2ghz radio
also LUCI removes channel configuration etc (channel, htmode, hwmode)

resolution is to write config by hand in /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option cell_density '0'
	option noscan '1'
	option hwmode '11g'
	option channel 'auto'
	option htmode 'HE40'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
	option cell_density '0'
	option hwmode '11a'
	option channel 'auto'
	option htmode 'HE80'

P.S option htmode 'HE80' - for wifi-6 (ax) - no suport in LUCI at all


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.