[Solved] Unable to access LUCI after installing OpenWrt on ASUS RT N56U

I used the ASUS recovery tool and the 18.06.5 upgrade bin file from the location https://openwrt.org/toh/asus/rt-n56u and sucessfullly managd to upload the firmware to the router.

However, after the reboot of the router, I was unable to access - not even telnet worked. I then tried http://openwrt.lan url and saw the following error. Can anyone help? What did I do wrong?

/usr/lib/lua/luci/dispatcher.lua:618: bad argument #1 to 'pairs' (table expected, got nil)
stack traceback:
	[C]: in function 'pairs'
	/usr/lib/lua/luci/dispatcher.lua:618: in function 'createtree'
	/usr/lib/lua/luci/dispatcher.lua:266: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:127: in function </usr/lib/lua/luci/dispatcher.lua:126>

There is no telnet.
Only ssh

So how do I configure the router? Any pointers? Was hoping to use some GUI like padavan has

Log in with ssh.
Edit config files in /etc/config with a text editor (like nano).
wiki: https://openwrt.org/docs/start

But based on the error message, you apparently do have LuCi installed, but it is somehow misconfigured. You might try resetting the settings with "firstboot" command from ssh console.

You could also try

Please report back if any of this solved your problem.

Thanks! I tried this and then it helped me move ahead. I was able to see the web interface but there still seems to be some issue.

I also tried resetting the root password on ssh using the passwd command but it complains with a weird reason as I can see the file

root@OpenWrt:/etc# passwd
Changing password for root
New password:
Retype password:
passwd: /etc/passwd: No such file or directory
passwd: can't update password file /etc/passwd

I suggest you do a clean install, including verification that the downloaded file is intact.

cd /tmp/
wget http://downloads.openwrt.org/releases/18.06.5/targets/ramips/rt3883/openwrt-18.06.5-ramips-rt3883-rt-n56u-squashfs-sysupgrade.bin
sha256sum openwrt-18.06.5-ramips-rt3883-rt-n56u-squashfs-sysupgrade.bin
## check the sha sum against the one published online here: http://downloads.openwrt.org/releases/18.06.5/targets/ramips/rt3883/
# if it does not match: download again, check sha256 again
sysupgrade -n openwrt-18.06.5-ramips-rt3883-rt-n56u-squashfs-sysupgrade.bin

Thanks again. I cleaned up the tmp-cache and then did a hard reboot and was able to go in using the LUCI web interface!

Thanks to you and @hnyman

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.