[Solved] SSH - Connection refused

Hi.

I´m having problem with SSH and SCP access on my router.
The message is: "Connection Refused".

Powered by LuCI Master (git-20.076.61489-c259369) / OpenWrt SNAPSHOT r12632-b78f61c336

Anyone with this problem too?

Regards,
Juliano

Tried update to the latest snapshot, to erase all settings. No lucky. Is something changed in the latest versions?

Any ideias?

Thanks.
Juliano

Hi.

Could be a problem with Dropbear?
I found this message in my System log.

Mon Apr  6 21:22:51 2020 daemon.info procd: Instance dropbear::instance1 s in a crash loop 6 crashes, 0 seconds since last crash
Mon Apr  6 21:23:07 2020 daemon.info procd: Instance dropbear::instance1 s in a crash loop 7 crashes, 0 seconds since last crash

Juliano

Yes, you dropbear daemon (who listens to SSH connections) is crashing. Are there any other.messages in the logs? Post the contents of '/etc/config/dropbear".

I am seeing the same problem. And how can someone get access to '/etc/config/dropbear' file without SSH?

I have one of my openwrt routers doing this to me. Not sure why though.

What I did discover is that if I run nmap against it once, the problem goes away and the connection is accepted.

You could try this and see if you get any mileage.

Try to use the failsafe boot.

I've seen this issue with other programs on snapshots before... @julianocs, did this happen to occur after an upgrade of your firmware?

Hello @lleachii.

I am not having this issue anymore.
I always compile my own builds, latest was yesterday.

It will be necessary to confirm, but after uncheck the option "STRIP UNECESSSARY EXPORTS TO KERNEL" on Global build settings, the issue was gone (even with older snapshots).

Juliano

I assume you're not. I'm not either (at this time)...did you read the thread?

It seems like a race condition...it may come back on another build...

@julianocs

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

2 Likes