[SOLVED] Netgear R7800 not connecting to FIOS ISP

I've got a new Netgear R7800 with OpenWRT/LEDE installed. I'm hoping this router will replace my old Asus RT-N16 running Tomato. But I'm having trouble getting the R7800 to connect to my ISP. My provider is Frontier FIOS (previously Verizon FIOS).

The Asus RT-N16 w/Tomato doesn't really have much in the way of WAN settings. It just does DHCP to get an IP address and connects.

With the R7800/OpenWRT/LEDE, there are a lot of settings for WAN. I assumed at first I could just leave them all blank or at defaults but it seems that doesn't get me a connection. I've set the Protocol to DHCP but I haven't got a clue what, if anything, should go in fields like "Client ID" and "Vendor Class".

On the fiber-side, I'm got a Verizon ECB2200V with an ethernet port that connects to the router. I've tried powering it down for two hours as per some forum discussions I found but that had no effect. I also called Frontier and they forced a lease release and reset my line but still no go. The R7800 simply won't connect but if I swap back to the RT-N16, it requests and gets an IP almost instantly and gets a good connection.

Any suggestions on how to debug the problem with R7800?

Sometimes MAC filtering is being applied on the ISP side. To verify this, simply lookup the MAC of your Asus' WAN port, and override the MAC address of the WAN port of your R7800 with that address. Then see if it can connect.

Client ID and Vendor class can be left empty. If they were required the Asus router would need them as well.

I leaned if you configured a Client ID on the WAN, that the device is locked to the ONT for 2 hours.

I discovered this in DSLReports threads and by testing the results with my OpenWRT and Verizon FiOS ONT. Also, I discovered the anomaly when my ISP first installed service. I was able to use my own (non LEDE) router and PC...but as soon as I hooked up the ISP's router or mine with a Client ID, I had issues with the WAN port locked down.

Three options:

  • Spoof the MAC of the currently working router;
  • Remove the Client ID and wait 2 hours, your ONT will no longer be locked; or
  • Call them and request they immediately drop the lease on their side (you cannot do this anymore with Verizon, you must wait 2 hours).

Hope this helps.

(I understand that you claim the the ISP already dropped the lease; but the instant you reconnected the device with a Client ID, it locked again. And "dropping the lease" at the ONT, doesn't appear to be the same as "dropping the Client ID" at the "headend..." In fact, it's no different that unplugging the ONT for 2 hours...So I would just remove the ID and wait 2 hours.)

How did I test:

  • On the LAN, I changed the MAC on WAN, Internet stopped
  • I changed the MAC back to default and removed Client ID
  • After 2 hours, I was able to change the MAC address, Internet continued to work

Ok, tried using the MAC address from the Asus RT-N16 on the R7800. Still wouldn't connect. I found the log on the R7800 and it shows:

daemon.notice netifd: wan (1127): udhcpc: sending discover

But it never sends a request for an IP.

On the other hand, the Tomato log on the Asus shows this during the successful connect:

daemon.info dnsmasq-dhcp[477]: DHCPDISCOVER(br0) 9c:b6:d0:ef:6a:fd
daemon.info dnsmasq-dhcp[477]: DHCPOFFER(br0) 9c:b6:d0:ef:6a:fd
daemon.info dnsmasq-dhcp[477]: DHCPREQUEST(br0) 9c:b6:d0:ef:6a:fd

So it looks like the R7800 isn't even trying to get an IP for some reason.

I see the other suggestion that I need to do both using the old MAC address and waiting two hours. I haven't got any better ideas, so I'll give that a try next. I'm not optimistic just because I don't see any way with Tomato on the Asus to even set a Client ID, so it seems unlikely that's the problem. But I might as well give it a shot!

In that case...what are you giving a shot...I thought the issue was Client ID. Did you set one on the OpenWRT and it wont connect?

Are you saying you're only expericing a MAC issue?

Using the old MAC address in the R7800 plus waiting two hours still doesn't do it. The R7800 still never sends an IP request to the FIOS network, it just sends the discover. But as soon as I switched back to my old router with Tomato, it connected immediately again.

Am I misunderstanding what I'm supposed to do for this two-hour FIOS wait? Do I need to power down the ECB2200V during the two hours or just leave things powered and wait for the time to elapse?

Also, any ideas on how I can verify that the R7800 isn't experiencing a hardware issue? I'm thinking maybe plug the WAN port on the R7800 into the LAN side of RT-N16 just to see if it can get an IP and bring the eth0 port up.

My problem is that I have a new R7800 with OpenWRT/LEDE and I can't get it to connect to my FIOS. My old Asus RT-N16 w/Tomato works fine though. I have no idea what the issue is, that's why I'm here, looking for advice on how to fix the problem. I have not tried setting a Client ID because I don't know what value to put in that field. I have tried changing the MAC value from the original one included with the R7800 to the one used by the RT-N16 but that didn't help. I have also tried waiting two hours (and now I've tried old MAC + waiting two hours, still no go).

When I was on Verizon I had to remove the '-C' mentioned in the ticket below to get it work reliably in Dallas, TX on older versions of OpenWrt 15.x and below:


Verizon sold Dallas, TX area to Frontier and I currently don't have that problem. Good luck!

SSH in to the router and run the following...

cat /etc/config/network

Post the results.

OK...I understand now...let's be clear...here's my log (I performed a reboot just for you):

Mon Mar 26 10:20:43 2018 daemon.notice netifd: wan (1184): udhcpc: started, v1.25.1
Mon Mar 26 10:20:43 2018 daemon.notice netifd: wan (1184): udhcpc: sending discover
Mon Mar 26 10:20:43 2018 daemon.notice netifd: wan (1184): udhcpc: sending select for 71.xxx.xxx.xxx
Mon Mar 26 10:20:43 2018 daemon.notice netifd: wan (1184): udhcpc: lease of 71.xxx.xxx.xxx obtained, lease time 7200

From: https://en.wikipedia.org/wiki/Dynamic_Host_Configuration_Protocol

DHCP operations fall into four phases: server discovery, IP lease offer, IP lease request, and IP lease acknowledgement. These stages are often abbreviated as DORA for discovery, offer, request, and acknowledgement.

Also, I noticed your offered WAN IP on the Tomato was a address...please confirm that's not the LAN on your OpenWRT!

I agree, we'd need to see your configs.

Oops. I hadn't even noticed those 192.* addresses in the Tomato log. Those are probably the DHCP daemon in Tomato handling requests from stuff on my LAN, not Tomato getting its own IP from the upstream WAN. Just ignore those, they're likely not relevant to the discussion, sorry! I guess all I know for sure then is that Tomato does get an IP from FIOS but OpenWRT/LEDE doesn't

At present I don't think SSH is set up on OpenWRT/LEDE, I was hoping to avoid having to do any command line stuff and get it working through the web UI. Don't suppose there's some way on the UI to get the info you want? Would it not be whatever is set up by default or is the question whether something about my setup in UI caused an unexpected change in /etc/config/network? Basically I just loaded the firmware image, plugged in the ethernet cable, and then checked that DHCP was the selected protocol for the WAN port.

In any case, I'll take another look at things when I get home this evening...

It's setup by default.

It should be whatever the default is...but that default config should be working too.

You can provide a photo of the various pages; but most of those on the forum who help (i.e. @jwoods), request copies of the configs.

Sorry for the delay in replying, finally got a chance to work on this problem again this weekend. I did manage to ssh to the new R7800 openwrt/lede router and find the /etc/config/network file, which I've copied below. I've set the hostname to 'tomato' and the MAC to '20:CF:30:C6:2E:83' because those are the values used successfully by my current router, the Asus RT-N16 w/Tomato. Still no luck connecting it to FIOS, however.

Is there any way to put udhcpc into a debug or verbose mode where it would log the traffic between it and FIOS so maybe we could discover more about why it's unable to get an IP?

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'
	option ula_prefix 'fd45:fb49:6604::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1'
	option proto 'static'
	option ipaddr ''
	option netmask ''
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'
	option macaddr '20:CF:30:C6:2E:83'
	option hostname 'tomato'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 0'

One other question. On my old router with Tomato, it's easy to do a release / renew on the WAN connection by clicking the "release" or "renew" buttons as needed and it displays the WAN status as the process happens. Where is the equivalent interface in the OpenWRT/LEDE UI to release or renew the dhcp lease on the WAN?

I ask because I found one forum discussion saying that swapping routers on FIOS is tricky because you have to explicitly do a release on the old router, then power it down, then swap to the new router and do a renew. It's no problem doing the release portion on Tomato, but when I plug in the OpenWRT/LEDE router, it still doesn't connect, and I can't find a "renew" button in the UI. If I later swap back to the Tomato router, it shows the FIOS connection as still in a disconnected state but reconnects as soon as I hit the "renew" button. Maybe if I could find a way to force OpenWRT/LEDE to do a release/renew, it would finally wake up and connect to FIOS.

There is none.

I do the following in the Local Startup section...

# Release WAN IP, wait 30 seconds, renew WAN IP (should get a new IP)

killall -SIGUSR2 udhcpc
sleep 30
killall -SIGUSR1 udhcpc

What is in between the R7800 and the ONT?

Do you have Internet only FIOS, or TV and phone?

Thanks, tried SSHing in and doing the renew manually after power up but still no go, just sits there and won't connect. :frowning:

Also tried the OpenWRT patch on this bug report page but that didn't help either.

What is in between the R7800 and the ONT?

The Fios equipment connects to a Verizon ECB2200V via coax and from there an Ethernet cable to my router (either my old Asus/Tomato or the new R7800/OpenWRT/LEDE).

Do you have Internet only FIOS, or TV and phone?

All three. Internet, TV, and phone service.

I tried one more experiment that may provide some useful information. Here's what I did:

  1. attached my old Asus/Tomato router to the FIOS connection
  2. got a new IP from FIOS and verified it was working
  3. wrote down the IP, gateway, etc.
  4. swapped out routers and connected the R7800/OpenWRT/LEDE
  5. configured the WAN interface on the R7800 as static using the info acquired by the Asus

Everything works fine and I have full access to FIOS through the R7800. Only good as a test obviously since it would break as soon as the lease expires but interesting. The only weird thing I noticed is that the WAN interface continued to be red even though it working. I expected it to turn green once it was connected like the LAN interface. Not sure what's up with that, maybe it realizes I'm doing something weird?

Next I switched the WAN interface back to DHCP and it immediately lost the IP, went down, and would not come back up. So I think this eliminates any remaining suspicion that I have a hardware issue like a bad ethernet port on the R7800. Looks to me like the DHCP software on OpenWRT is where the breakage is. For some reason it's just incapable of functioning with the FIOS DHCP servers. I wonder what DHCP software Tomato uses? Different than OpenWRT?

You need to use the MAC address of the R7800.

Call Frontier and have them reset the lease.

I've tried both MAC addresses. Neither works. Also I tried having Frontier reset the lease over the phone last week and that didn't help. Anyway, I can release it and get a new IP easily enough with my old router, or release the current one only but not get a new one, so I can swap routers to do the renew. So I really don't think the problem is on the FIOS end at this point. I think it's with udhcpc.

My guess is configuration.

I would recommend resetting OpenWrt/LEDE to factory settings, and reconfigure from scratch.

Start with the simplest configuration and backup each time before making a change.