R7800 WAN DHCP no IPv4 address


When replacing my current router with the R7800 the router does not get an IP address from my ISP.
First I restored a backup and tested, now I'm back to factory settings (18.06.2) and still no ip adress. Only thing I changed was the password.

Read [SOLVED] Netgear R7800 not connecting to FIOS ISP but I don't understand or see what the solution was.

What is the best next step?
Does trying another dhcp client makes any difference? udhcpc works on current router (eth1) not on r7800 (eth0.2)
Or is the default configuration wrong and what should I change?
Thanks for your help.

Use MAC address of the old router.

Hi vgaetera,

Read that also in the link above but I don't think that's the problem because I replaced my router before successfully.
That were two Netgear WNDR 3800's same ISP.
I will try and see what happens.

If you are on Verizon, there's at least a 2 hour timeout for any device that uses a DHCP Client ID.

If you omit that ID, the device will release instantly. Be mindful of that if you re-install your ISP's router out of frustration.

1 Like

See also:

@vgaetera your suggestion solved it.
Don't know why my first replace was successful right the first time. I can't remember that I waited till the lease time expired.
But hey, it works. Thanks.

@lleachii. It is not out of frustration. I hope to get a little more speed when using a VPN.

1 Like

You missed what I said. If you re-install your ISP's router, you have a 2 hour lease/waiting period. Other devices may not work!

I would say that not getting an IPv4 address is frustrating.


Be careful when changing vlans. Default wan device is eth0.2 (vlan). DHCP works.
I deleted the vlan and used eth0.
DHCP does not works.

Did cost me a lot of time to realize this so hopefully this is helpful to anyone.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.