[Solved] Need your help to revert TP-Link TD-W8968 v3 firmware

Hi folks!
I loaded Openwrt firmware (openwrt-18.06.2-brcm63xx-generic-FAST2704N-squashfs-cfe.bin) in my old router (tplink w8968 v3). Everything was working fine except for wifi and adsl. Realizing these limitations, I wanted to revert firmware back to its original state. So I downloaded the .bin file from Tplink website and generated stripped .bin file with 'dd' command. Tried to flash that with CFE bootloader, which didn't accept the image file (says 'illegal image'). Also tried out sysupgrade and mtd commands from ssh but it didn't work. Router's bootloader (cfe) is still intact and I can still flash openwrt image and boot it successfully.

Btw I have put block size value as 512 and tried these skip parameters 128,129,256 & 257 in the dd command to generate stripped .bin files. All of them did not work. After flashing these images, Router showed only the CFE webpage after reboot.

Please let me know how to get back stock firmware running on this router.

1 Like

If the CFE bootloader is intact and you can access the recovery webpage then I'd suggest to use an older TpLink firmware and just flash it without stripping. It should work for you.

These firmwares from tplink site doesn't contain the word 'boot' in the file name. So I tried loading it directly through CFE at first. But it failed saying 'illegal image'. Later I read some articles on openwrt wiki and on friedzombie site about stripping the .bin files. I'm not sure on how many bytes should I strip from the bin file to make it a valid file for the CFE loader.

Here's some info regarding the partitions:

*Edited the post to replace the screenshot with a right one :slight_smile:

2 Likes

Cut first 512 bytes from official firmware and inject via CFE.

are you succeeded in reverting back to original firmware if yes please send me stripped firmware so i can also revert back to original firmware by CFE method . my router is also v3 td-8968 i am also stuck on openwrt. please help please

1 Like

i have found the solution flash this file i have removed tplink header info from firmware just like openwrt has, :slight_smile: now firmware is flashing even from cfe recovery
link :slight_smile: https://drive.google.com/file/d/14Iq4QQz0ZK98x3esZlKQIGWtmCOA-EXi/view?usp=sharing

2 Likes

Oh, that's great. I'll give it a try.

@avinashsuwal Thanks a lot for the stripped bin file. I tried flashing through CFE and it worked. Now it is back to its default. Later I updated the firmware to 150512 v3 through TP Link's web interface :slight_smile:

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.