Need your help to revert to TP-Link TD-W8968 v4 firmware

Hello, I have been using OpenWrt for 3 years now, everything (almost) is working but I use an ADSL connection so to get OpenWrt working I have a secondary modem connected to the ADSL cable that I am running in Bridge mode and in turn I am connecting it to the main modem that is running OpenWrt, but the secondary modem is really old and I would like to test my main modem's original firmware to see if there is a difference in latency.
On an old post, someone ( @avinashsuwal [Solved] Need your help to revert TP-Link TD-W8968 v3 firmware ) managed to make a working framework for the TP-Link TD-W8968 V3 by "removing tplink header info from firmware just like openwrt has" and if someone knows how to make one for the TP-Link TD-W8968 v4 that would be greatly appreciated. Thank you.
(Ps: I have tried the V3 firmware that was provided in the linked post and it worked, however, I couldn't establish any connecting to my IPS.)

So since no one cared to help, I did some research and ended up taking the original .bin file of TP-Link TD-W8968 V3 firmware and comparing its binary with that of the modified v3 firmware, then I used this website (https://hexed.it/) to edit the TP-Link TD-W8968 V4 .bin file and removed the first lines of binaries as shown in the picture below. I was able to use it to revert to the original firmware.
Here is the modified firmware if someone wants it: https://drive.google.com/open?id=1w3aR-D9YCnUcIq6fsbQ-5U128gwG9P-X

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.