[Solved] Luci overview not loading in 21.02 rc2

It seems there is some issue with overview page loading.
Steps to reproduce:

  1. Login to openwrt (preview will most likely load fine).
  2. Close tab with loaded openwrt.
  3. Open new tab and load openwrt there (you can do that either in incognito mode or normal mode).
    Result, a blank page is loading beneath the menu.
    If you reload, the preview page will show.
    Also if you choose System->Overview from the menu.

Reproduces in both Palemoon and Google Chrome.

This isn’t a 21.02-rc2 fault.

It was a tread of this bug in the forum a while back and the bug is actually a 19.07.x thing.
If I remember right from that tread it had something to do with the SSL cert🤔

1 Like

It wasn’t easy but I found it eventually😃

1 Like

So the solution is to revert to plain http?
Because there are several users in that thread reporting the same behavior with plain http.

Http has problems also.

Another thing you could try is to make a real https certificate according to the user guide so the luci page is actually are seen as secure.

But I guess the problem itself is very low priority since luci works.

I could do that sure, but if the problem is evident for plain http users, is it even 100% the ssl problem?
In other words, will creating a true certificate and importing it, actually solve the problem?

Do you run luci on http or https?

Right now on https.

I don’t think anyone has really put their mind to it to dig out what works and what doesn’t so the fault is pinpointed. But if you uninstall luci-ssl then it should work if the hypothesis of https is right.
The thing I have noticed these last months when experimenting with 21.02 is that the luci start page loads without problem if I don’t have a password. If that is a coincidence I don’t know.

You mean if the openwrt doesn't have a password set?

1 Like

Ok so I got around to testing http vs https theory and glad to report http actually works fine.
All I needed to do was to disable http to https redirection and access using http.
No blank pages there.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.