[Solved] How to rollback R8000 to factory (oem) firmware?

I recently got a Linksys R8000 and tried OpenWRT but i would like to roll it back to oem firmware so i can return the router and get one better suited for OpenWRT.
I downloaded the oem firmware but how do i flash the oem firmware?
Router: https://openwrt.org/toh/netgear/r8000
Firmware: https://www.downloads.netgear.com/files/GDC/R8000/R8000-V1.0.4.76_10.1.82.zip

I installed OpenWRT 21.02.0 from the OEM firmware by choosing the .chk file.

You can try the instructions posted at Netgear: Reinstall the firmware on a router ...


The link to tftp is dead and i use Linux as OS.
Is that still the preferred to flash OEM firmware? Then i need to borrow a windows based computer but i still need tftp2.
I guess that one can't just use the " Flash new firmware image" from within OpenWRT or is it possible?
Should i perform a reset before flashing?
Should i use ethernet cable or Wi-Fi?
Where can i find tftp2.exe?
In my linux install i got tftp-hpa can it be used as a drop-in replacement for tftp?

1 Like

A TFTP client should be included with any desktop Linux. Try tftp on the CLI. Usually it is tftp-hpa.

There is also nmrpflash, a Linux equivalent to the Netgear recovery program.


I did reset the OpenWRT so there's no password and connected the router with en ethernet cable to port 1.
I tried tftp on windows with no success.
I have tried tftp-hpa and atftp in linux but i had no sucess it only times out no mater what i try.
I did set eth0 to static "sudo ifconfig eth0 netmask up"
I tried "atftp --option "mode octet" --option "timeout 90" --verbose --trace -p -l R8000-V1.0.4.76_10.1.82.chk"
I turned off the router and restarted an run the tftp before it booted up but i had no luck.
Maybe I'm missing something och doing it wrong cause it wont work when i following the instructions Reinstall the firmware on a router ...
Will take a look at nmrpflash instead

For either method, you have to activate recovery mode. Hold down the reset button while plugging in the power, and keep holding it until the power LED turns orange.

1 Like
sudo nmrpflash -i eth0 -f R8000-V1.0.4.76_10.1.82.chk
Waiting for Ethernet connection.
Advertising NMRP server on eth0 ... |
Received TFTP_UL_REQ while waiting for CONF_REQ!
Received upload request without filename.
Uploading R8000-V1.0.4.76_10.1.82.chk ... OK (30122042 b)
Waiting for remote to respond.
Received keep-alive request (28).  
Remote finished. Closing connection.
Reboot your device now.

nmrpflash was a way better tool and it was able to flash the device.
I didin't hold the reset button only started the device and run nmrpflash.
First nmrpflash timedout but i quickly ran it again and it worked.

Thanks to you all that took time to giude me to be able to reflash OEM firmware, i write this from the router with OEM firmware.
It was real easy to flash with nmrpflash.

tftp would probably work if i "Hold down the reset button while plugging in the power, and keep holding it until the power LED turns orange".
It seems like it was a timing problem when i only restarted and it wasn't able to time the exact moment for the flash to work, it would have been much better to start it recovery mode.
Well i learned a lot and now i know how i should have done.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Thanks! :slight_smile: