Factory restore Linksys MX4200v1

Hey everyone,

I'm looking to flash my MX4200v1 back to stock firmware as I'm having a lot of trouble with the current snapshot release, but I can't figure out how to do that without access to the serial console. So far, I've tried following this article, this article, this one, this one, and this one, but none of them seem to contain all the necessary information / any information (some just link to dead resources).

So far, what I gathered is that per my understanding, I need to:

  • download the stock firmware (I got mine from here),
  • set my local machine's IP to a specific value (couldn't find any information on which one for Linksys),
  • connect my local machine to the router via Ethernet,
  • start a TFTP server on my local machine (I'm on macOS and there is a lot of talk on which server to use or not to use, but those recommendations are partially >5 years old, so I'm not sure which TFTP server to use),
  • potentially rename the firmware file (I read somewhere that Linksys expects it to be called chiron.img, but haven't seen any talk about this elsewhere),
  • and then somehow cause the router to fetch the firmware from my TFTP server (I tried this method, but that didn't work - wrong IP? Wrong filename? Wrong approach? The LED just kept flashing in orange for a good five minutes before I eventually expected that whatever I did was probably not the right thing and unplugged it).

Can somebody help me, especially with the aspects in bold? I'm looking to understand which IP I should set my local machine to, which TFTP server to use (on macOS), what to name the firmware file, and how to make the router fetch that file and flash it.

Any and all help is greatly appreciated!

Alternatively, if there’s a different method for restoring the stock firmware, I’d be happy to know about that, too! Anything to return the router to its factory defaults.

Did you resolve this?

Try looking to the link below or contacting the poster for help?
@lytr

No I didn't, but mainly because I made some changes as to how I want to use the router, so I went back towards fixing up my installation OpenWRT rather than throwing it off the unit.

I had actually also found that thread, but I found it a little hard to follow, and there was repeated mention of the serial console, so after cracking my brain at it for a while I figured I'm not deep enough in the topic yet to make sense of what was being discussed there.

Still, thanks for the tip!

1 Like

I hear you.
It would be nice to know how to restore back to v1 factory image without serial.

1 Like

Maybe somebody will be able to help! I see you already posted in this thread; I feel like if anybody knows, it must be somebody in that thread.

I had actually posted there and then deleted it again because I felt it was a little off-topic in the context of the thread, but I think it might also be valuable information for others to understand how to reset the device back to its original state.

Either way, good luck!

1 Like