Setup WAN port as tagged VLAN 10 for fiber IPoE/DHCP

Hi IM trying to set up a fibre connection but the vlan setup differs to all the guides and pictures i believe because of DSA that come in in 21.02.

I wish to setup wan port as tagged vlan 10 for fibre IPoE/DHCP
all the guides show the pre DSA setup:

but i have this :

I have set it up like this but is still does not work and I dont know how to Tag the port and i dont know why wan is not present in the devices menu:

see this tutorial for DSA switch config

I have read that but I am still lost.

this is my connection settings from my isp:

  • WAN Connection Type: DHCP (Automatic IP/Dynamic IP/IP over Ethernet)
  • 802.1Q: Enabled
  • VLAN ID (802.1Q): 10
  • 802.1P (Priority): 0
  • IP Version: IPv4 or IPv6
  • MTU Size: 1492 or 1500
  • NAT: Enabled

Im guessing this is what i need to do from cli ?
the luci interface is confusing and i dont seem to have wan listed in my DSA device config?

config interface 'wan'
	option ifname 'wan.10'
	option proto 'dhcp'
	option peerdns '0'
	list dns '8.8.8.8'
	list dns '8.8.4.4'

config interface 'wan6'
	option ifname 'wan'
	option proto 'dhcpv6'

config device
	option name 'wan.10'
	option type '8021q'
	option ifname 'wan'
	option vid '10'

The names of the ports will vary depending on the hardware. Most 4+1 port routers name them wan, lan1 lan2 lan3 lan4. If it's an Edgerouter-X they are named eth0 eth1 etc even though they are still ports on the MT7621 DSA switch, since the case is marked with those names.

Since you've declared a device named wan.10, you would use option device here not option ifname. And in the device definition, the base port for wan.10 would be eth1 if it's an Edgerouter-X there is no hardware port named 'wan'.

It used to work to simply change the device named directly in the wan config to add the VLAN tag number-- no need to declare an 802.1q device explicitly. This worked if the port is dedicated only for wan, and you don't need to bridge or hardware switch other VLANs on it anywhere.

I believe I have an edgerouter and my ports are named eth0 and eth1

So the correct way to set it up would be something like this ?:

config device
	option name 'wan.10'
	option type '8021q'
	option ifname 'eht1'
	option vid '10'

config interface 'wan'
	option device 'eth1.10'
	option proto 'dhcp'


No you don't need an 8021q block.

As there are only two ports, is it an x86 type device where each port is individually connected to the CPU? In that case you just put eth1.10 in the wan section and it will work. Don't also have a plain eth1 with no VLAN number anywhere in the config.

1 Like

Seems if you want a "good" answer, you need to tell us the one thing that is missing from your question

your hardware

1 Like

It is a wallystech DR4029 routerboard.

https://wallystech.com/products_show.php?id=1&lm=1

It has an IPQ4029 chip. That is a special case when it comes to VLANs. I've never actually owned one but you should search on the IPQ4029 and the related IPQ4019.

Running a trunk firmware may be better than 21.02.0 as the DSA for those chips is still under development.

the device is not officially supported i have created my own repo based on patches by robert marko here:

professor-jonny/pj_openwrt: This repository is a fork of https://git.openwrt.org/openwrt/openwrt.git with support for Wallystech ipq40X9 devices. (github.com)

I think i need to intergrate this patch ?
ipq40xx: introduce proper ethernet and DSA support by robimarko · Pull Request #4721 · openwrt/openwrt (github.com)

edit yes this fixed my issue.

@professor_jonny Hello dear sir. Have you manage to work this out?
Do you have a simple steps how to do this and is it even possible via GUI luci?
Thanks. I have the same problem and I do not know how to do this. My device is GL-iNet SF-1200.

Sorry I cant help you much as my chipset is torally different to yours.

I dont know if dsa or swconfig is used on upur platform or any thing about it really other than it is mips not arm.

If the platform us dupported you should be able to use swconfig or dsa from luci to connect to your broadband service.
There is tutiorials for both on the wiki and forum how to set it up.

Dsa is prity new so lots of info around is related to swconfig.

The chipset in mine the switch ports were hard coded as a workaround and vlan tagging was not supported because of this.
with rob's above patches it fixed dsa and alliwed proper vlan tagging.

Thanks for the response

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.