Restoring VLAN for Bell/Aliant ISP in 21.02 (DSA)

I am running into difficulties trying to re-configure the VLAN setup I need to get internet access through my ISP (Bell Aliant) on 21.02. My router is a Linksys WRT3200ACM.

Below is what I had under 19.07:

I did read the "DSA Mini-Tutorial" and the "Converting to DSA" docs and I managed to add the WAN to the br-lan interface under 21.02. Each time I create the 2 VLAN on LUCI, connection with the router is lost and either the changes get reverted automatically or I have to reset the router (losing all configs and starting again from scratch).

I suspect I am missing something but I haven't been able to figure it out yet. Any pointers would be greatly appreciated!

I am still banging my head on this one.

Below is the swconfig I had under OpenWRT 19.07 (this mapped to the screenshot in my previous post).

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option proto 'dhcp'
	option ifname 'eth1.35'
	option peerdns '0'
	option macaddr 'xx:xx:xx:xx:xx:xx'
	list dns '192.168.1.3'

config interface 'wan6'
	option proto 'dhcpv6'
	option ifname 'eth1.35'
	option reqprefix 'auto'
	option reqaddress 'try'
	option peerdns '0'
	option macaddr 'xx:xx:xx:xx:xx:xx'
	list dns '192.168.1.3'
	list dns 'fdb5:19c3:1c45:0:d858:687c:1d42:8877'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '5t 3 2 1 0'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '6t 4t'
	option vid '35'

Under 21.02, here is what I was doing to attempt to re-create the config (LUCI):

  • Open Network - Interfaces - Devices
  • Edit br-lan and add the "wan"
  • Open the Bridge VLAN filtering tab and edit as follows

Attempting to "save and apply" this config ALWAYS result in an unreachable router (and either configs that get reverted automatically or a router that needs a hardware reset to become reachable again).

What I am missing? The “Converting to DSA” docs mentions:
Back with swconfig we had CPU ports, eth0/eth1, to tag the CPU in a VLAN (i.e. eth0.2 or eth1.2 for VLAN ID 2).

With DSA, we just create a subinterface of the bridge interface (i.e. br0.2) to get the router (CPU) involved in that VLAN.

If you specify br0.2 as the “Device” on Network → Interfaces section, OpenWrt will automatically create a subinterface of br0 with VLAN ID 2.

... so does this means I need to create a new VLAN (802.1q) device and then proceed with the bridged device VLAN filtering after?

Been searching the forums to similar topics and this is very close to what I am trying to do:

In my case, I need the WAN port as tagged VLAN 35.

Below is my config so far (missing the VLAN part):

config device
	option name 'wan'
	option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option peerdns '0'
	list dns '192.168.1.3'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
	option peerdns '0'
	list dns '192.168.1.3'

The thread above suggests that I need to specify option device 'eth1.35' in the wan section but I am not clear if anything else is needed. I would like to have some validation before I try again as I end up having to revert to 19.07 each time I am unsuccessful in restoring internet connectivity under 20.02.

Not sure why you tagged my response, and that thread is about the "wallystech DR4029" router - which apparently is a "special case" when it comes to VLANS (if you read the post 2 after mine) - so, probably not relevant to your router

Because it's a completely different device - though, it may still hold true, I wouldn't count on it

why? if you mess up WAN, you'd still have LAN connectivity to undo the changes

Seems it should be this simple if all you need is the WAN tagged.

All right - got another go at it today and the solution was indeed to have the WAN port as tagged VLAN 25 like so:

config interface 'wan'
	option device 'wan.35'
	[...]

config interface 'wan6'
	option device 'wan.35'
	[...]

Doing this restored internet connectivity with my ISP and allowed me to configure the rest. I did not even have to worry about replicating the setup in the screenshot in my original post.

Everything (firewall routes to various servers and access to OpenVPN server) seems to be working fine at this point.

Thanks all for your help - this is a setup I had done years ago and never had to redo until today. Took me a while to re-learn how to do it under DSA.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.