Roaming on router + APs

If my router is a NanoPi R4S and I have two APs for WiFi I need to configure the roaming settings (802.11krv) on the NanoPI R4S since the APs are bumd APs, am I right?

Thank you

IMO, roaming standards (802.11k/r/v) are not always the best method to get roaming to work. For those that do work, it can create a slightly better roaming experience. But some devices just don't work well with them enabled, and it can actually cause additional issues.

My recommendation is to start without those features and setup your APs for high performance standard roaming. This involves (to the best extent possible) placing your APs in the optimal locations and then tuning the power levels (reduce them!) and channels (scan for channels that are not heavily utilized in your physical area, then make sure you use different channels on each AP). Once that is working well, you can try adding the other standards.

Check out this video for a good run through of the steps

In my case both APs have signal all over the place and the clients only change the signal when it is really really bad but the client keep the AP with bad signal. I can't have a video call while walk around the house. If I need to tune the APs to have a good define limit between the APs I'll have poor signal on some locations.

I test a tplink mesh system (consumer grade not omada) at a friends house and it worked really well with the same client (mobile phone) I use at home.

Roaming is a client side process. Therefore, the most important aspect of roaming is to set the APs such that the clients make smart roaming decisions. Lower power levels are a key part of this -- the signal quality needs to fall off sufficiently quickly in the overlap areas to make the client 'want' to roam.

Obviously the power levels you need to run are very dependent on the floor plan of your space and the construction materials as well as the placement options you have for your APs. You may need to move the APs a bit, or add another AP or two in order to get the best physical coverage and tuning options (if those are options you can entertain).

Typically speaking, the addition of the roaming standards work on-top of a well tuned wifi environment. They won't resolve issues related to poor tuning of the radios.

2 Likes

Exactly, i was struggling with roaming after I changed my routers and started from scratch ( forgot how painfull the roaming setup was). I've put both of them to max power + 802.11 k,v,s,r and relayed on usteer to guide the clients and especially my laptop during MS Teams calls.
Well - it doesn't work, altrough handshaking was reported to be fine.
Lowering the power levels made the trick.
Kr
K

1 Like

But with 802.11kvr or without?

I've only ever used 802.11r, but it has worked flawlessly for all my client devices, except for a Nintendo Switch, which seems to stick to the original AP.

APs also play a role: https://learn.microsoft.com/en-us/windows-hardware/drivers/network/fast-roaming-with-802-11k--802-11v--and-802-11r https://support.apple.com/en-us/HT202628 https://www.mist.com/documentation/802-11k-802-11r-802-11v/

For roaming you will want to tweak power and possibly antenna orientation of the individual AP.

For me 802.11r is sufficient (3 APs wired to router).

You have to enable it on router too?

No, it’s over the air between the APs

1 Like

With kvr and usteer. However if I do not adjust the wifi power level and both routers are on max, the logs and the wifi signals on the client side looks like roaming works, but the MS Teams connection freezes for 5-6 seconds.

1 Like

I've roaming active in 4 AP's (Tp-Link EAP-225) and I get:

daemon.err hostapd: nl80211: kernel reports: key addition failed

@metropt Do you get the same error message in your log?

I didn't set up yet.

See here:

for a discussion.

1 Like

I just figured I'd raise awareness of this thread where it appears that 802.11r may have caused difficulties with a specific device:

While this may not be the absolute root cause, it does illustrate that these roaming 'enhancements' do not always improve the performance of the network.

1 Like

I think the problem here is not the defined protocol but the implementation.

That may be. But the larger point is that sometimes the KISS principle is really the best.

To answer your question directly : yes, kvr are setup on the AP's.
There is no "toggle" in openWRT to setup a device as AP or Router.
In an AP luci, you get an extra "wireless" menu entry. As you're using an R4S, you haven't seen that menu yet, hence your question.