802.11r Fast Transitioning / Roaming - Problem with Internet access after roam

Hello community!

I have a question regarding Fast Transitioning / Roaming on 22.03.0

My setup:

One modem (Fritzbox 7530AX) connected to the internet, running the only DHCP in the network, providing static IPs to three Archer C6 (OpenWRT 22.03.0) which are connected via LAN.

The Archer C6s have DHCP disabled and work as APs in 3 different floors.

I installed WPAD on all of those, enabled FT, they all share the same Mobility Domain (1234) and it provides FT just fine (at least that is what I think) with one huge problem:

After going from one floor to another, the WLAN switches just fine in nearly realtime, I have the best signal, but I lack Internet connection. I have to cycle the WIFI (off/on) on my phone to get access again.

My Phone (Xiaomi MI9SE) in Wifi-Analyzer sees that FT is enabled.

I have no idea how to debug this situation.

If you need any more information, I will happily provide it, but I do not know what exactly is needed.

Thank you very much in advance from Germany


Have the same kind of setup, and it works flawlessly, on Archer C2600s.
I however removed wpad, and installed hostapd instead of hostapd-mini.

1 Like

Thanks for your reply! So you mean you removed wpad completely and installed hostapd after removing hostapd-mini? I will try this for sure, as I was under the impression that wpad is needed in order for fast-transitioning to work in the first place. I will report back.
Best and thx!

either that, or they never roam :wink:

if I kick off a device from any of the two APs, it instantly pops up on the other one.
I can do it while my son is gaming online, he doesn't notice anything ...

a detail I forgot to mention in my initial reply, my routers/APs are still running 19.07.

1 Like

I think I owe you one. I did as you suggested, removed wpad completely, removed hostapd* and installed hostapd, rebooted all three routers and it works exactly like I imagined.

Hope it stays this way, will do some real-life-testing, but I did some cardio already (a.k.a running up and down the stairs for 15min straight) and I always had connection and never had to restart WiFi.

Thanks again! I will edit my question to solved and insert the steps for anyone having this problem in the future.


proper wifi, it's worth dying for :wink:


I've got two wifi5 (ac) APs and one wifi6 (ax) and I have similar issues when a device moves to the wifi6 AP: the phone reports no Internet and I have to reconnect. I'm fairly sure fast roaming works between the two wifi5 APs. I have hostapd-common and wpad-wolfssl installed on all three.

I also have usteer installed and setup. It seems tricky to debug whether that actually does much but my understanding is that it is supposed to force devices to switch when they are moved. Do you have any recommendations for a phone app for testing whether the fast roaming actually works as intended (preferably free/open and in f-droid).

Hey there @okapi , I use https://f-droid.org/de/packages/com.vrem.wifianalyzer/ - What I do is just checking the ID (XX:XX:XX:XX:XX:XX) of the WLAN Connection in question , and then moving to another floor - I check whether the ID is changing to be sure that the WLAN Transitioning works - It does so far, fingers crossed. I got some situations where it did not, but I am currently tweaking with the timeout settings.

If you want to check if FT is enabled at all for your devices (something I was questioning a lot when starting the whole thing in the beginning, and never knew) - just check the WLAN in WifiAnalyzer and see if it reads something like "WPA2-PSK+FT"

Currently looking into the usteer package, never heard of it as of yet.

Do you have multiple DHCP servers running? I noticed that all APs work as intended (at least with roaming between the different WLANS) when using "dumb ap" mode without any DHCP on their side.


WifiAnalyzer seems useful, thanks. I noticed that for the 5GHz band, my APs report as "WPA2-PSK-CCMP][RSN-PSK+FT/PSK+K-SHA256+SAE+FT/SAE-CCMP][ESS]". So no +FT for the first part. I changed encryption for 5GHz to just "psk2" to match that for 2.4GHz but that doesn't seem to help. I even tried turning off the 5GHz networks and I get the same problem. When watching it, it almost seems that the fast transition works but then the Android phone tries to check it has an Internet connection and concludes that it doesn't I can see it doing a DNS lookup for google.com with tcpdump. So it displays "Connected without Internet", then decides to disconnect, marks that AP as "Couldn't get IP address". A fresh connection to it does work and gets an IP. The Fast Transition works perfectly going in the other direction - from the wifi6 to the wifi5 AP.

I definitely only have the one DHCP server running. Even disabled it temporarily to make absolutely sure there wasn't another somewhere on the network.

Does it matter if you have wpad-basic-wolfssl and hostapd-common installed ?

1 Like

I'm curious about this detail since I think I have the same issue but run 22.03 instead of 19.07. Instead of trying what happens if I replace wpad-openssl with hostapd-openssl and getting complaints from my family members or ask someone with experience if there have been (significant) changes between 19.07 and 22.03 in regards to wpad/hostapd?

No idea, probably :slight_smile:

See this post for details on an incomplete Linux core mac80211 patch (aka bug) that was implemented between 19.07 and 22.03. This has impacted Fast Transition FT which used to work well for me, but hasn't since.

@fodiator has a patch that he is working to develop further to the point where it will be accepted by OpenWRT and hopefully Linux kernel itself. Can't wait.

1 Like