Read install guide wrong and didn't update snapshot to release

As the Title says f .

And the question is....?


You should upgrade to 22.03.1 (and not bother with snapshots). You're going to have to do this over many steps since 10 is so incredibly old.

This router is available since 2020, first support is since 21.02.0 as you can read here:
So, your conclusion must be wrong because nobody would port a 10 year old version to a new router model.
Just because of the release number, you can't say what version is running.
The release number of V. 21.02.3 on my router is r16554-1d4dea6d4f.


How did this version get installed? Did the OP install it themselves, or was this vendor installed?

If it is vendor supplied firmware, it is entirely likely that the vendor used this 12 year old version as the basis for their own firmware... not that someone backported support for this device into v10.

To the OP:
what is the output of:

ubus call system board

This is only valid for stable release versions.
But you have installed a snapshot. Believe me, you're conclusion is wrong.
Just install a release version, and you'll be fine.

As @elder_tinkerer said, install a stable release. Stable is always recommended unless there is a specific reason you need to use snapshot (such as for devices that don't yet have stable support, or if there are bug fixes or feature additions that exist only in snapshot that you need to leverage).

Clearly it didn't update, but did it produce any errors? How did you run the update?

is $DOWNLOAD_LINK actually resolving to something? What is the actual file it is attempting to download?

And nowhere in that is a sysupgrade call to actually perform the update.

1 Like

Do this:

cd /tmp/
sysupgrade -n /tmp/openwrt-22.03.1-ramips-mt76x8-tplink_tl-wr850n-v2-squashfs-sysupgrade.bin

Did you use the command line on your router or did you download it to your PC?
I would recommend to use the LuCI web interface to flash the new firmware (after you put it on your PC).

The OP cannot use LuCI because it isn't installed, and they can't install it because they are running into an issue here.

I recommended that they install stable via the command line (via an ssh session into the router), and that should hopefully work.

Sorry, i didn't read that.

Of course you're right. Via ssh on the router is the best (only) option then.

You’re welcome.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Strange. But I can mark the solution for you... point me to which comment you want to mark as the solution and I'll make sure it happens.

Good that you have apparently got it fixed by now, but just adding a clarification here in case somebody else runs into similar conclusions.

Your conclusion based on r20885 is wrong, as the commit revision count was restarted when OpenWrt/LEDE moved into git in April 2016.

And based on the commit hash 629f2de1a7, the OpenWrt code is from October 2022...

Additional confirmation would be that kernel 5.10 has been released in December 2020, so you could not have been running a 10-year older release with that kernel...


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.