LuCI install error: check_data_file_clashes, pkg_hash_check_unresolved: cannot find dependency kernel

Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.147-1-3c5b1ea4df7d3b7efcc7bf88f6631102) for kmod-nf-reject
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.147-1-3c5b1ea4df7d3b7efcc7bf88f6631102) for kmod-nf-reject6
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.147-1-3c5b1ea4df7d3b7efcc7bf88f6631102) for kmod-nf-log
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.147-1-3c5b1ea4df7d3b7efcc7bf88f6631102) for kmod-nf-log6
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.147-1-3c5b1ea4df7d3b7efcc7bf88f6631102) for kmod-crypto-crc32c
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.147-1-3c5b1ea4df7d3b7efcc7bf88f6631102) for kmod-nft-core
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.147-1-3c5b1ea4df7d3b7efcc7bf88f6631102) for kmod-nf-flow
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.147-1-3c5b1ea4df7d3b7efcc7bf88f6631102) for kmod-nf-ipt
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.147-1-3c5b1ea4df7d3b7efcc7bf88f6631102) for kmod-ipt-core
 * check_data_file_clashes: Package libnl-tiny2022-05-23 wants to install file /usr/lib/libnl-tiny.so
        But that file is already provided by package  * libnl-tiny2022-05-17
 * opkg_install_cmd: Cannot install package luci.
root@OpenWrt:~#

I reset my modem because I messed up. Now I can' re-install LuCI.

I tried updating snapshot.

I switched to release and still get the same output

When did you update the snapshot? And did you do it via the sysupgrade process or something else?

When you get the message “Cannot satisfy the following dependencies for…” it is most likely because you installed a snapshot version of OpenWrt.
Read here for possible solutions.

I switched to release and still get the same output

I'd recommend that you work on one thing at a time given that you have two threads open... This will not be an issue once you have updated properly to a release build, but in your other thread, it's clear that the update didn't take.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.