R7800 back to stock firmware

how to revert back to original firmware just installed to to get the sqm and wan mac address change but i cant find how to change wan mac address

Original firmware, as in stock firmware, correct? If so, you need to use the TFTP recovery method.

how to get the tftp client?

I personally use http://tftpd32.jounin.net/, but any tftp client should work.

thank you very much

tried the tftp method but it didnt work

any know another method?

the tftp method.
even with windows client is as easy as hell, you can manage it.

Back to the topic, i've tried the "master" and i couldn't even see the 5G wireless interface, so i'm back to stable
am i the only?

its my first time to use the tftp so i dont know anything about it tried what hnyman exactly but didnt work

What "hnyman exactly"?

The TFTP recovery process has been described in detail in Netgear R7800 exploration (IPQ8065, QCA9984) and so far it has worked 100% ok for me for maybe a dozen times during the past two years.

EDIT:
I got recently trouble with TFTP2 that I used earlier, so I switched to use tftpd64 which has worked ok with R7800 and the current master and 18.06.

also netgear iself explained how this works (1st google result:
https://kb.netgear.com/22688/How-to-upload-firmware-to-a-NETGEAR-router-using-TFTP )

i've always used (old 3700 and now 7800) the stupid windows client:
tftp -i 192.168.1.1 put "R7800-lede1701-r3877-23a638ebd1-20180425-2137-sqfs-factory.img"

as i said above, as easy as hell.

when i config the ip address do i need to put default gateaway?

and what firmware should i upgrade too does it need to be version 1 or latest r7800 version?

tried many times before few days and wont work so today i gave it a try and following every step carefully maybe i skipped a step but still doesn't work any other way to downgrade to netgear firmware?

Have done this many times and followed the steps below:

  1. Turn the router off
  2. Press and hold the reset button
  3. Turn the router back on while holding the resett button
  4. Wait for the power light to start blinking white (10 seconds or so)
  5. Set your PC to 192.168.1.2/255.255.255.0, leave default route empty
  6. Ping 192.168.1.1 to verify the connection; only proceed if ping works
  7. Get OpenWRT factory image or the OEM firmware (*.img)
    tftp
    connect 192.168.1.1
    mode binary
    put {image file}
    quit

how to get the openWRT factory image is it in master folder ? or i need to get it from somewhere else

because i was flashing netgear default firmware

If you want the factory firmware, then use the Netgear *.img file.

from thier site?

That is the only official place, yes.

ok thank you

still doesnt work