OpenWrt support for Asus RT-AX59U

Dear developers,

Could you please consider adding OpenWRT support for Asus RT-AX59U ? Its hardware looks very similar to that of Xiaomi Redmi AX6000

The CPU of both is MediaTek MT7986A (Filogic 830 platform)

Unlike Xiaomi Redmi AX6000, Asus RT-AX59U has 2 USB ports. Xiaomi Redmi AX6000 has 4x4 5 GHz MIMO, while Asus RT-AX59u has 3x3 5 GHz MIMO.

Thank you.

there's no such wish list.
you own the device, you'll be adding it.

start by getting serial console access.

I don’t have it yet. Thank you for the nice message :slight_smile:

if openwrt is a must for you, don't buy it.

1 Like

That is the harsh reality.

If you can't add the device support yourself, you should not open a topic for it.


Btw, It would be nice to add a page in the Wiki for it. Also with a tear down manual, as the installation requires serial access. :confused:


At least serial there seem to be pins though. That's a lot nowadays.

Pre-populated pins are +1 but I wouldn't buy a € 130 router to void the warranty on the fist boot because I had to open the case to install OpenWrt. :confused:

So another +1 for Dynalink DL-WRX36: not just populated serial, but easy teardown and no warranty seals! :pray:
I hope Asus do the same too!

1 Like

I'm interested in the result of running the command:

ubinfo /dev/ubi0 -a

This can be run on either an OpenWRT or AsusWRT system.

I am also interested in the full UART log.

root@OpenWrt:/# ubinfo /dev/ubi0 -a
Volumes count:                           5
Logical eraseblock size:                 126976 bytes, 124.0 KiB
Total amount of logical eraseblocks:     992 (125960192 bytes, 120.1 MiB)
Amount of available logical eraseblocks: 544 (69074944 bytes, 65.8 MiB)
Maximum count of volumes                 128
Count of bad physical eraseblocks:       0
Count of reserved physical eraseblocks:  20
Current maximum erase counter value:     13
Minimum input/output unit size:          2048 bytes
Character device major/minor:            249:0
Present volumes:                         0, 1, 2, 3, 4

Volume ID:   0 (on ubi0)
Type:        dynamic
Alignment:   1
Size:        1 LEBs (126976 bytes, 124.0 KiB)
State:       OK
Name:        nvram
Character device major/minor: 249:1
Volume ID:   1 (on ubi0)
Type:        dynamic
Alignment:   1
Size:        8 LEBs (1015808 bytes, 992.0 KiB)
State:       OK
Name:        Factory
Character device major/minor: 249:2
Volume ID:   2 (on ubi0)
Type:        dynamic
Alignment:   1
Size:        8 LEBs (1015808 bytes, 992.0 KiB)
State:       OK
Name:        Factory2
Character device major/minor: 249:3
Volume ID:   3 (on ubi0)
Type:        dynamic
Alignment:   1
Size:        32 LEBs (4063232 bytes, 3.8 MiB)
State:       OK
Name:        linux
Character device major/minor: 249:4
Volume ID:   4 (on ubi0)
Type:        dynamic
Alignment:   1
Size:        373 LEBs (47362048 bytes, 45.1 MiB)
State:       OK
Name:        jffs2
Character device major/minor: 249:5

Why don’t I see volume rootfs and rootfs_data in this list?

After installing the OpenWRT, 65 MiB are available for files?

This is from TFTP-loaded initramfs, I had probably a broken flash attempt before.

And yes after installing OpenWRT, 65 MiB are available for files!

I also made it possible for this device to have a simple installation:

Available disk memory has been expanded!

PS.: I haven't tested anything on this device! Use this at your own risk!

Tested with AX59U version ( and it worked fine.

Booted into initramfs and then flashed a custom AX59U image built from this branch

1 Like

great news

What can a custom bootloader be useful for?
The stock bootloader has all the necessary features.

I've used stock layout

1 Like

The RT-AX59U doesn't seem to have a wiki-page yet, or does it? I don't (yet) own an RT-AX59U, but I could buy one if that helps the project?

I can create a techdata entry, but for some reason the DokuWiki isn't working atm.

until then, install details are in;a=commit;h=782eb050082acac93c2f9b3eb22348234bc93e99
images at


I am getting the following errors:

root@OpenWrt:~# logread -e err
Wed Mar 20 11:06:45 2024 kernel: [    3.434419] mt7530-mdio mdio-bus:1f: no interrupt support
Wed Mar 20 11:06:45 2024 kern.warn kernel: [   10.400988] mt798x-wmac 18000000.wifi: Direct firmware load for mediatek/mt7986_eeprom_mt7976_dbdc.bin failed with error -2
Wed Mar 20 11:06:45 2024 kern.warn kernel: [   10.503682] mt798x-wmac: probe of 18000000.wifi failed with error -12
Wed Mar 20 11:06:53 2024 daemon.warn odhcpd[1628]: No default route present, overriding ra_lifetime!

The version from frollic worked last week but today it doesn't work anymore which leads me to believe it is a HW issue with my unit, however the stock firmware works fine. Any clue?

I've been reading that's most probably an issue with data that is written into the EEPROM. This explains the behaviour, however I still don't know how to fix.