OpenWrt support for Asus RT-AX53U

Can openwrt support this router?
MediaTek MT7621A
MediaTek MT7905D
Flash1 Size
128 MiB
RAM1 Size
256 MiB

it could, but doesn't ...

+1

I have an asus RT-AX53U ... :grimacing:

Then crack it open, connect to the serial uart and get hacking.

Hi!
I've bought a rt-ax53u and started populating the wiki.
Will update with installation process details.
Here's the device page on the wiki https://openwrt.org/toh/asus/rt-ax53u

I bought one yesterday, soldered on serial connectivity and off to the races! (or so I thought)

I go through the setup with PC IP at 192.168.1.2 and fire up a tftpd64 server with openwrt.bin file in root.
I get a serial console up and boot into U-Boot, no problem.
I do the settings in U-Boot with IP 192.168.1.1 and call out for the openwrt.bin

..nothing. It runs through all iterations and times out.
I try to ping 192.168.1.1 from PC, no reply.

Do I need to use a cross-over patch cable or a switch between? I see that the LAN port on router goes 'live' on my PC but thats it. I tried all three LAN and the WAN port, same different.

Also, I did upgrade to latest firmware from ASUS before I tried this. I dont know what that could have done to the boot loader.

A firewall is very effective at stopping incoming tftp calls, from the surrounding network.

Can't be sure uboot will reply to pings, it only have very basic network functionality.

Yes, I am aware of that. I have an old laptop with win7 and FW/AV that I can disable completely just for this purpose. Did flash a few OpenWRT firmware with exactly same laptop, OS and software, PL-2303 USB adapter before. It is confirmed working.

Yes, the lack of ping reply is a grey area. I also looked over the U-Boots command list and tried a few commands in U-Boot console but not much there as you say..

EDIT: I also tried with a dumb switch between PC and router and a couple of fresh patch cables. Still no dice.

Only reccomendation I had in mind was to try with a switch, it's also reccomended since by using one the eth links are up by the time the u-boot starts.
Only thing i can think of right now is to try a different OS, maybe some live linux distro if you know your way around it
I'll try myself once i get my serial adaptor and solder it to the pcb.

FYI with the help of @tmomas we're moving the wiki page to the "supported" template. Will update you with the final link once it's ready so you can help with documentation aswell if you'd like

Thats exactly what I did. I fired up a Debian 11 on a SBC I had lying around and surely it worked.

Im in!

Yes, I'll put some words in once I get it all up here.

1 Like

I had a couple of hours with some iffy stuffs. First of all I am not sure soft factory reset works properly.
I apply 'firstboot && reboot now' and it got into a semi bricked state. After some tries to get the serial console up and running I managed to reflash it and all up again.

As for the serial console and my USB to PL-2303 adapter (10 years old) it seems the router is hanging due to some creep over grounds between the router and PL-2303 chip. Router simply refuses to boot for like 8 out of 10 times if the ground is connected. Once I pulled the ground router boots but obviously I get garble in terminal becuase signal gets messed up without ground for the serial connection. I solved it by take another spare USB cable and skin it and connect the ground from another USB port to ground on serial on router. That bypassed whatever the PL-2303 chip ground creep messed up.

..maybe its my old USB adapter that is funky but I thought I throw it out there if someone has the same kind of issues with router refuses to boot while serial (ground) is connected.

OpenWrt support for RT-AX53U support has been added with https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=8c00fd9b4519bf0ef8fb3470a6df421b9f38c03c

First of all, many thanks to @ccchen and @chunkeey for bringing OpenWRT to this router. It worked very well for me. Could you update the TOH page with the description of the preparation (soldering 4 pins to the board) and the commands given? This would simplify the process a bit for new users and help them choose a suitable router, e.g. if soldering is out of the question for someone.

The wiki content is largely user contributed - meaning, you can fill in the blanks just as well.

Currently I can't because self-registration is forbidden on the wiki. But you're right, I could apply for an account myself. Will try it.

it's done in Applying for OpenWrt wiki account

Sorry for my first-timer question:
In order to flash this Asus router I have to open it (voiding warranty), solder a serial cable 'somewhere' and then follow the instructions as provided in pimpeks message?

Will the exact serial connections be documented at some point? Ideally with pictures.
(wow, now I really feel like a newbie :slight_smile: )

yes, so it seems.

See the devicepage: https://openwrt.org/toh/asus/rt-ax53u#serial

1 Like

My bad. I did not check the last part of the page :slight_smile: Tnx!