OpenWrt support for Asus RT-AX53U

Has anybody tried a 160mhz wide wifi channel? Does it work in any way or is there some hardware limitation?


I don't know whether this will be helpful in any way, but it seems that ASUS has released their sources for this router?


Not really, and it's already supported?

I'm thinking of buying this or the Linksys E8450/Belkin RT3200, I've been a Asus fan in the past, is this one any good?

I use this model, it is very stable on OEM firmware.
I think the cheapest wifi6 router (with ax on 2.4GHz, that is not present on mt7622) with USB port.

They pushed GPL dump instead of firmware

Quite interesting GPL, it looks like Asus is working on devices based on chips:
MT7986A, MT7986B, MT7981 - all ARM64

We would also see some devices in near future to work DBDC with each band 4x4:4, 802.11be, 1024QAM, 160MHz channels: MT7902 and MT7990, called Besra.
There are many patches for mt76, mac80211 and hostapd to support them - I hope - officially by mac80211 subsystem.

Also.. For the time being I will stick to STOCK FW, is there any reason to NOT update it to the newest version?
Is it possible that in the future some exploit will be available for older FW that would not need opening the case and soldering the serial header?
I'm currently at

you can enable SSH and reflash NAND with any image from stock FW

1 Like

I don't own one, but people who do, are happy with it...

Waiting/hoping for wax206 support, kind of same as the rt3200, but got a 2.5gbe uplink/wan port.

But let's stay on topic, from now on.

Could you share a how-to?

Yesterday I bought this device and tried to install OpenWRT, however, got a bootloop.
Restoraition is quite simple (thanks Asus).

Tried with last snapshot:
openwrt-ramips-mt7621-asus_rt-ax53u-squashfs-factory.bin e6cab292c8bbefc448b55a2125665b6658c23ba7fbb55d8c9a7a4915172b76bc | 8960.0 KB | Mon Aug 8 20:23:58 2022
as well as with build from
db0906f663ca6638f42cbb9fa996ac30754a38d2870bdb7d474b7746ff45d7eb openwrt-916189392e7b-ramips-mt7621-asus_rt-ax53u-squashfs-factory.bin .

Installed it over stock via TFTP powering device on while holding reset button (installation via TFTP using UBOOT menu was unsuccessful after many retries for some reason).
Also tried installation via SSH:
mtd-write -i /tmp/openwrt-ramips-mt7621-asus_rt-ax53u-squashfs-factory.bin -d linux
The result is the same:

[    3.394008] UBI error: no valid UBI magic found inside mtd5
[    3.400480] /dev/root: Can't open blockdev
[    3.404571] VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
[    3.412071] Please append a correct "root=" boot option; here are the available partitions:
[    3.420417] 1f00             896 mtdblock0 
[    3.420424]  (driver?)
[    3.426948] 1f01            1024 mtdblock1 
[    3.426953]  (driver?)
[    3.433457] 1f02            1024 mtdblock2 
[    3.433462]  (driver?)
[    3.439987] 1f03            1024 mtdblock3 
[    3.439992]  (driver?)
[    3.446494] 1f04            4096 mtdblock4 
[    3.446498]  (driver?)
[    3.453019] 1f05           47104 mtdblock5 
[    3.453024]  (driver?)
[    3.459543] 1f06           51200 mtdblock6 
[    3.459548]  (driver?)
[    3.466050] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[    3.474303] Rebooting in 1 seconds..

Did I something wrong or the last snapshot is broken?

More details:

i've installed openwrt last night, probably using the same snapshot you did, but found no issues.
The method used was to connect a usb-to-serial adapter ( ) with TFTP method, interrupting u-boot and then flashing the firmware from TFTP server. The whole process was done through picocom shell

I see you are using "mtd" command, but personally I didn't need to use it.
The wiki page has been updated with detailed instructions on how to flash from factory firmware, did you try that?

a how-to on this would be very nice! I believe many people are scared of opening the case and don't have required tools to solder or even don't know how to use the serial adapter.

if you can share some commands on how to flash from stock through ssh we can think of a way to make it more pretty and document it on the wiki aswell

Yes, I tried that.
My problem with the described instructions is that after selecting all the options ( 2. Upgrade firmware; 0 - TFTP client (Default); Input U-Boot's IP address:; and so on) TFTP was unable to download the firmware, it gave up after N tries.
I was trying to use curl and atftp as described here (I'm on Linux).
What tftp server have you used? What was the stock FW version? Could you please share sha265 of the file you flashed?
I've checked the firewall, tried to disable NetworkManager, tried to disable all other network interfaces, tried to add arp record..

I've used atftpd:

on archlinux (manjaro)
you could try with a live linux distro to set up the tftp server
The IP of the tftp server should be set according to the ethernet link, personally i've had to manually set the network interface not to use the DHCP but with and

If you are unable to reach the tftp server from the router itself the main reasons should be

  • network connectivity (required to set IP and netmask manually)
  • firewall / something else in your network blocking the connection (try a live linux distro)

Regarding the hashes of the files i'll give you an update later on when I'm home
The stock firmware version i flashed from was the latest one downloadable from asus support website:

1 Like

Finally, it works. It's always not a good idea to perform such things at 3AM LOL.
My problem was, that I've mixed up TFTP server & TFTP client.
Uboot's option "2. Upgrade firmware; 0 - TFTP client (Default)" is client, and powering on while holding reset button is server.
I've tried client (on a laptop), but have to - server.

And, it seems, loading Openwrt in rescue mode is not working yet.

1 Like

Hi again

I decided to join in the fun, so I went ahead and ordered one.

So far I've managed to flash the current snapshot onto the device by TFTP. it seemed to have worked as I can now SSH in and it is clearly running OpenWrt, but I don't have a LuCI interface running. Also I've lost the serial console, when it boots I just get garbage on minicom? Is that normal?



I did another flash with a sysupgrade and I've got my serial console back.

opkg update
opkg install luci luci-ssl kmod-mtd-rw

what is this package for?