OpenWrt Support for Armor G5 (NBG7815)

thanks a lot for the info!
i'm trying to build the asvio's nbg7815-test firmware, but i cant'see IPQ807x as a target system and i don't understand so much about these things, if you have the compiled firmware could you please pass it to me ?

I supposed you were already using one of my builds looking at the firmware name in your screenshot ("ZyXEL NBG7815 with led fan patch").

Regarding the target, it was recenty moved under qualcommax.

1 Like

for openwrt-23.05

if you are going to make defconfig, include the following lines in the .config file

CONFIG_TARGET_ipq807x=y
CONFIG_TARGET_ipq807x_generic=y
CONFIG_TARGET_ipq807x_generic_DEVICE_zyxel_nbg7815=y

for main branch

if you are going to make defconfig, include the following lines in the .config file

CONFIG_TARGET_qualcommax=y
CONFIG_TARGET_qualcommax_ipq807x=y
CONFIG_TARGET_qualcommax_ipq807x_DEVICE_zyxel_nbg7815=y

If you want to build base on openwrt main branch with led and fan support i suggest my nbg7815-test-230625 branch. There was a lot of change on commits published june 26th and don´t know how stable or problem could have with fan an led support.
I also suggest not to play with the configuration of the leds, and especially not to choose mmc0:: because you can even block the router.

1 Like

thank you so much for the patience guys! i just finished compiling the firmware, as soon as I have time I will flash it

I managed to flash psychowood 's latest build but I don't understand how I'm meant to control the LEDs on the router. In this thread I saw that itorK mentioned not to use Luci and especially not to use mmc0 but those are all old posts. I still tried using luci and when I tried applying an option for channel0 the router rebooted. What am I doing wrong?

I've also tried AugustinLorenzo's NSS builds and they seemed very stable, the only issue is that they don't have the fixes for the fan and the LED, if I wanted to try and add those features to his releases on my own, do you think using the latest commits that mention those on psychowood's repo would be enough or are there others that I missed?

@asvio is your -nss branch based off the same repository? Since you said there were stability problems in your tests...

Yes, it is.
If you try it, make a reboot after sysupgrade first run.

Thank you @psychowood for pointing that out, I didn't realize.
I'm building it right now and I'll be testing it tonight.

Keep in mind that when I said that it looked more stable I'm using the device as an AP rather than a full fledged router since I have a x86 server with OpenWRT that handles routing for me.

@asvio I was able to build the branch but when I flashed it the router wasn't bringing up the interfaces.
So I opened it and with the serial I was able to discover that OpenWRT wasn't able to generate the /etc/config/network file, as it should on the first boot, because the filesystem was read only.

So I followed the instructions to have the router boot the initramfs version of the build and it worked, I used that to try and reflash the version but the issue persisted. I then tried to flash @psychowood build but stuff wasn't working either since the kernel was not being updated and it was still booting into the nss one. I tried flashing multiple times the same build without any success.

Looking into some old messages I found this message from asvio that seems to describe what was happening. The only way that I could fix the router was to return it to stock and then repeat the process of flashing the router twice because at the first boot it used the stock kernel.

It seems that the dual boot partitions are not being handled correctly and I don't know how to fix it.
When I flashed the router with the script from the stock firmware I received the error dd: writing '/dev/mmcblk0p7': No space left on device mentioned multiple times in the thread, don't know if it has any impact on the issue.

I've checked the partitions and they are all there and with the right sizes and indexes.

I honestly don't know what is going on.

If you are using it only as AP lastest master version base on kernel 6.1 has more performance that actual nss version base on 5.15.

NSS support for k6.1 is still in development.

I'm going to be out somedays, but id i was you i will install stock firmware throught sftp and then return to openwrt with a new snapshot base on 23.05.
If you want nss, install over it. But now i get more performance on main snapshot than nss version.

I don't know if the las it is valid for pppoe

This is what I've done to fix, went back to stock and flashed the latest psychowood build and I finally have a working router.

When I first flashed it tho I had flashed an AugustinLorenzo NSS build and it managed 850 Mb/s with a 2x2 client on a 80 MHz channel. With the non-nss builds I've only seen 650/700 Mb/s tops.

Wich client?
Intel, mediateck, qualcomm??
I'm getting just a bit more with ax210 client.
870 down 800 up on 80mhz without nss

I was trying with an Exynos S21 Ultra so from what I understand it's using a BCM4389.

Tonight I'll try with both an ax210 and an older ax200.

1 Like

I had rather similar issues with another ipq807x device QNAP QHora-301W.

I found this link from the FCC, which has done some tests on the router (like DFS test) and there are several photos, maybe it can be helpful

1 Like

The ath11k firmware has recently been updated to version WLAN.HK.2.9.0.1-01837.
Since then I have verified that I suffer from constant disconnections from ax210 clients and especially in download stress tests.
Could someone else check this problem.
I always get errors on iperf3 test with the new firmware.

As a reference I add images made with flent of the new firmware and the previous firmware (WLAN.HK.2.9.0.1-01385).

WLAN.HK.2.9.0.1-01837



WLAN.HK.2.9.0.1-01385



Hi everybody,

can i downgrade to 23.05.0-rc2 (from snapshot build)?
which one can i use?

On first install the guide said to use sysupgrade, why?

Thanks.

anybody? please?

No time to explain it.
You must use sysupgrade version to go to openwrt from factory firmware with this device.
After first reboot you must install luci to get web access. You always can configure it via ssh command line.