OpenWrt Support for Armor G5 (NBG7815)

If you are using it only as AP lastest master version base on kernel 6.1 has more performance that actual nss version base on 5.15.

NSS support for k6.1 is still in development.

I'm going to be out somedays, but id i was you i will install stock firmware throught sftp and then return to openwrt with a new snapshot base on 23.05.
If you want nss, install over it. But now i get more performance on main snapshot than nss version.

I don't know if the las it is valid for pppoe

This is what I've done to fix, went back to stock and flashed the latest psychowood build and I finally have a working router.

When I first flashed it tho I had flashed an AugustinLorenzo NSS build and it managed 850 Mb/s with a 2x2 client on a 80 MHz channel. With the non-nss builds I've only seen 650/700 Mb/s tops.

Wich client?
Intel, mediateck, qualcomm??
I'm getting just a bit more with ax210 client.
870 down 800 up on 80mhz without nss

I was trying with an Exynos S21 Ultra so from what I understand it's using a BCM4389.

Tonight I'll try with both an ax210 and an older ax200.

1 Like

I had rather similar issues with another ipq807x device QNAP QHora-301W.

I found this link from the FCC, which has done some tests on the router (like DFS test) and there are several photos, maybe it can be helpful

1 Like

The ath11k firmware has recently been updated to version WLAN.HK.
Since then I have verified that I suffer from constant disconnections from ax210 clients and especially in download stress tests.
Could someone else check this problem.
I always get errors on iperf3 test with the new firmware.

As a reference I add images made with flent of the new firmware and the previous firmware (WLAN.HK.



Hi everybody,

can i downgrade to 23.05.0-rc2 (from snapshot build)?
which one can i use?

On first install the guide said to use sysupgrade, why?


anybody? please?

No time to explain it.
You must use sysupgrade version to go to openwrt from factory firmware with this device.
After first reboot you must install luci to get web access. You always can configure it via ssh command line.

Hi, I installed following wiki guide.
I got the space warnings, but installation went through:

root@NBG7815:/tmp/ApplicationData# ./
dd: writing '/dev/mmcblk0p7': No space left on device
12289+0 records in
12288+0 records out
6291456 bytes (6.0MB) copied, 0.550667 seconds, 10.9MB/s
9892+1 records in
9892+1 records out
5064736 bytes (4.8MB) copied, 0.629982 seconds, 7.7MB/s
dd: writing '/dev/mmcblk0p8': No space left on device
122881+0 records in
122880+0 records out
62914560 bytes (60.0MB) copied, 5.795166 seconds, 10.4MB/s
14080+0 records in
14080+0 records out
7208960 bytes (6.9MB) copied, 0.860055 seconds, 8.0MB/s

now my problem is about installing luci:

root@OpenWrt:~# opkg install luci
Installing luci (git-23.051.66410-a505bb1) to root...
Installing libnl-tiny2023-07-01 (2023-07-01-d433990c-1) to root...
Collected errors:
 * check_data_file_clashes: Package libnl-tiny2023-07-01 wants to install file /usr/lib/
        But that file is already provided by package  * libnl-tiny2023-04-02
 * opkg_install_cmd: Cannot install package luci.

I googled about this error, and seems pretty common and related to snapshot builds. Which version could I install to solve the problem? Thank you

Had lately a similar experience with package libnl-tiny. As far as I remember I simply removed it and than installed the luci again. That solved the issue.

In my googling I found out that is highly reccomended not to do that... but I admit that was my first thought :smiley:

About sysupgrade I read that luci is quite easier and safer for beginners, but it looks like I've no choice than ssh upgrade.

It would help me to know the reason for using sysupgrade, when you have the time.
I'm not clear on the steps, if I reset to factory settings now I get the factory openwrt version not the factory manufacturer firmware.

up! please! thanks

Hi! I am using the psychowoods OpenWRT build with the LED and fan patch from asvio, and I was wondering, if there is a way to change the max temps (without rebuilding the whole firmware)? My router still gets hot, I don't think it impacts performance anymore, but I am just not comfortable with it reaching 70+°C
Thank you!

When you build a firmware for nbg7815 you get 3 different image:

kernel Image. this is the openwrt-*-initramfs-uImage.itb file. This image is for special use (debricking, special installation over factory image, ...) You must install sysupgrade image over it to get full openwrt.

factory image: this image is intended to use on GUI factory firmware, but it must be structure and compress with factory algorithms that at this momentthey are not known, so this factory image has no value at this moment.

sysupgrade image: Once the device is working on openwrt you can use this image to update your firmware.

As almost all current device the nbg7815 original firmware is base on openwrt so it is posible upgrade with sysupgrade image but with special process. The "" script prepare the original firmware and extract from openwrt's sysupgrade image what is needed to flash the router.

1 Like

There is no way.

If you can build around my nbg7815 branch, you get a new fan support base on @itorK work that can be configure via uci. It check cpu, nss, the 3 wifi radios and aqr113c chip temp. by default fan is switch on at around 75ºC and go off at 70ºC

An example for change max temp to 70º through uci:

uci set fanctld.config.Temp=70000
uci commit
service fanctld restart
1 Like

in my nbg7815 can i downgrade with same process as upgrade with sysupgrade image?