OpenWrt for Zyxel WSM20 (Multy M1) development discussion

yes, that's exactly what i did. I now have an RiP4 lan connected to the router. However, this means (a) more power use and (b) if i need to make use of it on the router, e.g. to backup from router to it or send syslogs to it, then i have to cifs mount it. Works, but would be much neater with a USB connected storage straight on the router.
What I'll try and do is see if i can find a schematic on how USB is provided (pcb wired) on other routers, if lucky ones that use the same SOC, and reverse engineer from there. At the moment I cannot find a schematic diagram for such thing.
thanks for your response.

Replying to my own post:
Someone has already done what i'm proposing on an Archer C6, see here: adding a usb port to archer C6
I need the pinouts for the MT7621AT to try this. I have the datasheet for the MT7621 which identifies the pins (K1 &K2) for USB2 on the ball map, but what I need is the SOC pin outs so i know where to solder the D- and D+ data pins. Anyone got a schematic or link to one it would be appreciated.
I then need to modify the .dts file as shown here in post#6 dts mod
thanks...

Unfortunately, I have no expertise to help you except by doing a Google search, which I imagine you have already done. I'm following your work though with a lot of interest, if it's possible to do something like that it would be a really nice shot, and I would definitely try some welding :grin:

Hi, yes I've given up on this project for now cause these zyxel wsm20 are showing signs of bigger problems. I've had syslog error messages which i've never seen before with my linksys velop dual band system. I've had ip routing issues, where the nodes shows still connected but uncontactable, weird phantom nodes detected and roaming is an absolute nightmare. I've tried 802.11s (need wifi cannot do wired) with and without 802.11r, also tried with and without 'dawn', kv. I've mapped the entire house to make sure dBm levels are correct with the, according to topics, magic answer of ensuring placement and power levels are correct. All data shows that roaming should occur yet none of my modern android, tablets or windows clients roam. Once they logon to an AP they will stick with it even if you're in a room where the logged on AP is -80dBms and the nearby AP is -25dBms. Roaming needs work so for now I'm going back to my trusted linksys velops with stock firmware. Pity cause I think these wsm20 have some potential with their 2C/4T at 880Mhz and if we could have added USB at current selling price they would have been a steal.

These units were dirty cheap last year. Are they still making them? The access point roaming on the stock firmware was very poor. I tried with Zyxel support to fix it but no joy. Since I installed Openwrt on the 3 access points in my house (without roaming) I have had no issues. I just leave the client to roam without any assistance.

BTW is there GA Openwrt support for these devices now, I'm currently using OpenWrt SNAPSHOT r23369-92b8b18c26.

Uptime 244d 22h 27m 52s :slight_smile:

1 Like

I have three WSM20 running 23.05.2. Uptime 83 days. No problems whatsoever. Stable and good range.

3 Likes

I had similar problems. Did you try with mesh11sd v3? There are rare problems with the wifi drivers that mesh11sd is supposed to fix when uncontactable issues occur.

Iā€™m also getting close to 100 days uptime at this point. The only cause of restart is when I update the firmware.

Rock solid and reliable real world wifi speeds of > 400Mbps. 2xWSM20 with 1Gbps wired backhaul and they cost me less than a single equivalent TP Link.

1 Like

thanks, yes i did try mesh11sd v3 and the problems persist. The biggest is when they lose ip routing because then since all my nodes are wifi backhaul i cannot connect to the nodes even if i power off/on and reset the main node mesh wifi, I have to move the nodes and connect to the router to be able to access them. I have WPA3-AX on the backhaul so don't know if that may be the problem. Anyway for now i'm reloading them with oem firmware and will sell all 4 of them. Honestly I've spent days troubleshooting these whereas my velops (in bridge mode) just connect first time and stay on always. Pity, I had high hopes for these and was also working on trying to enable USB port since the SOC supports it, alas s**t happens. thanks for everyone's help.

I put together a little guide for mesh on these if it's helpful.

1 Like

thanks, i downloaded the doc It's pretty much how i set it up except for the backhual, mine was set up using 5GHz wifi 6 which was reliable in my house. Even when ip routing was failing the nodes still show up as connected but you can't access them anymore.
Anyway, thanks ...

What were your mesh11sd parameters?

A heads-up: the source for version 6 (100ABZF6C0) of the original firmware is now available. My request through https://www.zyxel.com/global/en/form/gpl-oss-software-notice from the fall got a positive reply today. I would expect future requests to be faster now.

And before someone asks: I did not have time to look into the package yet.

Hello,

I recently purchased the triple set of this device from an online electronics store for $45. After spending a few days with the stock software, I installed OpenWrt 23.05.2. I have a question for those who use this device. I've read through the entire thread, and it seems there are different methods available. I've come across various names such as 802.11s, DAWN, B.A.T.M.A.N, WDS, etc. What method is recommended for mesh networking w/o ethernet backhaul? Thanks.
Cheers.

ulpian

I purchased three unit. in AP mode the units work fine. I connected four units: three mesh points with MediaTek MT7915E and one node with IPQ4019. I tested releases 23.05.0, 23.05.1 and 23.05.2. Unfortunately, after a few hours one of the two MediaTek MT7915E nodes is unreachable.

I used this guide with two WSM20s (Access point and wireless bridge), works well since about three months :grinning:

1 Like

Same here, a WSM20 is connected via WDS to another WDS20 - no issues recognized so far (uplink at 5 GHz WiFi, AP at the Repeater only on the 2.4 GHz WiFi with ~160 Mbit/s real life throughput)

okay. I identified the problem.
I set 17 dbm in all radios because syslog reported this error: mesh plink closed with reason 55.
the network is stable with 4 mesh nodes.

edit.
after 19 hours of activity, node 2 and node 3 do not ping each other. I try without encryption. no errors in the registry. both nodes remain connected to the access point.

1 Like

Think you're running into the exact same problem I did in my thread: A foolproof guide to setting up further wifi coverage - #32 by alex24

mesh11sd v3.0.1 will aparently fix that. It's a known issue but noboys knows exactly why it happens. I'm going to hopefully try this weekend to see if WDS fixes it (you can try that if you want).

Hi Alex. I know well wds and i think it is reliable. what I don't understand is this: ipq4019 is always online. in my network one of two mesh peers with mt7915e always falls. it makes me angry. :slight_smile:. I have 3 mesh nodes. 1 IPQ4019 and 2 with MT7915E. after a few hours the 7915e nodes stop pinging and I don't see any events in the systemlog file.