OpenWrt Firmware for Archer c6 v3.2

Right after the disconnect of a few minutes ago I didn't see anything new in the log but then this appeared minutes later
Thu Apr 21 17:18:16 2022 daemon.notice hostapd: wlan1-1: AP-STA-DISCONNECTED [my mac]
Thu Apr 21 17:18:16 2022 daemon.info hostapd: wlan1-1: [my mac] IEEE 802.11: disassociated due to inactivity
Thu Apr 21 17:18:17 2022 daemon.info hostapd: wlan1-1: STA [my mac] IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Checking the "Disable inactivity polling" box it disconnected again after a while, with the same 3 log entries and after setting "Station Inactivity Limit" to a ridiculously high number it also disconnected again after a while, with the usual 3 log entries.
Is there some other setting I should try to change?

I might add that I have a custom ROM on my phone without Google Play Services so it doesn't keep sending my data to Google and I also don't keep data collection apps on my phone, this being probably the reason for the "inactivity" of it.

sammo: What do you mean "radar channel"? I'm on the standard channel, channel 36.

I flashed 21.02.3 for the A6 V3 on 4 of my C6 V3 access points 9 hours ago and performance and stability is as expected

1 Like

There is now a release candidate for 22.03 (and the Archer C6 V3), I've upgraded to that but I have the same issue as above.

https://downloads.openwrt.org/releases/22.03.0-rc1/targets/ramips/mt7621/

In case developers are reading and they can fix this for final release: after using the phone more it's clear now that the (both 2.4 Ghz and 5 Ghz) Wifi doesn't disconnect only when I'm not using the phone but also while I am using it, with the same log entries. Even though the log says "due to inactivity", that's not the case. I've checked the connection configuration on my phone and "auto-connect" is enabled. I will test on more devices to see how the connection behaves on them.
Edit: my laptop doesn't disconnect, another phone on which I am also running a custom ROM doesn't disconnect, a headset with Snapdragon XR2 at the very least reconnects when woken up, I only get these particular log entries and these disconnects on the phone which I've mentioned in previous posts.

22.03.01-rc1 has been officially released. More information here.

This is the first stable version to include support to Archer C6 v3/v3.2. The OpenWrt firmware images are available here.

3 Likes

Installed on 4 devices, works well so far

2 Likes

Is the EU version of the router (Archer C6(EU)_V3.20) supported by this version? The device page only mentions US and BR.

Hello All,
I just installed the 22.03.01-rc1 for my Archer C6 V3.2 (India). The installation was smooth and am able to access the GUI.

I wanted to use this router in PPPoE mode and my ISP requires VLAN 100 to connect. Where can I find this option in OpenWRT?

I am also unable to switch on the 5GHz radio. I get this screen. Though it can detect 5G radios in my surroundings when I scan.

So I managed to connect to the ISP and figured out the VLAN option. I still cannot get the 5GHz radio to switch on.

Any ideas?

Thanks

Yes, I have installed it on the EU version. I have an issue with one of my phones disconnecting from Wifi but the ROM does flash really easy without issues and it works for the most part, other devices of mine work just fine. I can't say that I regret getting rid of the stock ROM.

did you manage to get the 5GHz wifi radio working? any settings I have missed? I just cant get it working.

Yes, I had 2 unencrypted connections for each, for 2.4 Ghz and 5 Ghz made by default, I had to secure what I was using and disable what I wasn't using. Both 2.4 Ghz and 5 Ghz work.

On my Wifi connection problems, I now disconnect from the other Wifi router that I have so maybe it's not because of OpenWrt after all, it might have to do with something on my side after all, maybe a VPN that I've installed on that phone just before I flashed the ROM, I'll have to keep investigating the problem as I also have a firewall managing per application connectivity. I've updated my official custom ROM to the latest version and now it does reconnect sometimes, after the 3 disconnecting log entries I get 2 reconnecting entries but sometimes it disconnects from 5 Ghz and reconnects to 2.4 Ghz, not the same one and other times it doesn't reconnect at all. With my phone firewall disabled it seemed to not lose the connection but I've never noticed this problem and having to reconnect manually until very recently, after flashing this router ROM, I had the custom ROM with the firewall enabled for many months.

1 Like

Hello @dsouza , would it be possible for me to install the current snapshot for Archer C6 V3.2 on the 22.03.01-rc1 through the sysupgrade option? I am unable to get the 5GHz working. I can post the log if that will show whats wrong. Thanks for your help.

Finally sorted out the issue. Seems the channel ranges would not allow the adapter/service to start. changed it to 36-48...5GHz is now working fine.

Were you using DFS channels (52-144)? If so, I believe that DFS channels are not officially implemented in this router yet (the last time I read about this the mt76 driver did not have the capability to listen to radar signals with mt7613, so I believe that this might be the cause, but I am not certain about this).

It may be possible to use DFS channels if you select a country where these channels are not restricted. Notice that doing so if you are not in the selected country may be against the law.

3 Likes

Any solution for low wifi signal and also low data transfer rate with distance.i am currently on 22.03.01-rc1

That's good news! I flashed your "unofficial" build and it's working really good! But now I want to install WireGuard. Will the official build let me install packages? If so, can I upgrade by flashing the image or is it a more complicated process? Thanks for your hard work :smiley:

Yes, 22.03.0-rc1 should allow you to install all available packages. You can flash it normally via sysupgrade or LuCI.

1 Like

Thanks a lot!

Can you resend the stripped firmware for returning to stock?