OpenWrt 23.05.0-rc1 first release candidate

I have seen similar on my B1300.

I also seemingly ran into an issue while trying to port my swconfig config to dsa format. It might have been due to a misunderstanding on my side during my early porting attempt. In short by following https://github.com/openwrt/openwrt/pull/11579#issuecomment-1366984480 I was able to setup vlans & not get locked out of my device. In case this helps others my resulting configuration for having a main network, bridge lan <-> wan interface (wan as an additional lan interface), & a guest vlan looks like this ->


config device
        option name 'br-lan'
        option type 'bridge'
        option ipv6 '0'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'wan'

config interface 'lan'
        option device 'br-lan.1'
        option proto 'static'
        option ipaddr '<stuff>'
        option netmask '<stuff>'
        option ip6assign '60'
        option gateway '<stuff>'
        list dns '<stuff>'

config interface 'lan6'
        option proto 'dhcpv6'
        option ifname '@lan'
        option reqprefix 'no'

config device
        option type '8021q'
        option ifname 'br-lan'
        option vid '1'
        option name 'br-lan.1'

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'wan'


config bridge-vlan
        option device 'br-lan'
        option vlan '40'
        list ports 'lan1:t'
        list ports 'lan2:t'
        list ports 'wan:t'

config device
        option type 'bridge'
        option name 'br-guest'
        list ports 'br-lan.40'

config interface 'guest'
        option proto 'static'
        option device 'br-guest'
        option ipaddr '<stuff>'
        option netmask '<stuff>'

I likely have done this incorrectly as this does not seem to match up to what https://openwrt.org/docs/guide-user/network/dsa/dsa-mini-tutorial has.

Has anyone been able to use the firmware selector's package customization on this RC yet? It's now been three days sense the announcement and I still haven't been able to do that for Raspberry Pi 4B 64 bit. Same error: "Unsupported branch: 23.05.0-rc1."

I'm beginning to wonder if maybe this has to do with some issue on the build server. Maybe to do with the build server being moved to new hardware and upgraded to Debian 11 back in May, or maybe it's just some code or configuration file that didn't get set correctly. I don't know. I'm just speculating, I did notice the message originally labeled it as 23.05-rc1, but then changed to say 23.05.0-rc1. I don't know if that has anything to do with it.

I use this package customization feature to add the kmod-usb-net-rtl8152 package that I need to connect my Pi to my modem via a USB Ethernet adapter. I'm just staying on 22.03 until the 23.05.0-rc1 package customization starts working.

Tagging @aparcar. Not trying to rush you guys. Just giving you a heads up in case there actually is a build server problem that needs fixing. I appreciate all the work you guys do on this as volunteers, and 22.03.5 continues to work great. :+1:

5 Likes

Yeah, certainly doesn't look normal, I've been waiting for days, on the assumption it was just the building servers getting things ready, but now it seems like it's a permanent error.

2 Likes

The package kmod-usb-net-rtl8152 is built and available for download for bcm27xx target and bcm2711 devices:
https://downloads.openwrt.org/releases/23.05.0-rc1/targets/bcm27xx/bcm2711/packages/kmod-usb-net-rtl8152_5.15.114-1_aarch64_cortex-a72.ipk

You could transfer the package to /tmp and install it from there, as described in opkg documentation: https://openwrt.org/docs/guide-user/additional-software/opkg

1 Like

Xiaomi Mi Router 4A Gigabit Edition
OpenWrt 23.05.0-rc1 r23069-e2701e0f33 / LuCI openwrt-23.05 branch git-23.118.79121-6fb185f

upgraded fine in luci from 22.03.5
improved ethernet: super responsive at ~930 Mbps
wifi 5Ghz working fine (the same): 866.7 Mbit/s, 80 MHz, VHT-MCS 9, VHT-NSS 2, Short GI

1 Like

I just updated my 3 TP-link deco M4R access points and all went without any trouwble.
Experience is the same as v 22.xx so that's good.
I also still experience issues with my esp86xx devices which is exactly the same as before.

So for me no issues.

@aparcar hasn't logged in since May 30, so maybe he's just on vacation. I believe that he's the sole member who maintains the configuration of sysupgrade.openwrt.org, so we just have to be patient until he gets time to do the update.

2 Likes

The error message has changed, for example
Unsupported target: ramips/mt7621

3 Likes

zbtlink_zbt-wr8305rt image building disabled by default, though it has 64 mb ram

commit

Following deprecation notice[1] in 21.02, disable targets with 32M of RAM
https://git.openwrt.org/?p=openwrt/openwrt.git;a=commitdiff;h=f5cb556d4f70e7aac428857fe782b58ece0cf188

WRT1900ACS v1 upgraded from SNAPSHOT r22755
WAC104 upgraded from 22.03.5

No issues so far.

I saw a performance drop on ethernet on my R7800. Discussion on this thread, developers considering how to fix it: Netgear R7800 performance drop in 23.05.0-rc1

1 Like

The Netgear EX3700 simply doesn't work with 23.05.0 rc1. It consistently reboots after a few minutes and drops all config. I have installed 22.03.5 and now it's stable as before.

Self built one for my Redmi AC2100-MT7621, upgrade with settings, but dnsmasq fails to start and all clients cannot receive ip addresses.
In syslog dnsmasq complains dhcp-range issue in config: bad dhcp-range in line 74 of config /var/etc/dnsmasq.conf.cfg01411c
I checked the file, seems it phrasing the config from /etc/config/dhcp incorrectly:

dhcp-range=set:lan,192,,255.255.255.0,24h

This is where the issue lies in:
192,,

The correct one should be something like
dhcp-range=set:lan,192.168.66.100,192.168.66.247,255.255.255.0,24h

Strangely I did not change anything in /etc/config/dhcp, so my guessing is it is related to the new codes.

Reverted back to 22.03.4 with the same settings, everything is OK now.

There are models with only 4 MB flash, so the 4/32 warning applies: https://openwrt.org/supported_devices/432_warning OpenWrt 19.07 was the last official build for this device: https://openwrt.org/toh/zbtlink/wr8305rt

It’s end of life now, there is no 23.05 support for this low RAM and low flash device. But you could try building your own custom image for it, if you have the time.

Even 8 MB flash and 64 MB RAM are low resources for today. Recommended popular devices today have 256 MB flash and 512 MB RAM, or more.

1 Like

Please post the contents of /etc/config/dhcp and the output of command -v awk

well the wiki says it has only 32 MB RAM. Perhaps there are many different versions of the device?

It seems like he didn't have to do anything and it's working now (or maybe he or someone else did something)! I would still like to know why it took about a week.

1 Like

+1 -- 8/64 is the new 4/32: https://openwrt.org/supported_devices/864_warning

We should have a direct link to that on the "Supported Devices" front page now...

2 Likes

Has anyone noticed that the "System>Software" LuCI menu item is missing?

1 Like

i don't have this problem he seems on rt3200 if i understand