OpenWrt 21.02.0 Fourth release candidate

Never encountered similar issues on Xiaomi Redmi 2100, MT7621. upgraded all the way from RC2-RC3-RC4, even tested several snapshots build. Anyway I set "Flow control" under windows NIC to off, maybe you can try it out?

Hi, I have the exact same device (Redmi AC2100), did not try to upgrade since it is my main router, and I did not want to interrupt with other family members.

Can you please tell me how 21.02 is working on this device? 2.4G and 5G signal, ethernet performance, etc?

Hi, all.
Recently, I upgraded my Redmi AC2100, to the rc4 from previous 19.07.7 snapshot.
(Just FYI, I use both experimental options software and hardware flow offloading).

It seems Wifi is more stable, more fluid.
(I wroted on my personal tuto all steps to sysupgrade correctly, inspired by the official page wiki).

Hello all - I am not running RC4, but a slightly older master. Discovered a possible bug. Can anyone confirm whether it is still there?

In LUCI, go to network -> interfaces -> devices -> configure e.g. one of the wifi wlan0 (check a box like Send ICMP redirects)

The RESET button, when you hover over, gives a tool tip of "DELETE". And when you press Reset, UCI queues up an edit e.g.: uci del ...... cfg9827634. Sometimes even uci del network.@device[-1]

But when you apply, the whole device ceases to function. So this is not a RESET, but an actual DELETE. Seems rather at odds. Should it reset the CFG or should it actually delete the device (antonymous to the add device cfg button)?

Just updated two Archer C7 V5 from 21.03 rc3. Everything is working fine. Thanks a lot!

I'm not quite sure what the problem is. If you browse manually, the package does exist at something like:

Obviously you might need to change for your target, that's for my 7530 (ipq40xx based)

I ended up downloading and installing manually, then using Luci to install the rest. (I needed librt for Avahi)

I tried to install after manually searching:

I tried the "Downolad and Install" Option... should i use "Upload Package"?

Yeah I had to download the ipk to my computer then use upload to install it.

Working so far: wired 1G LAN speed, 2.4g/5g wifi
Not working as expected:

  1. DSA based VLAN, cannot figure it out even with instruction on the forum, but not required so I just made a workaround method
  2. HWNAT has soft-irq seen in htop, max internet speed capped to 550M(wired internet)/300M(wifi internet)
  3. Updating from rc3 but Luci told me config version not compatible, don't know why because I used same config from rc2 to rc3 with no issue, nevertheless I compiled rc4 myself and added config in /files and it worked.

Where can I find the above pic in this release

try to uncheck "Disassociate On Low Acknowledgement"

Where can I view the lan port connect speed eg. 100 or 1000


RC4 not working correctly on DIR 878 (MT7621). All seemed fine until trying gaming where intermittently (every 10s-2mins) I had massive lag spikes making the game unplayable. I am connected wired.

CPU load and RAM usage are both fine when it happens. I am connected via DHCP from my cable router in modem mode.

Both the kernel and system log seemed unremarkable.

I have not tested previous versions but I have tested the latest snapshot and the issue persists.

I have noticed another person mentioning this on his DIR 878 on this thread, but no further mention of resolution. I have tried with SQM on but it had no effect.

I have had to revert back to stock due to this

After updating from RC3 to RC4, Atheros WDS wireless network bridge stopped working.
Rolled back to RC3, and WDS wireless bridge is working again.
Hardware : Tp-link Archer A7

I've seen this on my Archer C7 v2 as well, sometimes several times an hour, sometimes not for one or two days. I have since disabled Energy Efficient Ethernet (EEE or sometimes also "Green Ethernet") for the port in question on my Archer C7 v2 as well as on my managed switch for the port to which the Archer C7 v2 is connected. This seems to have solved this for me.

Please note, I think EEE is disabled by default on OpenWrt. I always used it on older releases and didn't encounter issues (I might have not noticed them before, though). And left it enabled now on the other ports that don't exhibit this behavior.


I noticed something similar, but with a device where there's not stable release yet. Could you test if the problem is ipv4 only? I checked with tcpdump on WAN but everything looked ok so far, just some missing replies (did not happen before changing from RouterOS or with direct connection to modem).

It does not make any sense that packet loss affects only one protocol and not others. This would be a problem that is not on the network layer, but the physical layer. If the device uses RGMII as the ethernet interface it is likely that the clocks are not adjusted properly which occasionally causes the signals to be misread.

I could be wrong, but I believe packet loss in IPv4 but not IPv6 means there is a software-related problem in upstream devices, not the one with openwrt.

Now to the original problem

Even though you don't see CPU being maxed out, MT7621 is a dual-core device, so it probably will help to install the package irqbalance

DSA VLAN intro

dir-860l (is also MediaTek MT7621AT based) pings flawless so far on command line from LAN to WAN with rc4 using IPv4.
Does your problem show with a repeated ping or other command? Or does it only show in games via UDP traffic?

Has anyone here tried rc4 with the linksys WRT3300?
How did you get in?
(There us a somewhat depressing thread about WiFi disconnectiond in the 'installing and using' section)