OpenWrt 19.07.4 service release

I confirm. Me too, I upgraded with success! :smiley:
Thanks for all devs! :partying_face:

And the "Hardware flow offloading" option seems to be functionnal, even for others interfaces, than LAN. :stuck_out_tongue:

Please keep this discussion on-topic. The ER-X does not have 4g (or any radio) hardware, so this is irrelevant to the 19.07.4 announcement thread.

Thanks for this valuable upgrade. I upgraded two Sitecom WLR-8100 routers from 19.07.3. The one that was configured as router needed it's interface to the fiber (WAN) make a forced connection or it would not connect and I needed to re-install the luci app for SQM (the config was still intact though). The other one is just an extra AP two floors up: no changes needed: upgraded, rebooted and just worked again.

I noticed the 19.07.4 is slightly more memory efficient. And Luci is more responsive, although the latter can also be just my mind wishing that :wink:

Both 19.07.3 and 19.07.4 work great for the Sitecom WLR-8100. I have both hardware revision (v1.001 and v1.002). The PCB's are identical visually, except for the caps (which I replaced by high quality ones btw). So I suggest the WLR-8100 v1.002 it is safe to move this version from snapshot to mainstream stable.

The v1.002 is running as my router and (so far) never needs rebooting because of a software/settings issue.

Keep up the good work!

1 Like

Thank you for great work.

Awesome job guys!

I upgraded my Mikrotik RB750GR3 from 19.07.3 to 19.07.4 with keep settings, but so far it seems to be somewhat unstable. I get random reboots multiple times a day. The previous version easily got up to 40+ days uptime.

I'm seeing the same problem on an Asus RT-N56U wireless router and have appended a little more information to the bug report.

1 Like

My issue is not really the same, my router completely reboots (uptime resets etc).
In the linked bug report the router stays up but drops packets.

1 Like

Yes, I have the same problem "mtk_soc_eth 10100000.ethernet eth0" on my Asus RT-N56U (Ralink RT3883 ver:1 eco:5).

Yes, my Asus RT-N56U (Ralink RT3883 ver:1 eco:5) sometimes reboots and I have no way to refer to the system or kernel logs to troubleshoot the error.

Small correction, uptime resets, but the bootlog times stay the same, it just resets after the whole bootup sequence (everything between bootup and (soft)reboot disappears from system log.
Because the stability of this router is somewhat important to me i decided to revert to 19.07.3 for now.
The hangs / crashes / reboots are very visible on my memory statistics charts.

Upgraded Linksys EA8500 from .3 to .4, noticing some wifi drops and LAN drops... other than that all ok

In Open Source this aproach is commen

"Its ready when its ready"

I updated my EdgeRouter X without any problems.

4 posts were split to a new topic: Why should I update from 15.05 to 19.07?

I upgraded my Linksys EA4500 v1 from 19.07.3 to 19.07.4 and it works perfectly.

I upgraded my TPLink VR200 from 19.07.3 to 19.07.4 and looks the same. Everything works as expected :relaxed:

Btw, MediaTek MT76x0e has been giving error, But not so important It was giving error at old stable one.
One of the guy tries snapshot r14418-d0f295837a and looks good 5 Ghz at this snapshot . MT7610E drive installation to VR200, Deck works
Stable releases comes so frequent. I think It ll come in next 6 month. You know I need Luci :smile:

Nothing notable to report here in upgrading the WNDRMACv2 (using WNDR3800, ath79) from .3 to .4.

1 Like

hi. why is the size of the image sections from the upload page different from, the size of my own image? for x86_64 target, pc engines apu2.

Was b1300 vlan problem fixed in this release

Ftrizbox 4040, from 19.07.3 to .4, first attempted with "keep settings".
After fixing the missing packages using, I still have one BIG issue: the wired ports do not work, the TX counter shows traffic but all RX counters stay at 0.

My switch was split in 3 segments and the ports in the old config were listed in descending order; the new version likes them better in ascending order, but I don't think that is the issue here: I removed the network config, let the boot process generate a platform default, saw the different ordering, fixed it in my older config and rebooted again. Still no RX traffic.

I'm going to try with the default switch configuration and then revert to .3, else my NAS and destkop won't be pleased.

EDIT: started from a clean network config on .4, added one VLAN (named 101) and GUI rolls back the config. If I do the config from serial console, I can see there is no RX traffic after restarting network config to apply switch config.

TLDR: do NOT update to 19.07.4 if you have a 4040 (and possibly any ipq40xx device) and you need to split the switch. I am writing this after going back to .3 which works just fine. I'll update this post if new info comes up.
Most likely this is the reason

to the mods: feel free to break this post out of the thread if it makes sense.