OpenWrt 19.07.4 service release

mimini works bad:

Fri Sep 11 17:07:46 2020 kern.err kernel: [ 6615.438086] mtk_soc_eth 10100000.ethernet eth0: transmit timed out
Fri Sep 11 17:07:46 2020 kern.info kernel: [ 6615.444416] mtk_soc_eth 10100000.ethernet eth0: dma_cfg:80000065
Fri Sep 11 17:07:46 2020 kern.info kernel: [ 6615.450586] mtk_soc_eth 10100000.ethernet eth0: tx_ring=0, base=07780000, max=1024, ctx=17, dtx=17, fdx=16, next=17
Fri Sep 11 17:07:46 2020 kern.info kernel: [ 6615.461258] mtk_soc_eth 10100000.ethernet eth0: rx_ring=0, base=06408000, max=1024, calc=47, drx=48
Fri Sep 11 17:07:56 2020 kern.err kernel: [ 6619.306350] mtk_soc_eth 10100000.ethernet eth0: transmit timed out
Fri Sep 11 17:07:56 2020 kern.info kernel: [ 6619.312684] mtk_soc_eth 10100000.ethernet eth0: dma_cfg:80000065
Fri Sep 11 17:07:56 2020 kern.info kernel: [ 6619.318854] mtk_soc_eth 10100000.ethernet eth0: tx_ring=0, base=07780000, max=1024, ctx=28, dtx=28, fdx=16, next=28
Fri Sep 11 17:07:56 2020 kern.info kernel: [ 6619.329525] mtk_soc_eth 10100000.ethernet eth0: rx_ring=0, base=06470000, max=1024, calc=63, drx=64
Fri Sep 11 17:08:06 2020 kern.err kernel: [ 6623.157217] mtk_soc_eth 10100000.ethernet eth0: transmit timed out
Fri Sep 11 17:08:06 2020 kern.info kernel: [ 6623.163553] mtk_soc_eth 10100000.ethernet eth0: dma_cfg:80000065
Fri Sep 11 17:08:06 2020 kern.info kernel: [ 6623.169720] mtk_soc_eth 10100000.ethernet eth0: tx_ring=0, base=07780000, max=1024, ctx=25, dtx=25, fdx=16, next=25
Fri Sep 11 17:08:06 2020 kern.info kernel: [ 6623.180398] mtk_soc_eth 10100000.ethernet eth0: rx_ring=0, base=06408000, max=1024, calc=59, drx=60

19.07.03 worked fine, looks like I need to downgrade

1 Like

Solved my problems:

Thanks a lot to the hard working OpenWRT team :muscle:

Downgrade to 19.07.3 and it works fine. The issue is packet loss.

1 Like

There seems to be a bug report about it (maybe opened by you actually).

Me, yep, I'll try to revert it.

Hi
I just Loaded "stable" ATH79 19.07.04 sysupgrade build into a TP-LINK tl-wdr3600 previously running ATH78 19.07.03 without issues just a few minutes ago. So far so good. Will push some traffic through it and see if it's solid.

Big thanks once again to the OPENWRT team for the great work.

Can I upgrade from 19.07.2 or .3 without resetting all the settings?

1 Like

I upgraded my Linksys WRT3200ACM from 19.07.3 to 19.07.4 and reinstalled my extra packages. Smooth upgrade, no issues at all.

Thank you to all of the developers and testers at OpenWrt for making this happen!

It worked fine for me. If you installed any non-default packages such as external disk support, you'll need to install them again. But once you do that, they pretty much all just start up running again since their configuration files are all carried over with the upgrade process.

At least that's been my experience.

See here for results confimed by others.

Upgraded TP-Link C2600 to 19.07.4. Until now only one problem I have, is that my chromecast has difficulties to connect and maintain connection

Sorry don't chromecast. It might be better if you post a new topic?

I've not had any wireless issues since the upgrade, mind you I've not experienced any yet (it's only been just over 1 day on 19.07.4) :wink:

Weak wifi signal on WNDR3700 v1 in previous version (see other post) is solved in OPENWRT_19.07.4-ath79. Now an excellent wifi signal strenght in 2.4Ghz and 5Ghz bands.
Thanks!. All other functions that I use in my custom build like Wireguard, OpenVPN, Adblock, DynamicDNS, Wifi Schedule, Wake on LAN, Network Shares, SQM QoS, LED configuration, BandWith Monitor and uHTTPd work perfect!
I could upgrade from OPENWRT_19.07.3-ar71xx to OPENWRT_19.07.4-ath79 while I could not upgrade to OPENWRT_19.07.4-ar71xx, but in my case ath79 was the route to go anyway. :grinning:

Many Thanks to all volunteers working on OpenWRT. what a perfect piece of open source sofware with high quality. :clap:

I have upgraded my HomeHub 5.0 from 19.07.3 to 19.07.4 and my ac WiFi radio stopped working completely.
On Luci it says Qualcomm Atheros QCA9880 802.11nac “Device is not active”. Restarting it does not change the status
Edit: installing wpad-openssl fixed it

Just upgraded Linksys MR8300 to 19.07.4 using EA8300 factory.bin. I used Advanced Reboot https://github.com/openwrt/luci/blob/master/applications/luci-app-advanced-reboot/README.md, thanks to Flashing OpenWrt on Linksys MR8300 - partially bricked, luci module to boot back into OEM partition and reinstalled factory.bin with http://routeripaddress/fwupdate.html web firmware uploader and reconfigured once rebooted.
All is working fine !
Many thanks to Dev Team !

Edit: Also upgraded Linksys EA8300, booted from OEM partition, upgraded with factory.bin, reconfigured, all is fine.

Upgraded EdgeRouter X to 19.07.4 from 19.07.3 with keep settings. No issues after 3 days of run time as the home network gateway taking care of SQM; Adblock; DHCP for LAN, Guest and IOT VLANs; and two wired AP's.

Thank you Developers!

1 Like

What is the max speed can you achieve with SQM?

EdgeRouter X running OpenWrt 19.07.4 with layer CAKE SQM, ECN "on" for both ingress and egress; Ethernet with 22 Byte per packet overhead link layer adaption; DOCSIS 3.0 cable ISP:
image

Edit - for completeness, this is what I get without SQM:
image

3 Likes

Just upgraded my Linksys WRT1200AC from .3 to .4 and everything works fine. It also fixed the ability to reboot from Luci where in .3 it often had issues. Now it's perfect. Keep up the awesome job Devs!!!

Congrats on the release. Running well on my Meraki MR33 which is running as an AP on the network.