Problems opening LUKS-devices on APU (x86) running latest version of OpenWrt

I have some problems after upgrading from OpenWRT 18.06.4 to OpenWRT 19.07.3 on my PC engines APU2 device :frowning:

I have tried with two different USB/LUKS encrypted storage devices, when trying to open them with
cryptsetup --debug luksOpen /dev/sdb test

It freezes after:
#Trying to open key slot 0 [ACTIVE_LAST]

I got no more messages or errors, I have also tried with --verbose

If i take the same USB storage devices in can unencrypt them with the same command on a TP-link Archer C7 device running OpenWRT 19.07.3 it totally works...? I have checked and its the same version of cryptsetup and more or less the same kmod-crypto-X modules installed :thinking:

Not a solution, but maybe it puts you on the right track: I would make sure that on your APU2, you use the correct device (/dev/sdb is right?). Is there a different key slot that maybe the C7 uses (instead of slot 0 on the APU2)? Maybe slot 0 is broken and causes a crash, while you set up another slot as well.

Hmm, I think I am using slot 0 on both devices๐Ÿค”

For sure I will try it later today๐Ÿ‘๐Ÿป

Now I have upgraded to 19.07.4 - guess what... It just works :ok_hand:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.