MT7610E drive installation to VR200, Deck works

I've seen this topic now.

@slh Could you explain, How can I able to enable 5 GHz? Is there any way?

Apropos 5G I can not prompt did not check
Has left the factory software

Okay, Thanks for answer :slight_smile:

I have WiFi 5GHz working on VR200 using the latest snapshot build (r14418-d0f295837a) - assume this is thanks to the work of Kevin Schmidt and Hauke Mehrtens. Not sure when this will be in a stable release though, hopefully the next one?

I hope so, using OpenWrt 19.07.3 r11063-85e04e9f46 version. Did u update via system > software > updates.
I did via the above way but Luci interface freezed badly then had to soft reset. Due to I am staying a little bit away from this way :blush:
btw could you share status of mt76x0e at system log

I installed from TFTP via the bootloader / UART header, then had to install LuCI manually as it's not in the snapshot builds.

Status of mt76x0e from dmesg (Kernel Log):

[   15.226924] mt76x0e 0000:02:00.0: enabling device (0000 -> 0002)
[   15.233219] mt76x0e 0000:02:00.0: ASIC revision: 76100002
[   15.243342] mt76x0e 0000:02:00.0: Firmware Version: 0.1.00
[   15.479249] mt76x0e 0000:02:00.0: EEPROM ver:01 fae:00
1 Like

There is a new update on routers page; I updated to new version
OpenWrt 19.07.3 r11063-85e04e9f46 -->
OpenWrt 19.07.4 r11208-ce6496d796
and mannually were installed mt76x0e but I getting same error

It seems to wait next uptate

I install below programs on latest 19.07.07 release but any wifi doesn't occurred under Network tab

opkg update
opkg install kmod-mt76x0e wpad-mini pciutils
reboot

OpenWrt 19.07.7 r11306-c4a6851c72 / LuCI openwrt-19.07 branch git-21.044.30835-34e0d65
what have to additionally?

@sc84647 Sorry for interruption but I have to ask where u get the latest snapshot's version.
Could u explain more clearly?

Because, I installed below packages but still I don't have wireless tab on Luci interface.
How did u enable wireless module.

https://downloads.openwrt.org/snapshots/

1 Like

Thank you, I'll try

Hi, were you able to solve the issue with 5G driver?

I didn't try this snapshot yet. But whenever go family home I'll try.
Former snapshot (RC-2) works, but sometimes lost connection. Maybe this release(RC-3) will be solved.

Thanks.. I will try as well.

Update: I tried with the above snapshot, and like usual all i get is the same old error.

Sun Jun 13 22:02:27 2021 kern.err kernel: [    9.984738] mt76x0e 0000:01:00.0: card - bus=0x1, slot = 0x0 irq=4
Sun Jun 13 22:02:27 2021 kern.info kernel: [    9.991398] mt76x0e 0000:01:00.0: ASIC revision: 76100002
Sun Jun 13 22:02:27 2021 kern.info kernel: [   10.014797] mt76x0e 0000:01:00.0: Firmware Version: 0.1.00
Sun Jun 13 22:02:27 2021 user.err kernel: [   10.107464] urngd: jent-rng init failed, err: 2
Sun Jun 13 22:02:27 2021 kern.err kernel: [   10.160894] mt76x0e 0000:01:00.0: EEPROM data check failed: 7662
Sun Jun 13 22:02:27 2021 kern.err kernel: [   10.179491] mt76x0e 0000:01:00.0: driver does not support default EEPROM
Sun Jun 13 22:02:27 2021 kern.warn kernel: [   10.186559] mt76x0e: probe of 0000:01:00.0 failed with error -22

These messages means that "radio" partition at offset 0 contain incorrect EEPROM data. It's possible that it contain EEPROM for mt7662 wifi chipset.
Just for test you can backup radio partition and write any mt7610 refferance eeprom data from Mediatek SDK.
You can get eeprom from Padavan project

Thanks for your reply, first of all my device is Tp link archer c20 v1, 2.4ghz works fine only 5ghz radio is not showing up under wireless.
I backed up the radio. Which eeprom should i write?, i believe i need to write for mt7610e, which is the chip for 5ghz. there are two files available on the link above MT7610E-V10-FEM.bin and MT7612E_EEPROM.bin, which one should i try?

mt7610 and mt7612 are different wifi chipsets so only MT7610E-V10-FEM.bin suit you.
And for tp-link archer c20 v1 EEPROM offset is 0x8000

OK thanks, so just to be clear, i need to replace radio.bin(backed up) with MT7610E-V10-FEM.bin file correct? and start writing at offset 0x8000... is that right?

You need to overwrite data of radio partition at position 0x8000 with data of MT7610E-V10-FEM.bin file. In unix command line it may be done as follow:

dd if=MT7610E-V10-FEM.bin of=radio.bin bs=1 seek=$((0x8000)) conv=notrunc

where radio.bin is backup copy of radio partition.
Then write this new radio.bin file back to flash. To unlock read only radio partition use kmod-mtd-rw package. Something like:

opkg update
opkg install kmod-mtd-rw
insmod mtd-rw i_want_a_brick=1
mtd unlock radio
mtd write radio.bin radio

After reboot mt7610 driver will read correct EEPROM.

1 Like

I did the above, ran the commands, verified it with hex editor.. and after flashing the modified radio... 5Ghz lives.

Thu Jul  1 08:23:35 2021 kern.err kernel: [   15.242503] mt76x0e 0000:01:00.0: card - bus=0x1, slot = 0x0 irq=4
Thu Jul  1 08:23:35 2021 kern.info kernel: [   15.249059] mt76x0e 0000:01:00.0: ASIC revision: 76100002
Thu Jul  1 08:23:35 2021 kern.info kernel: [   15.301321] mt76x0e 0000:01:00.0: Firmware Version: 0.1.00
Thu Jul  1 08:23:35 2021 kern.info kernel: [   15.392138] mt76x0e 0000:01:00.0: EEPROM ver:01 fae:00

Haven't tested it much aside from noticing the transmit power being only 6 dBm. Will discuss it more once i test it further.

I have one little confusion, now that i have modified the radio partition, do i have to start the whole process (flashing modified radio partition) again, if i install a different version of openwrt or go back to stock firmware?

Thanks a lot for the help.

1 Like