OpenWrt 19.07.4 service release

Upgraded Linksys EA8500 from .3 to .4, noticing some wifi drops and LAN drops... other than that all ok

In Open Source this aproach is commen

"Its ready when its ready"

I updated my EdgeRouter X without any problems.

4 posts were split to a new topic: Why should I update from 15.05 to 19.07?

I upgraded my Linksys EA4500 v1 from 19.07.3 to 19.07.4 and it works perfectly.

I upgraded my TPLink VR200 from 19.07.3 to 19.07.4 and looks the same. Everything works as expected :relaxed:

Btw, MediaTek MT76x0e has been giving error, But not so important It was giving error at old stable one.
One of the guy tries snapshot r14418-d0f295837a and looks good 5 Ghz at this snapshot . MT7610E drive installation to VR200, Deck works
Stable releases comes so frequent. I think It ll come in next 6 month. You know I need Luci :smile:

Nothing notable to report here in upgrading the WNDRMACv2 (using WNDR3800, ath79) from .3 to .4.

1 Like

hi. why is the size of the image sections from the upload page different from, the size of my own image? for x86_64 target, pc engines apu2.

Was Gi.net b1300 vlan problem fixed in this release

Ftrizbox 4040, from 19.07.3 to .4, first attempted with "keep settings".
After fixing the missing packages using opkgscript.sh, I still have one BIG issue: the wired ports do not work, the TX counter shows traffic but all RX counters stay at 0.

My switch was split in 3 segments and the ports in the old config were listed in descending order; the new version likes them better in ascending order, but I don't think that is the issue here: I removed the network config, let the boot process generate a platform default, saw the different ordering, fixed it in my older config and rebooted again. Still no RX traffic.

I'm going to try with the default switch configuration and then revert to .3, else my NAS and destkop won't be pleased.

EDIT: started from a clean network config on .4, added one VLAN (named 101) and GUI rolls back the config. If I do the config from serial console, I can see there is no RX traffic after restarting network config to apply switch config.

TLDR: do NOT update to 19.07.4 if you have a 4040 (and possibly any ipq40xx device) and you need to split the switch. I am writing this after going back to .3 which works just fine. I'll update this post if new info comes up.
Most likely this is the reason

to the mods: feel free to break this post out of the thread if it makes sense.

Thanks aboaboit! It is quite a pitty that OpenWRT was released without taking into account ipq40xx devices and fixing vlan tagging.

Now we need another service release.

1 Like

Router is spontaneously rebooting after .4 update. I just noticed somewhere on openwrt.org that I wasn't supposed to do the update from the NetGear webui, but rather use a program Linux program to flash. I thought "aha!", and reflashed latest Netgear firmware and then Openwrt fw.

Still rebooting spontaneously.

FWIW, my affected device is a NetGear R6120.

Probably doesn't matter, but just in case, I'll mention that I am 1 of 4 renters living in this home. I have split the 4 Ethernet ports into 4 different segments. While there is no firewall between them, I have all 4 LAN ports split into 4 different IP address subnets, each with its own DHCP server settings, etc. WiFi is Bridged to the 1st LAN port, and the other 3 have a separate APs at the other end of their respective Ethernet runs. I have had to completely take down my Netgear router, and put back up my backup router.

No issues upgrading 5 routers (4 remotely):

WRT1900ACS
2x Archer C7 v2
WDR3600
WDR3500

I'd like if the sysupgrade options "-u" and "-k" were added to LuCI as well.
Also, /etc/rc.d/* symlinks deletions are not preserved across upgrades. On some routers, I disabled dnsmasq and odhcpd. I have to do it again after each upgrade, and reinstall packages. If there was an automatic package re-installation feature, a minor upgrade like this would be transparent to me.

thanks for the good work

5 posts were split to a new topic: Automatic update script

Hi All, upgrading from a 19.07.3 I to 07.4 I'm getting this message:


The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

device is indeed a xiaomi mini, file is miwifi-mini-squashfs-sysupgrade.bin , checksums match.

Should I just cross my fingers and force (-F) the upgrade ?

Rock solid for 14 days on my Netgear R7800. :+1:

My issue was related to firewall hardware offloading, disabling it fixed the stability issue

Replying to my own question: yes, you can safely force update the 19.07.4 image.
AFAIK someone omitted 'xiaomi' somewhere, but otherwise 19.07.4 is running fine.

Flashed a snapshot update, and the device rebooted maybe 2 more times, but has now been up almost 7 days straight. For some reason, when I flashed the snapshot, LuCI stopped working, and I had to ssh in and install the packages. (I'm just glad I re-enabled dropbear before doing the update). Everything seems to be great now. Thank you to the devs at OpenWRT.

I have a question regarding the .4 update. If this is the wrong place to ask, well, mods don't really need my permission to move it... :grin:

Anywho, I noticed there is no update link for my Netgear R7900. Is this an oversight, or is there some reason why I can't or shouldn't update it directly from .3 to .4?